summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2005-09-06 07:46:04 +0000
committerStuart Herbert <stuart@gentoo.org>2005-09-06 07:46:04 +0000
commita24bb2e6f1a20959e73c20fb698fa976c79a6851 (patch)
treedd47241b4c3c6ab11179a55be49cfb401591d98d /dev-php5/pecl-pdflib
parentRemoved corrupted patch file (diff)
downloadgentoo-2-a24bb2e6f1a20959e73c20fb698fa976c79a6851.tar.gz
gentoo-2-a24bb2e6f1a20959e73c20fb698fa976c79a6851.tar.bz2
gentoo-2-a24bb2e6f1a20959e73c20fb698fa976c79a6851.zip
Replaced corrupted patch file
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-php5/pecl-pdflib')
-rw-r--r--dev-php5/pecl-pdflib/ChangeLog5
-rw-r--r--dev-php5/pecl-pdflib/Manifest2
-rw-r--r--dev-php5/pecl-pdflib/files/ifgd-patch.diff209
3 files changed, 214 insertions, 2 deletions
diff --git a/dev-php5/pecl-pdflib/ChangeLog b/dev-php5/pecl-pdflib/ChangeLog
index a99df8f01476..0929e62169f2 100644
--- a/dev-php5/pecl-pdflib/ChangeLog
+++ b/dev-php5/pecl-pdflib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-php5/pecl-pdflib
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdflib/ChangeLog,v 1.1 2005/09/04 16:31:34 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdflib/ChangeLog,v 1.2 2005/09/06 07:41:37 stuart Exp $
+
+ 06 Sep 2005; Stuart Herbert <stuart@gentoo.org> +files/ifgd-patch.diff:
+ Replaced corrupted patch file
18 Aug 2005; <stuart@gentoo.org> ChangeLog:
Initial version; replaces older dev-php/* packages
diff --git a/dev-php5/pecl-pdflib/Manifest b/dev-php5/pecl-pdflib/Manifest
index cdf704b461fb..7faa1c944b2f 100644
--- a/dev-php5/pecl-pdflib/Manifest
+++ b/dev-php5/pecl-pdflib/Manifest
@@ -2,4 +2,4 @@ MD5 c58d07ca1c1235bbad9bccaec96fc062 metadata.xml 157
MD5 139b2018482e17bb2300bd728b49cabc ChangeLog 313
MD5 d0359a6bba3de589b12ddbf77ee1cdcf pecl-pdflib-2.0.4-r1.ebuild 638
MD5 1ffaf58e4d052d47b48b8490ca92efaf files/digest-pecl-pdflib-2.0.4-r1 60
-MD5 9d45d39010dcbd7504fcba35273cadde files/ifgd-patch.diff 5891
+MD5 f1d1195704d3132b7878446eba109903 files/ifgd-patch.diff 5798
diff --git a/dev-php5/pecl-pdflib/files/ifgd-patch.diff b/dev-php5/pecl-pdflib/files/ifgd-patch.diff
new file mode 100644
index 000000000000..824bbd2298d0
--- /dev/null
+++ b/dev-php5/pecl-pdflib/files/ifgd-patch.diff
@@ -0,0 +1,209 @@
+--- pdf.c 2005-08-02 17:43:36.000000000 +0200
++++ pdf.c 2005-08-02 17:45:33.000000000 +0200
+@@ -17,12 +17,12 @@
+ +----------------------------------------------------------------------+
+ */
+
+-/* $Id: pdf.c,v 1.143 2004/11/30 11:42:13 rjs Exp $ */
++/* $Id: pdf.c,v 1.144 2005/03/08 12:02:19 rjs Exp $ */
+
+ /* {{{ Comments about the module */
+
+ /* derived from:
+- $Id: pdf.c,v 1.143 2004/11/30 11:42:13 rjs Exp $
++ $Id: pdf.c,v 1.144 2005/03/08 12:02:19 rjs Exp $
+ synced with pdflib.h 1.237 */
+
+ /* PDFlib 2.02 ... 4.0.x is subject to the ALADDIN FREE PUBLIC LICENSE.
+@@ -63,8 +63,12 @@
+
+ /* Bootstrap of PDFlib Feature setup */
+ #define PDF_FEATURE_INTERNAL
++#define PDFLIB_PECL_VERSIONSTRING "2.0.4-r1"
+
+-#define PDFLIB_PECL_VERSIONSTRING "2.0.3"
++/* set this define if you want to include GD support
++ * this adds the (unofficial) function pdf_open_memory_image()
++#define PDFLIB_WITH_GD_SUPPORT
++*/
+
+ /* }}} */
+
+@@ -87,6 +91,7 @@
+ # include "Zend/zend_exceptions.h"
+ #endif /* PHP_MAJOR_VERSION >= 5 */
+
++#if PDFLIB_WITH_GD_SUPPORT
+ #if HAVE_LIBGD13
+ # include "ext/gd/php_gd.h"
+ # if HAVE_GD_BUNDLED
+@@ -96,6 +101,7 @@
+ # endif /* HAVE_GD_BUNDLED */
+ static int le_gd;
+ #endif /* HAVE_LIBGD13 */
++#endif /* PDFLIB_WITH_GD_SUPPORT */
+
+ #ifdef HAVE_UNISTD_H
+ # include <unistd.h>
+@@ -299,10 +305,12 @@
+
+ /* End of the official PDFLIB API */
+
++#if PDFLIB_WITH_GD_SUPPORT
+ #if HAVE_LIBGD13
+ /* not supported by PDFlib GmbH */
+ PHP_FE(pdf_open_memory_image, NULL)
+ #endif /* HAVE_LIBGD13 */
++#endif /* PDFLIB_WITH_GD_SUPPORT */
+
+ {NULL, NULL, NULL}
+ };
+@@ -491,10 +499,12 @@
+
+ /* End of the official PDFLIB API */
+
++#if PDFLIB_WITH_GD_SUPPORT
+ #if HAVE_LIBGD13
+ /* not supported by PDFlib GmbH */
+ /* PHP_ME_MAPPING(open_memory_image, pdf_open_memory_image, NULL) */
+ #endif /* HAVE_LIBGD13 */
++#endif /* PDFLIB_WITH_GD_SUPPORT */
+
+ {NULL, NULL, NULL}
+ };
+@@ -768,7 +778,7 @@
+ php_info_print_table_row(2, "PDF Support", "enabled" );
+ php_info_print_table_row(2, "PDFlib GmbH Version", PDFLIB_VERSIONSTRING );
+ php_info_print_table_row(2, "PECL Version", PDFLIB_PECL_VERSIONSTRING);
+- php_info_print_table_row(2, "Revision", "$Revision: 1.143 $" );
++ php_info_print_table_row(2, "Revision", "$Revision: 1.144 $" );
+ php_info_print_table_end();
+
+ }
+@@ -7197,6 +7207,7 @@
+
+
+
++#if PDFLIB_WITH_GD_SUPPORT
+ #if HAVE_LIBGD13
+ /* {{{ proto int pdf_open_memory_image(resource p, int image)
+ Takes an GD image and returns an image for placement in a PDF document */
+@@ -7276,6 +7287,7 @@
+ }
+ /* }}} */
+ #endif /* HAVE_LIBGD13 */
++#endif /* PDFLIB_WITH_GD_SUPPORT */
+
+ #else /* PDFLIB_MAJORVERSION < 5 */
+ /* use the old wrapper for PDFlib 4 and earlier */
+--- pdf4.c 2005-08-02 17:43:43.000000000 +0200
++++ pdf4.c 2005-08-02 17:47:52.000000000 +0200
+@@ -17,7 +17,7 @@
+ +----------------------------------------------------------------------+
+ */
+
+-/* $Id: pdf4.c,v 1.2 2004/11/30 11:42:13 rjs Exp $ */
++/* $Id: pdf4.c,v 1.4 2005/07/08 06:22:03 steinm Exp $ */
+
+ /* pdflib 2.02 ... 3.0x is subject to the ALADDIN FREE PUBLIC LICENSE.
+ Copyright (C) 1997-1999 Thomas Merz. 2000-2001 PDFlib GmbH */
+@@ -40,6 +40,7 @@
+ #include "ext/standard/file.h"
+ #include "php_streams.h"
+
++#if PDFLIB_WITH_GD_SUPPORT
+ #if HAVE_LIBGD13
+ #include "ext/gd/php_gd.h"
+ #if HAVE_GD_BUNDLED
+@@ -49,6 +50,7 @@
+ #endif
+ static int le_gd;
+ #endif
++#endif / * PDFLIB_WITH_GD_SUPPORT * /
+
+ #ifdef HAVE_UNISTD_H
+ # include <unistd.h>
+@@ -187,9 +189,11 @@
+
+ /* some more stuff for compatibility */
+ PHP_FE(pdf_add_annotation, NULL)
++#if PDFLIB_WITH_GD_SUPPORT
+ #if HAVE_LIBGD13
+ PHP_FE(pdf_open_memory_image, NULL)
+ #endif
++#endif
+ /* depreciatet after V4.0 of PDFlib */
+ PHP_FE(pdf_setgray_fill, NULL)
+ PHP_FE(pdf_setgray_stroke, NULL)
+@@ -334,7 +338,7 @@
+ #else
+ php_info_print_table_row(2, "PDFlib GmbH Version", tmp );
+ #endif
+- php_info_print_table_row(2, "Revision", "$Revision: 1.2 $" );
++ php_info_print_table_row(2, "Revision", "$Revision: 1.4 $" );
+ php_info_print_table_end();
+
+ }
+@@ -1949,6 +1953,7 @@
+ }
+ /* }}} */
+
++#if PDFLIB_WITH_GD_SUPPORT
+ #if HAVE_LIBGD13
+ /* {{{ proto int pdf_open_memory_image(int pdf, int image)
+ Takes an GD image and returns an image for placement in a PDF document */
+@@ -2015,6 +2020,7 @@
+ }
+ /* }}} */
+ #endif /* HAVE_LIBGD13 */
++#endif /* PDFLIB_WITH_GD_SUPPORT */
+
+ /* {{{ proto void pdf_close_image(int pdf, int pdfimage)
+ Closes the PDF image */
+--- php_pdf.h 2005-08-02 17:44:20.000000000 +0200
++++ php_pdf.h 2005-08-02 17:49:15.000000000 +0200
+@@ -16,7 +16,7 @@
+ +----------------------------------------------------------------------+
+ */
+
+-/* $Id: php_pdf.h,v 1.30 2004/11/30 11:42:13 rjs Exp $ */
++/* $Id: php_pdf.h,v 1.31 2005/03/08 12:02:19 rjs Exp $ */
+ /* Derived from:
+ Id: php_pdf.h,v 1.22 2001/11/30 04:46:35 sniper Exp */
+
+@@ -201,10 +201,12 @@
+ #endif /* PDFlib >= 6.0.0 */
+
+
++#if PDFLIB_WITH_GD_SUPPORT
+ #if HAVE_LIBGD13
+ /* not supported by PDFlib GmbH */
+ PHP_FUNCTION(pdf_open_memory_image);
+ #endif
++#endif /* PDFLIB_WITH_GD_SUPPORT */
+
+ #ifdef ZTS
+ #define PDFG(v) TSRMG(pdf_globals_id, php_pdf_globals *, v)
+--- php_pdf4.h 2005-08-02 17:44:26.000000000 +0200
++++ php_pdf4.h 2005-08-02 17:50:39.000000000 +0200
+@@ -16,7 +16,7 @@
+ +----------------------------------------------------------------------+
+ */
+
+-/* $Id: php_pdf4.h,v 1.2 2004/11/30 11:42:13 rjs Exp $ */
++/* $Id: php_pdf4.h,v 1.3 2005/03/08 12:02:20 rjs Exp $ */
+
+ #ifndef PHP_PDF_H
+ #define PHP_PDF_H
+@@ -140,9 +140,11 @@
+
+ /* some more stuff for compatibility */
+ PHP_FUNCTION(pdf_add_annotation);
++#if PDFLIB_WITH_GD_SUPPORT
+ #if HAVE_LIBGD13
+ PHP_FUNCTION(pdf_open_memory_image);
+ #endif
++#endif /* PDFLIB_WITH_GD_SUPPORT */
+
+ #if (PDFLIB_MAJORVERSION >= 4)
+ /* support for new functions in PDFlib V4.0 */