summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-08-27 10:13:12 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-08-27 10:13:12 +0000
commite46af7fff1ec3ce21b01f0edc340ccc3357170ae (patch)
treec4ba2670efefe1ab9ba27c6ddcd1b38980e132f3 /dev-php5/pecl-http
parentVersion bump. (diff)
downloadgentoo-2-e46af7fff1ec3ce21b01f0edc340ccc3357170ae.tar.gz
gentoo-2-e46af7fff1ec3ce21b01f0edc340ccc3357170ae.tar.bz2
gentoo-2-e46af7fff1ec3ce21b01f0edc340ccc3357170ae.zip
version bump for bug #190381
(Portage version: 2.1.3.6)
Diffstat (limited to 'dev-php5/pecl-http')
-rw-r--r--dev-php5/pecl-http/ChangeLog11
-rw-r--r--dev-php5/pecl-http/files/digest-pecl-http-1.5.43
-rw-r--r--dev-php5/pecl-http/pecl-http-1.5.4.ebuild39
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-php5/pecl-http/ChangeLog b/dev-php5/pecl-http/ChangeLog
index fda88bb5a4f0..14b1e6046877 100644
--- a/dev-php5/pecl-http/ChangeLog
+++ b/dev-php5/pecl-http/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-php5/pecl-http
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/ChangeLog,v 1.4 2007/03/17 23:55:14 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/ChangeLog,v 1.5 2007/08/27 10:13:12 jokey Exp $
+
+*pecl-http-1.5.4 (27 Aug 2007)
+
+ 27 Aug 2007; Markus Ullmann <jokey@gentoo.org> +pecl-http-1.5.4.ebuild:
+ version bump for bug #190381
+
+ 27 Aug 2007; Jakub Moc <jakub@gentoo.org> +metadata.xml,
+ +pecl-http-1.5.4.ebuild:
+ Version bump, Bug 190381
*pecl-http-1.5.2 (17 Mar 2007)
diff --git a/dev-php5/pecl-http/files/digest-pecl-http-1.5.4 b/dev-php5/pecl-http/files/digest-pecl-http-1.5.4
new file mode 100644
index 000000000000..b6dad8bd551e
--- /dev/null
+++ b/dev-php5/pecl-http/files/digest-pecl-http-1.5.4
@@ -0,0 +1,3 @@
+MD5 b2e5440d2d2ae8c260594d2230f0a6d2 pecl_http-1.5.4.tgz 168091
+RMD160 e3698afac63d4a292ffc5a091cd09de9b08f40b5 pecl_http-1.5.4.tgz 168091
+SHA256 7dcab683935616d25dba8e77edbd526a19f200ea3d3d84e09d9869abdb41f526 pecl_http-1.5.4.tgz 168091
diff --git a/dev-php5/pecl-http/pecl-http-1.5.4.ebuild b/dev-php5/pecl-http/pecl-http-1.5.4.ebuild
new file mode 100644
index 000000000000..266bf01ee418
--- /dev/null
+++ b/dev-php5/pecl-http/pecl-http-1.5.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/pecl-http-1.5.4.ebuild,v 1.1 2007/08/27 10:13:12 jokey Exp $
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="net-misc/curl
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+src_compile() {
+ my_conf="--enable-http \
+ --with-http-curl-requests \
+ --with-http-zlib-compression"
+
+ php-ext-pecl-r1_src_compile
+}
+
+pkg_postinst() {
+ has_php
+ if ! built_with_use --missing true =${PHP_PKG} spl session hash iconv ; then
+ elog "${PN} can optionally use spl, session, hash and iconv features."
+ elog "If you want those, recompile ${PHP_PKG} with those flags in USE."
+ fi
+}