summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-11-04 13:41:07 +0000
committerMatti Bickel <mabi@gentoo.org>2010-11-04 13:41:07 +0000
commitd2b26532d96474d4b0bfc8b1088daec151dacac6 (patch)
tree16012304bb71f866fca25952c3755515f87b5330 /dev-php5/pecl-http
parentold (diff)
downloadgentoo-2-d2b26532d96474d4b0bfc8b1088daec151dacac6.tar.gz
gentoo-2-d2b26532d96474d4b0bfc8b1088daec151dacac6.tar.bz2
gentoo-2-d2b26532d96474d4b0bfc8b1088daec151dacac6.zip
add version that supports minor version slotting, version bump, cleanup
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/pecl-http')
-rw-r--r--dev-php5/pecl-http/ChangeLog9
-rw-r--r--dev-php5/pecl-http/pecl-http-1.7.0-r1.ebuild60
-rw-r--r--dev-php5/pecl-http/pecl-http-1.7.0.ebuild (renamed from dev-php5/pecl-http/pecl-http-1.6.0.ebuild)25
3 files changed, 78 insertions, 16 deletions
diff --git a/dev-php5/pecl-http/ChangeLog b/dev-php5/pecl-http/ChangeLog
index 8fed348881cd..477091b19bfe 100644
--- a/dev-php5/pecl-http/ChangeLog
+++ b/dev-php5/pecl-http/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-php5/pecl-http
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/ChangeLog,v 1.15 2010/10/20 14:20:56 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/ChangeLog,v 1.16 2010/11/04 13:41:07 mabi Exp $
+
+*pecl-http-1.7.0-r1 (04 Nov 2010)
+*pecl-http-1.7.0 (04 Nov 2010)
+
+ 04 Nov 2010; Matti Bickel <mabi@gentoo.org> -pecl-http-1.6.0.ebuild,
+ +pecl-http-1.7.0.ebuild, +pecl-http-1.7.0-r1.ebuild:
+ add version that supports minor version slotting, version bump, cleanup
20 Oct 2010; Markos Chandras <hwoarang@gentoo.org> pecl-http-1.6.6.ebuild:
Stable on amd64 wrt bug #336869
diff --git a/dev-php5/pecl-http/pecl-http-1.7.0-r1.ebuild b/dev-php5/pecl-http/pecl-http-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..721ceed29142
--- /dev/null
+++ b/dev-php5/pecl-http/pecl-http-1.7.0-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/pecl-http-1.7.0-r1.ebuild,v 1.1 2010/11/04 13:41:07 mabi Exp $
+
+EAPI="3"
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="docs/examples/tutorial.txt ThanksTo.txt KnownIssues.txt"
+
+inherit php-ext-pecl-r2 php-ext-source-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP."
+LICENSE="BSD-2 MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=net-misc/curl-7.19.4
+ sys-libs/zlib
+ dev-libs/libevent
+ || ( <dev-lang/php-5.3[spl] >=dev-lang/php-5.3 )
+ >=dev-lang/php-5[hash,session,iconv]
+ "
+RDEPEND="${DEPEND}"
+
+my_conf="--enable-http \
+ --with-http-curl-requests \
+ --with-http-zlib-compression \
+ --with-http-curl-libevent \
+ --with-http-magic-mime"
+
+src_install() {
+ php-ext-pecl-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "http.etag.mode" "MD5"
+ php-ext-source-r2_addtoinifiles "http.force_exit" "1"
+ php-ext-source-r2_addtoinifiles "http.log.allowed_methods" ""
+ php-ext-source-r2_addtoinifiles "http.log.cache" ""
+ php-ext-source-r2_addtoinifiles "http.log.composite" ""
+ php-ext-source-r2_addtoinifiles "http.log.not_found" ""
+ php-ext-source-r2_addtoinifiles "http.log.redirect" ""
+ php-ext-source-r2_addtoinifiles "http.only_exceptions" "0"
+ php-ext-source-r2_addtoinifiles "http.persistent.handles.ident" "GLOBAL"
+ php-ext-source-r2_addtoinifiles "http.persistent.handles.limit" "-1"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.connect" "0"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.cookie" "0"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.dns" "1"
+ php-ext-source-r2_addtoinifiles "http.request.datashare.ssl" "0"
+ php-ext-source-r2_addtoinifiles "http.request.methods.allowed" ""
+ php-ext-source-r2_addtoinifiles "http.request.methods.custom" ""
+ php-ext-source-r2_addtoinifiles "http.send.inflate.start_auto" "0"
+ php-ext-source-r2_addtoinifiles "http.send.inflate.start_flags" "0"
+ php-ext-source-r2_addtoinifiles "http.send.deflate.start_auto" "0"
+ php-ext-source-r2_addtoinifiles "http.send.deflate.start_flags" "0"
+ php-ext-source-r2_addtoinifiles "http.send.not_found_404" "1"
+}
diff --git a/dev-php5/pecl-http/pecl-http-1.6.0.ebuild b/dev-php5/pecl-http/pecl-http-1.7.0.ebuild
index fcb582023c84..14c6ac9eec9b 100644
--- a/dev-php5/pecl-http/pecl-http-1.6.0.ebuild
+++ b/dev-php5/pecl-http/pecl-http-1.7.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/pecl-http-1.6.0.ebuild,v 1.3 2008/05/05 20:54:11 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-http/pecl-http-1.7.0.ebuild,v 1.1 2010/11/04 13:41:07 mabi Exp $
PHP_EXT_NAME="http"
PHP_EXT_PECL_PKG="pecl_http"
@@ -8,22 +8,25 @@ PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
DOCS="docs/examples/tutorial.txt ThanksTo.txt KnownIssues.txt"
+EAPI="2"
+
inherit php-ext-pecl-r1 php-ext-base-r1
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
DESCRIPTION="Extended HTTP Support for PHP."
LICENSE="BSD-2 MIT"
SLOT="0"
IUSE=""
-DEPEND=">=net-misc/curl-7.16.4
+DEPEND=">=net-misc/curl-7.19.4
sys-libs/zlib
- dev-libs/libevent"
+ dev-libs/libevent
+ || ( <dev-lang/php-5.3[spl] >=dev-lang/php-5.3 )
+ >=dev-lang/php-5[hash,session,iconv]
+ "
RDEPEND="${DEPEND}"
-need_php_by_category
-
src_compile() {
my_conf="--enable-http \
--with-http-curl-requests \
@@ -59,11 +62,3 @@ src_install() {
php-ext-base-r1_addtoinifiles "http.send.deflate.start_flags" "0"
php-ext-base-r1_addtoinifiles "http.send.not_found_404" "1"
}
-
-pkg_postinst() {
- has_php
- if ! built_with_use --missing true =${PHP_PKG} hash iconv session spl ; then
- elog "${PN} can optionally use hash, iconv, session and spl features."
- elog "If you want those, recompile ${PHP_PKG} with those flags in USE."
- fi
-}