summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2009-04-09 10:10:40 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2009-04-09 10:10:40 +0000
commit68f56689883de1c20e57825f6734f6fb68bfd5d7 (patch)
treed8f80baa2c307f6ed687be1b3f47cfedfeb57c00 /dev-php5/pecl-htscanner
parentEAPI2ification (diff)
downloadgentoo-2-68f56689883de1c20e57825f6734f6fb68bfd5d7.tar.gz
gentoo-2-68f56689883de1c20e57825f6734f6fb68bfd5d7.tar.bz2
gentoo-2-68f56689883de1c20e57825f6734f6fb68bfd5d7.zip
version bump wrt bug 264216, thanks to Michael Huber <mikki111@gmx.de> for reporting
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5/pecl-htscanner')
-rw-r--r--dev-php5/pecl-htscanner/ChangeLog11
-rw-r--r--dev-php5/pecl-htscanner/pecl-htscanner-0.9.0.ebuild35
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-php5/pecl-htscanner/ChangeLog b/dev-php5/pecl-htscanner/ChangeLog
index 32283bcdc2de..fea66f294cde 100644
--- a/dev-php5/pecl-htscanner/ChangeLog
+++ b/dev-php5/pecl-htscanner/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-php5/pecl-htscanner
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-htscanner/ChangeLog,v 1.7 2008/05/09 12:58:12 hoffie Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-htscanner/ChangeLog,v 1.8 2009/04/09 10:10:40 hoffie Exp $
+
+*pecl-htscanner-0.9.0 (09 Apr 2009)
+
+ 09 Apr 2009; Christian Hoffmann <hoffie@gentoo.org>
+ +pecl-htscanner-0.9.0.ebuild:
+ version bump wrt bug 264216, thanks to Michael Huber <mikki111@gmx.de> for
+ reporting
09 May 2008; Christian Hoffmann <hoffie@gentoo.org>
pecl-htscanner-0.8.1.ebuild:
diff --git a/dev-php5/pecl-htscanner/pecl-htscanner-0.9.0.ebuild b/dev-php5/pecl-htscanner/pecl-htscanner-0.9.0.ebuild
new file mode 100644
index 000000000000..6549b453afbf
--- /dev/null
+++ b/dev-php5/pecl-htscanner/pecl-htscanner-0.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-htscanner/pecl-htscanner-0.9.0.ebuild,v 1.1 2009/04/09 10:10:40 hoffie Exp $
+
+PHP_EXT_NAME="htscanner"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+PHPSAPILIST="cgi"
+
+inherit php-ext-pecl-r1 eutils depend.php php-ext-base-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Enables .htaccess options for php-scripts running as cgi."
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+need_php_by_category
+my_conf="--enable-htscanner"
+
+pkg_setup() {
+ has_php
+ require_php_sapi_from cgi
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+
+ php-ext-base-r1_addtoinifiles "config_file" ".htaccess"
+ php-ext-base-r1_addtoinifiles "default_docroot" "/"
+ php-ext-base-r1_addtoinifiles "default_ttl" "300"
+ php-ext-base-r1_addtoinifiles "stop_on_error" "0"
+}