summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-03-18 15:04:46 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-03-18 15:04:46 +0000
commit6d655f30da20b173ed2d792090ef399b0287bd7e (patch)
tree74fd2db99d4c521f6a89ee1afa8f4eadc1418a5e /dev-php5/onphp
parentRevision bump to fix some Java QA issues. (diff)
downloadgentoo-2-6d655f30da20b173ed2d792090ef399b0287bd7e.tar.gz
gentoo-2-6d655f30da20b173ed2d792090ef399b0287bd7e.tar.bz2
gentoo-2-6d655f30da20b173ed2d792090ef399b0287bd7e.zip
Cleanup.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-php5/onphp')
-rw-r--r--dev-php5/onphp/ChangeLog7
-rw-r--r--dev-php5/onphp/metadata.xml9
-rw-r--r--dev-php5/onphp/onphp-0.2.18.ebuild13
-rw-r--r--dev-php5/onphp/onphp-0.4.11.ebuild10
-rw-r--r--dev-php5/onphp/onphp-0.6.4.ebuild16
-rw-r--r--dev-php5/onphp/onphp-0.8.5.ebuild16
-rw-r--r--dev-php5/onphp/onphp-0.8.6.ebuild16
7 files changed, 50 insertions, 37 deletions
diff --git a/dev-php5/onphp/ChangeLog b/dev-php5/onphp/ChangeLog
index d22e99330fa3..e47ac2aecb1d 100644
--- a/dev-php5/onphp/ChangeLog
+++ b/dev-php5/onphp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/onphp
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/ChangeLog,v 1.42 2007/03/11 18:02:41 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/ChangeLog,v 1.43 2007/03/18 15:04:46 chtekk Exp $
+
+ 18 Mar 2007; Luca Longinotti <chtekk@gentoo.org> metadata.xml,
+ onphp-0.2.18.ebuild, onphp-0.4.11.ebuild, onphp-0.6.4.ebuild,
+ onphp-0.8.5.ebuild, onphp-0.8.6.ebuild:
+ Cleanup.
*onphp-0.8.6 (11 Mar 2007)
diff --git a/dev-php5/onphp/metadata.xml b/dev-php5/onphp/metadata.xml
index 1f8cb34afaa4..add2db9a25b6 100644
--- a/dev-php5/onphp/metadata.xml
+++ b/dev-php5/onphp/metadata.xml
@@ -1,8 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>voxus@gentoo.org</email>
- <name>Konstantin Arkhipov</name>
-</maintainer>
+ <herd>php</herd>
+ <maintainer>
+ <email>voxus@gentoo.org</email>
+ <name>Konstantin Arkhipov</name>
+ </maintainer>
</pkgmetadata>
diff --git a/dev-php5/onphp/onphp-0.2.18.ebuild b/dev-php5/onphp/onphp-0.2.18.ebuild
index b0c154864b6d..d3cbaad02005 100644
--- a/dev-php5/onphp/onphp-0.2.18.ebuild
+++ b/dev-php5/onphp/onphp-0.2.18.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-0.2.18.ebuild,v 1.3 2007/02/13 20:35:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-0.2.18.ebuild,v 1.4 2007/03/18 15:04:46 chtekk Exp $
inherit php-lib-r1
-KEYWORDS="x86 amd64"
+KEYWORDS="amd64 x86"
+
DESCRIPTION="onPHP is the GPL'ed multi-purpose object-oriented PHP framework."
HOMEPAGE="http://onphp.org/"
SRC_URI="http://onphp.org/download/${P}.tar.bz2
@@ -13,13 +14,16 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="doc"
+DEPEND=""
+RDEPEND=""
+
need_php_by_category
src_install() {
has_php
if use doc ; then
- for doc in `find doc -maxdepth 1 -type f -print`; do
+ for doc in `find doc -maxdepth 1 -type f -print` ; do
dodoc ${doc}
done
@@ -27,6 +31,5 @@ src_install() {
fi
php-lib-r1_src_install ./ global.inc.php.tpl
- php-lib-r1_src_install ./ `find core -type f -print`
- php-lib-r1_src_install ./ `find main -type f -print`
+ php-lib-r1_src_install ./ `find core main -type f -print`
}
diff --git a/dev-php5/onphp/onphp-0.4.11.ebuild b/dev-php5/onphp/onphp-0.4.11.ebuild
index 48e8f046e743..f1ecb70562ec 100644
--- a/dev-php5/onphp/onphp-0.4.11.ebuild
+++ b/dev-php5/onphp/onphp-0.4.11.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-0.4.11.ebuild,v 1.3 2007/02/13 20:35:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-0.4.11.ebuild,v 1.4 2007/03/18 15:04:46 chtekk Exp $
inherit php-lib-r1
-KEYWORDS="x86 amd64"
+KEYWORDS="amd64 x86"
+
DESCRIPTION="onPHP is the GPL'ed multi-purpose object-oriented PHP framework."
HOMEPAGE="http://onphp.org/"
SRC_URI="http://onphp.org/download/${P}.tar.bz2
@@ -13,13 +14,16 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="doc"
+DEPEND=""
+RDEPEND=""
+
need_php_by_category
src_install() {
has_php
if use doc ; then
- for doc in `find doc -maxdepth 1 -type f -print`; do
+ for doc in `find doc -maxdepth 1 -type f -print` ; do
dodoc ${doc}
done
diff --git a/dev-php5/onphp/onphp-0.6.4.ebuild b/dev-php5/onphp/onphp-0.6.4.ebuild
index df1e88b2ba69..84127a2b7110 100644
--- a/dev-php5/onphp/onphp-0.6.4.ebuild
+++ b/dev-php5/onphp/onphp-0.6.4.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-0.6.4.ebuild,v 1.3 2007/02/13 20:35:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-0.6.4.ebuild,v 1.4 2007/03/18 15:04:46 chtekk Exp $
inherit php-lib-r1
-KEYWORDS="x86 amd64"
+KEYWORDS="amd64 x86"
+
DESCRIPTION="onPHP is the GPL'ed multi-purpose object-oriented PHP framework."
HOMEPAGE="http://onphp.org/"
SRC_URI="http://onphp.org/download/${P}.tar.bz2
@@ -13,17 +14,16 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="doc"
-# since need_php51 is missing
-DEPEND=">=dev-lang/php-5.1"
-RDEPEND=">=dev-lang/php-5.1"
-PHP_VERSION="5"
-PHP_SHARED_CAT="php5"
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
src_install() {
has_php
if use doc ; then
- for doc in `find doc -maxdepth 1 -type f -print`; do
+ for doc in `find doc -maxdepth 1 -type f -print` ; do
dodoc ${doc}
done
diff --git a/dev-php5/onphp/onphp-0.8.5.ebuild b/dev-php5/onphp/onphp-0.8.5.ebuild
index 7582847a6e03..3acc21d0f69f 100644
--- a/dev-php5/onphp/onphp-0.8.5.ebuild
+++ b/dev-php5/onphp/onphp-0.8.5.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-0.8.5.ebuild,v 1.2 2007/03/04 14:02:22 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-0.8.5.ebuild,v 1.3 2007/03/18 15:04:46 chtekk Exp $
inherit php-lib-r1
-KEYWORDS="x86 amd64"
+KEYWORDS="amd64 x86"
+
DESCRIPTION="onPHP is the GPL'ed multi-purpose object-oriented PHP framework."
HOMEPAGE="http://onphp.org/"
SRC_URI="http://onphp.org/download/${P}.tar.bz2
@@ -13,17 +14,16 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="doc"
-# since need_php51 is missing
-DEPEND=">=dev-lang/php-5.1"
-RDEPEND=">=dev-lang/php-5.1"
-PHP_VERSION="5"
-PHP_SHARED_CAT="php5"
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
src_install() {
has_php
if use doc ; then
- for doc in `find doc -maxdepth 1 -type f -print`; do
+ for doc in `find doc -maxdepth 1 -type f -print` ; do
dodoc ${doc}
done
diff --git a/dev-php5/onphp/onphp-0.8.6.ebuild b/dev-php5/onphp/onphp-0.8.6.ebuild
index 02926d60eef9..aaa8d69deb91 100644
--- a/dev-php5/onphp/onphp-0.8.6.ebuild
+++ b/dev-php5/onphp/onphp-0.8.6.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-0.8.6.ebuild,v 1.1 2007/03/11 18:02:41 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-0.8.6.ebuild,v 1.2 2007/03/18 15:04:46 chtekk Exp $
inherit php-lib-r1
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~x86"
+
DESCRIPTION="onPHP is the GPL'ed multi-purpose object-oriented PHP framework."
HOMEPAGE="http://onphp.org/"
SRC_URI="http://onphp.org/download/${P}.tar.bz2
@@ -13,17 +14,16 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="doc"
-# since need_php51 is missing
-DEPEND=">=dev-lang/php-5.1"
-RDEPEND=">=dev-lang/php-5.1"
-PHP_VERSION="5"
-PHP_SHARED_CAT="php5"
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
src_install() {
has_php
if use doc ; then
- for doc in `find doc -maxdepth 1 -type f -print`; do
+ for doc in `find doc -maxdepth 1 -type f -print` ; do
dodoc ${doc}
done