summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2006-08-17 07:10:05 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2006-08-17 07:10:05 +0000
commit9d64d12986a4e396fc69af0274c8032b38564a6b (patch)
tree5ef410f4a214be401423c883590b3d1458f43a77 /dev-php4
parentVersion bump. (diff)
downloadgentoo-2-9d64d12986a4e396fc69af0274c8032b38564a6b.tar.gz
gentoo-2-9d64d12986a4e396fc69af0274c8032b38564a6b.tar.bz2
gentoo-2-9d64d12986a4e396fc69af0274c8032b38564a6b.zip
Version bump.
(Portage version: 2.1.1_pre5-r1)
Diffstat (limited to 'dev-php4')
-rw-r--r--dev-php4/pecl-apc/ChangeLog8
-rw-r--r--dev-php4/pecl-apc/files/digest-pecl-apc-3.0.113
-rw-r--r--dev-php4/pecl-apc/pecl-apc-3.0.10.ebuild7
-rw-r--r--dev-php4/pecl-apc/pecl-apc-3.0.11.ebuild75
4 files changed, 89 insertions, 4 deletions
diff --git a/dev-php4/pecl-apc/ChangeLog b/dev-php4/pecl-apc/ChangeLog
index c71d5efb6965..c5d017f1681e 100644
--- a/dev-php4/pecl-apc/ChangeLog
+++ b/dev-php4/pecl-apc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php4/pecl-apc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apc/ChangeLog,v 1.8 2006/05/27 00:44:31 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apc/ChangeLog,v 1.9 2006/08/17 07:10:05 sebastian Exp $
+
+*pecl-apc-3.0.11 (17 Aug 2006)
+
+ 17 Aug 2006; Sebastian Bergmann <sebastian@gentoo.org>
+ -pecl-apc-3.0.8.ebuild, pecl-apc-3.0.10.ebuild, +pecl-apc-3.0.11.ebuild:
+ Version bump.
27 May 2006; Luca Longinotti <chtekk@gentoo.org> pecl-apc-3.0.10.ebuild:
Added to ~amd64.
diff --git a/dev-php4/pecl-apc/files/digest-pecl-apc-3.0.11 b/dev-php4/pecl-apc/files/digest-pecl-apc-3.0.11
new file mode 100644
index 000000000000..3b05428874a2
--- /dev/null
+++ b/dev-php4/pecl-apc/files/digest-pecl-apc-3.0.11
@@ -0,0 +1,3 @@
+MD5 4d4481ba7be4245320083b9b254d6d79 APC-3.0.11.tgz 93066
+RMD160 356ddc9ac3f967cd04ec0004de2a3fbdd90b832f APC-3.0.11.tgz 93066
+SHA256 cf6ca220d51b7d202e9fe74dd705485b71903e9312d045fdd661d27cafab4c0a APC-3.0.11.tgz 93066
diff --git a/dev-php4/pecl-apc/pecl-apc-3.0.10.ebuild b/dev-php4/pecl-apc/pecl-apc-3.0.10.ebuild
index 3bdcea8d690a..6f7c4bd9ce88 100644
--- a/dev-php4/pecl-apc/pecl-apc-3.0.10.ebuild
+++ b/dev-php4/pecl-apc/pecl-apc-3.0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apc/pecl-apc-3.0.10.ebuild,v 1.2 2006/05/27 00:44:31 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apc/pecl-apc-3.0.10.ebuild,v 1.3 2006/08/17 07:10:05 sebastian Exp $
PHP_EXT_NAME="apc"
PHP_EXT_PECL_PKG="APC"
@@ -10,13 +10,14 @@ PHP_EXT_ZENDEXT="no"
inherit php-ext-pecl-r1 confutils
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-DESCRIPTION="The Alternative PHP Cache."
+DESCRIPTION="A free, open, and robust framework for caching and optimizing PHP intermediate code."
LICENSE="PHP"
SLOT="0"
IUSE="mmap"
DEPEND="${DEPEND}
- !dev-php4/eaccelerator"
+ !dev-php4/eaccelerator
+ !>=dev-lang/php-5.2.0"
need_php_by_category
diff --git a/dev-php4/pecl-apc/pecl-apc-3.0.11.ebuild b/dev-php4/pecl-apc/pecl-apc-3.0.11.ebuild
new file mode 100644
index 000000000000..8dfb52e3ee86
--- /dev/null
+++ b/dev-php4/pecl-apc/pecl-apc-3.0.11.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apc/pecl-apc-3.0.11.ebuild,v 1.1 2006/08/17 07:10:05 sebastian Exp $
+
+PHP_EXT_NAME="apc"
+PHP_EXT_PECL_PKG="APC"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1 confutils
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+DESCRIPTION="A free, open, and robust framework for caching and optimizing PHP intermediate code."
+LICENSE="PHP"
+SLOT="0"
+IUSE="mmap"
+
+DEPEND="${DEPEND}
+ !dev-php4/eaccelerator"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+
+ require_php_sapi_from cgi apache apache2
+}
+
+src_compile() {
+ has_php
+
+ # PECL-APC does not work with Zend Thread Safety (ZTS)
+ # so abort if we are using PHP compiled with ZTS.
+ if has_zts ; then
+ eerror "PECL-APC doesn't work with a ZTS enabled PHP."
+ eerror "Please disable ZTS by turning the 'threads'"
+ eerror "USE flag off when you compile dev-lang/php."
+ die "PECL-APC does not support ZTS"
+ fi
+
+ my_conf="--enable-apc"
+ enable_extension_enable "apc-mmap" "mmap" 0
+ enable_extension_with_built_with =${PHP_PKG} apache2 apxs2 /usr/sbin/apxs2 "optimisation for apache2"
+ enable_extension_with_built_with =${PHP_PKG} apache apxs /usr/sbin/apxs "optimisation for apache1"
+
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+ dodoc-php CHANGELOG INSTALL LICENSE NOTICE
+
+ php-ext-base-r1_addtoinifiles "apc.enabled" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_segments" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_size" '"30"'
+ php-ext-base-r1_addtoinifiles "apc.optimization" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.num_files_hint" '"1000"'
+ php-ext-base-r1_addtoinifiles "apc.ttl" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.gc_ttl" '"3600"'
+ php-ext-base-r1_addtoinifiles "apc.cache_by_default" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.filters" '""'
+ php-ext-base-r1_addtoinifiles "apc.mmap_file_mask" '""'
+ php-ext-base-r1_addtoinifiles "apc.slam_defense" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.file_update_protection" '"2"'
+ php-ext-base-r1_addtoinifiles "apc.stat" '"1"'
+
+ dodir "${PHP_EXT_SHARED_DIR}"
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins apc.php
+}
+
+pkg_postinst() {
+ einfo "The apc.php file shipped with this release of PECL-APC was"
+ einfo "installed into /usr/share/php4/apc/."
+}