summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-10-27 19:54:16 +0000
committerSven Wegener <swegener@gentoo.org>2006-10-27 19:54:16 +0000
commit9aa563793b8b6dfe656d112d5fc800a1a3f435c6 (patch)
tree638b83154d180399d5a4cc7a6be9d0954861fab3 /dev-php/xdebug-client
parentMoved to vdr-testing overlay. (diff)
downloadgentoo-2-9aa563793b8b6dfe656d112d5fc800a1a3f435c6.tar.gz
gentoo-2-9aa563793b8b6dfe656d112d5fc800a1a3f435c6.tar.bz2
gentoo-2-9aa563793b8b6dfe656d112d5fc800a1a3f435c6.zip
Set S correctly to avoid cd'ing around.
(Portage version: 2.1.2_pre3-r9)
Diffstat (limited to 'dev-php/xdebug-client')
-rw-r--r--dev-php/xdebug-client/ChangeLog6
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild15
2 files changed, 13 insertions, 8 deletions
diff --git a/dev-php/xdebug-client/ChangeLog b/dev-php/xdebug-client/ChangeLog
index 38199ab02cf5..d1fb9e3c1211 100644
--- a/dev-php/xdebug-client/ChangeLog
+++ b/dev-php/xdebug-client/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/xdebug-client
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.1 2006/10/27 18:58:01 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.2 2006/10/27 19:54:16 swegener Exp $
+
+ 27 Oct 2006; Sven Wegener <swegener@gentoo.org>
+ xdebug-client-2.0.0_rc1.ebuild:
+ Set S correctly to avoid cd'ing around.
*xdebug-client-2.0.0_rc1 (27 Oct 2006)
diff --git a/dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild b/dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild
index 6b6579a665f2..511fdcc00b01 100644
--- a/dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild
+++ b/dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild,v 1.1 2006/10/27 18:58:01 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.0.0_rc1.ebuild,v 1.2 2006/10/27 19:54:16 swegener Exp $
IUSE="libedit"
DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
@@ -8,16 +8,18 @@ HOMEPAGE="http://www.xdebug.org/"
SLOT="0"
MY_PV="${PV/_/}"
SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
-S="${WORKDIR}/xdebug-2.0.0RC1"
+S="${WORKDIR}/xdebug-2.0.0RC1/debugclient"
LICENSE="Xdebug"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-DEPEND="${DEPEND} libedit? ( || ( dev-libs/libedit sys-freebsd/freebsd-lib ) )"
+DEPEND="libedit? ( || ( dev-libs/libedit sys-freebsd/freebsd-lib ) )"
-src_compile() {
- cd "${S}/debugclient"
- chmod +x configure
+src_unpack() {
+ unpack ${A}
+ chmod +x "${S}"/configure
+}
+src_compile() {
econf \
$(use_with libedit ) \
|| die "Configure of debug client failed!"
@@ -26,6 +28,5 @@ src_compile() {
}
src_install() {
- cd "${S}/debugclient"
newbin debugclient xdebug
}