summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-03-13 13:21:06 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-03-13 13:21:06 +0000
commit57c714a7ef76db7d858fac6a06ca4302fdcf01b8 (patch)
treed85c051caf235206b37bfc367bf7b4ecb23fed32 /dev-php/xdebug-client
parentMarking xdg-menu-1.5 ppc for bug 400481 (diff)
downloadgentoo-2-57c714a7ef76db7d858fac6a06ca4302fdcf01b8.tar.gz
gentoo-2-57c714a7ef76db7d858fac6a06ca4302fdcf01b8.tar.bz2
gentoo-2-57c714a7ef76db7d858fac6a06ca4302fdcf01b8.zip
Version bump
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/xdebug-client')
-rw-r--r--dev-php/xdebug-client/ChangeLog8
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.1.4.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-php/xdebug-client/ChangeLog b/dev-php/xdebug-client/ChangeLog
index ba71aab55948..ce11109ac004 100644
--- a/dev-php/xdebug-client/ChangeLog
+++ b/dev-php/xdebug-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/xdebug-client
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.36 2012/02/25 18:02:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.37 2012/03/13 13:21:06 olemarkus Exp $
+
+*xdebug-client-2.1.4 (13 Mar 2012)
+
+ 13 Mar 2012; Ole Markus With <olemarkus@gentoo.org>
+ +xdebug-client-2.1.4.ebuild:
+ Version bump
25 Feb 2012; Raúl Porcel <armin76@gentoo.org> xdebug-client-2.1.2.ebuild:
alpha/ia64/sparc stable wrt #400323
diff --git a/dev-php/xdebug-client/xdebug-client-2.1.4.ebuild b/dev-php/xdebug-client/xdebug-client-2.1.4.ebuild
new file mode 100644
index 000000000000..d3b355a44632
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.1.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.1.4.ebuild,v 1.1 2012/03/13 13:21:06 olemarkus Exp $
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( dev-libs/libedit )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ chmod +x "${S}"/configure
+}
+
+src_compile() {
+ econf $(use_with libedit) --disable-dependency-tracking
+ emake || die "Build of debug client failed!"
+}
+
+src_install() {
+ newbin debugclient xdebug
+}