summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-02-12 19:13:00 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-02-12 19:13:00 +0000
commitbfbb847646a07fdf580ea4dcd36e3770ce8cd7d7 (patch)
tree377fa4ac8d3522e80be5d7eb8b84d7111f2cf4bd /dev-php/suhosin
parentCall python_convert_shebangs() only in correct combination of USE flags. Patc... (diff)
downloadgentoo-2-bfbb847646a07fdf580ea4dcd36e3770ce8cd7d7.tar.gz
gentoo-2-bfbb847646a07fdf580ea4dcd36e3770ce8cd7d7.tar.bz2
gentoo-2-bfbb847646a07fdf580ea4dcd36e3770ce8cd7d7.zip
Added patch that makes suhosin build with php[threads]. Bug 400889
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/suhosin')
-rw-r--r--dev-php/suhosin/ChangeLog6
-rw-r--r--dev-php/suhosin/files/suhosin-0.9.33-fix-ZTS-compile-problem.patch54
-rw-r--r--dev-php/suhosin/suhosin-0.9.33.ebuild3
3 files changed, 61 insertions, 2 deletions
diff --git a/dev-php/suhosin/ChangeLog b/dev-php/suhosin/ChangeLog
index 774bcd0634b4..24b727bdb5f7 100644
--- a/dev-php/suhosin/ChangeLog
+++ b/dev-php/suhosin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/suhosin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/suhosin/ChangeLog,v 1.3 2012/01/27 13:30:25 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/suhosin/ChangeLog,v 1.4 2012/02/12 19:13:00 olemarkus Exp $
+
+ 12 Feb 2012; Ole Markus With <olemarkus@gentoo.org>
+ +files/suhosin-0.9.33-fix-ZTS-compile-problem.patch, suhosin-0.9.33.ebuild:
+ Added patch that makes suhosin build with php[threads]. Bug 400889
27 Jan 2012; Agostino Sarubbo <ago@gentoo.org> suhosin-0.9.33.ebuild:
Stable for AMD64, wrt security bug #399427
diff --git a/dev-php/suhosin/files/suhosin-0.9.33-fix-ZTS-compile-problem.patch b/dev-php/suhosin/files/suhosin-0.9.33-fix-ZTS-compile-problem.patch
new file mode 100644
index 000000000000..361d6f2091e6
--- /dev/null
+++ b/dev-php/suhosin/files/suhosin-0.9.33-fix-ZTS-compile-problem.patch
@@ -0,0 +1,54 @@
+From af51a7f576f0cec1d2c94b9bbb3dfb46dd466a66 Mon Sep 17 00:00:00 2001
+From: Stefan Esser <stefan@nopiracy.de>
+Date: Sun, 12 Feb 2012 10:47:10 +0100
+Subject: [PATCH] Fix ZTS compile problem
+
+---
+ php_suhosin.h | 2 +-
+ post_handler.c | 2 +-
+ suhosin.c | 4 +++-
+ 3 files changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/php_suhosin.h b/php_suhosin.h
+index 7d0a286..c3491d0 100644
+--- a/php_suhosin.h
++++ b/php_suhosin.h
+@@ -308,7 +308,7 @@
+ char *suhosin_cookie_decryptor(TSRMLS_D);
+ char *suhosin_getenv(char *name, size_t name_len TSRMLS_DC);
+ void suhosin_hook_post_handlers(TSRMLS_D);
+-void suhosin_unhook_post_handlers();
++void suhosin_unhook_post_handlers(TSRMLS_D);
+ void suhosin_hook_register_server_variables();
+ void suhosin_hook_header_handler();
+ void suhosin_unhook_header_handler();
+diff --git a/post_handler.c b/post_handler.c
+index b405ae2..96f4b4a 100644
+--- a/post_handler.c
++++ b/post_handler.c
+@@ -162,7 +162,7 @@ void suhosin_hook_post_handlers(TSRMLS_D)
+ ini_entry->on_modify = suhosin_OnUpdate_mbstring_encoding_translation;
+ }
+
+-void suhosin_unhook_post_handlers()
++void suhosin_unhook_post_handlers(TSRMLS_D)
+ {
+ zend_ini_entry *ini_entry;
+
+diff --git a/suhosin.c b/suhosin.c
+index 9829896..01f987c 100644
+--- a/suhosin.c
++++ b/suhosin.c
+@@ -189,9 +189,11 @@ static int suhosin_module_startup(zend_extension *extension)
+
+ static void suhosin_shutdown(zend_extension *extension)
+ {
++ TSRMLS_FETCH();
++
+ suhosin_unhook_execute();
+ suhosin_unhook_header_handler();
+- suhosin_unhook_post_handlers();
++ suhosin_unhook_post_handlers(TSRMLS_C);
+
+ if (ze != NULL) {
+ ze->startup = orig_module_startup;
diff --git a/dev-php/suhosin/suhosin-0.9.33.ebuild b/dev-php/suhosin/suhosin-0.9.33.ebuild
index d04eba1b6d49..70822835df41 100644
--- a/dev-php/suhosin/suhosin-0.9.33.ebuild
+++ b/dev-php/suhosin/suhosin-0.9.33.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/suhosin/suhosin-0.9.33.ebuild,v 1.2 2012/01/27 13:30:25 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/suhosin/suhosin-0.9.33.ebuild,v 1.3 2012/02/12 19:13:00 olemarkus Exp $
EAPI="2"
@@ -27,6 +27,7 @@ src_prepare() {
for slot in $(php_get_slots); do
php_init_slot_env ${slot}
epatch "${FILESDIR}"/${P}-libcrypt.patch
+ epatch "${FILESDIR}"/${P}-fix-ZTS-compile-problem.patch
done
php-ext-source-r2_src_prepare
}