summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-09-18 11:02:27 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-09-18 11:02:27 +0000
commitd0648ca87dff4490e2760c3c8d803a60d7d1ec60 (patch)
tree1c26356a20b7b880b25fd5bd6e980119b1cb3474 /dev-php/phpunit-mockobject
parentStable on amd64 wrt bug #383399 (diff)
downloadgentoo-2-d0648ca87dff4490e2760c3c8d803a60d7d1ec60.tar.gz
gentoo-2-d0648ca87dff4490e2760c3c8d803a60d7d1ec60.tar.bz2
gentoo-2-d0648ca87dff4490e2760c3c8d803a60d7d1ec60.zip
Moved from dev-php5/phpunit-mockobject
(Portage version: 2.1.10.3/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-php/phpunit-mockobject')
-rw-r--r--dev-php/phpunit-mockobject/ChangeLog24
-rw-r--r--dev-php/phpunit-mockobject/metadata.xml5
-rw-r--r--dev-php/phpunit-mockobject/phpunit-mockobject-1.0.0.ebuild24
-rw-r--r--dev-php/phpunit-mockobject/phpunit-mockobject-1.0.3.ebuild24
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-php/phpunit-mockobject/ChangeLog b/dev-php/phpunit-mockobject/ChangeLog
new file mode 100644
index 000000000000..d98e507619de
--- /dev/null
+++ b/dev-php/phpunit-mockobject/ChangeLog
@@ -0,0 +1,24 @@
+# ChangeLog for dev-php5/phpunit-mockobject
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit-mockobject/ChangeLog,v 1.1 2011/09/18 11:02:27 olemarkus Exp $
+
+ 24 May 2011; Markos Chandras <hwoarang@gentoo.org>
+ phpunit-mockobject-1.0.3.ebuild:
+ Stable on amd64 wrt bug #368293
+
+ 23 May 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ phpunit-mockobject-1.0.3.ebuild:
+ x86 stable wrt bug #368293
+
+*phpunit-mockobject-1.0.3 (26 Mar 2011)
+
+ 26 Mar 2011; Ole Markus With <olemarkus@gentoo.org>
+ +phpunit-mockobject-1.0.3.ebuild:
+ Version bump
+
+*phpunit-mockobject-1.0.0 (04 Oct 2010)
+
+ 04 Oct 2010; Markus Ullmann <jokey@gentoo.org>
+ +phpunit-mockobject-1.0.0.ebuild, +metadata.xml:
+ Initial import for phpunit-3.5
+
diff --git a/dev-php/phpunit-mockobject/metadata.xml b/dev-php/phpunit-mockobject/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/phpunit-mockobject/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/phpunit-mockobject/phpunit-mockobject-1.0.0.ebuild b/dev-php/phpunit-mockobject/phpunit-mockobject-1.0.0.ebuild
new file mode 100644
index 000000000000..106751276e19
--- /dev/null
+++ b/dev-php/phpunit-mockobject/phpunit-mockobject-1.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit-mockobject/phpunit-mockobject-1.0.0.ebuild,v 1.1 2011/09/18 11:02:27 olemarkus Exp $
+
+EAPI="2"
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Mock Object library for PHPUnit"
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit_MockObject-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="!dev-php4/phpunit
+ >=dev-php/PEAR-PEAR-1.9.1"
+RDEPEND="${DEPEND}
+ dev-php/php-texttemplate"
+
+need_php_by_category
+
+S="${WORKDIR}/PHPUnit_MockObject-${PV}"
diff --git a/dev-php/phpunit-mockobject/phpunit-mockobject-1.0.3.ebuild b/dev-php/phpunit-mockobject/phpunit-mockobject-1.0.3.ebuild
new file mode 100644
index 000000000000..69136f682889
--- /dev/null
+++ b/dev-php/phpunit-mockobject/phpunit-mockobject-1.0.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit-mockobject/phpunit-mockobject-1.0.3.ebuild,v 1.1 2011/09/18 11:02:27 olemarkus Exp $
+
+EAPI="2"
+inherit php-pear-lib-r1
+
+KEYWORDS="amd64 x86"
+
+DESCRIPTION="Mock Object library for PHPUnit"
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit_MockObject-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="!dev-php4/phpunit
+ >=dev-php/PEAR-PEAR-1.9.1"
+RDEPEND="${DEPEND}
+ dev-php/php-texttemplate"
+
+need_php_by_category
+
+S="${WORKDIR}/PHPUnit_MockObject-${PV}"