summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-24 16:33:30 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-24 16:33:30 +0000
commitd5380740ef57c418456c59845e4bd258e89375d5 (patch)
tree6d7169c96e35e80b64cbaff73d4025a9a175bc21 /dev-php/phpgroupware
parentVersion bumped (diff)
downloadgentoo-2-d5380740ef57c418456c59845e4bd258e89375d5.tar.gz
gentoo-2-d5380740ef57c418456c59845e4bd258e89375d5.tar.bz2
gentoo-2-d5380740ef57c418456c59845e4bd258e89375d5.zip
Version bumped
Diffstat (limited to 'dev-php/phpgroupware')
-rw-r--r--dev-php/phpgroupware/ChangeLog8
-rw-r--r--dev-php/phpgroupware/Manifest4
-rw-r--r--dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.0061
-rw-r--r--dev-php/phpgroupware/phpgroupware-0.9.14.006.ebuild49
4 files changed, 59 insertions, 3 deletions
diff --git a/dev-php/phpgroupware/ChangeLog b/dev-php/phpgroupware/ChangeLog
index 8f55893e80ad..72013b360e95 100644
--- a/dev-php/phpgroupware/ChangeLog
+++ b/dev-php/phpgroupware/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/phpgroupware
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/ChangeLog,v 1.8 2003/07/07 17:42:33 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/ChangeLog,v 1.9 2003/07/24 16:33:20 mholzer Exp $
+
+*phpgroupware-0.9.14.006 (25 Jul 2003)
+
+ 25 Jul 2003; Martin Holzer <mholzer@gentoo.org>
+ phpgroupware-0.9.14.006.ebuild:
+ Version bumped.
*phpgroupware-0.9.14.005 (07 Jul 2003)
diff --git a/dev-php/phpgroupware/Manifest b/dev-php/phpgroupware/Manifest
index 01c0ea80d290..db665ef18c19 100644
--- a/dev-php/phpgroupware/Manifest
+++ b/dev-php/phpgroupware/Manifest
@@ -1,5 +1,5 @@
-MD5 e75359f9da2bbbe5119a2d8c522e1604 ChangeLog 1189
-MD5 3a086d8cc36c42feabb6825f1fc21b3f phpgroupware-0.9.14.006.ebuild 1417
+MD5 efba25c24895a9945241475e86e708cd ChangeLog 1332
+MD5 7adf5d5c6fc36c48fcdea1440cefdd26 phpgroupware-0.9.14.006.ebuild 1442
MD5 3a086d8cc36c42feabb6825f1fc21b3f phpgroupware-0.9.14.005.ebuild 1417
MD5 1dd9268509d0274661f43e45850a5875 files/digest-phpgroupware-0.9.14.006 77
MD5 02d45a79a1a9729f984d8e9ff76e3939 files/digest-phpgroupware-0.9.14.005 77
diff --git a/dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.006 b/dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.006
new file mode 100644
index 000000000000..57b79a6ee955
--- /dev/null
+++ b/dev-php/phpgroupware/files/digest-phpgroupware-0.9.14.006
@@ -0,0 +1 @@
+MD5 e0c3c12899d81e334d36e7b186be1bcb phpgroupware-0.9.14.006.tar.bz2 6097601
diff --git a/dev-php/phpgroupware/phpgroupware-0.9.14.006.ebuild b/dev-php/phpgroupware/phpgroupware-0.9.14.006.ebuild
new file mode 100644
index 000000000000..f256c2f9cc2b
--- /dev/null
+++ b/dev-php/phpgroupware/phpgroupware-0.9.14.006.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpgroupware/phpgroupware-0.9.14.006.ebuild,v 1.1 2003/07/24 16:33:20 mholzer Exp $
+
+S=${WORKDIR}/${PN}
+HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+DESCRIPTION="The phpGroupWare intranet/groupware tool and application framework."
+SRC_URI="mirror://sourceforge/phpgroupware/${P}.tar.bz2"
+HOMEPAGE="http://www.phpgroupware.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~amd64 ~sparc ~hppa ~arm"
+IUSE=""
+
+DEPEND="virtual/php
+ dev-db/mysql"
+
+
+pkg_setup() {
+ if [ -L ${HTTPD_ROOT}/phpgroupware ] ; then
+ ewarn "You need to unmerge your old phpGroupWare version first."
+ ewarn "phpGroupWare will be installed into ${HTTPD_ROOT}/phpgroupware"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+}
+
+src_compile() {
+ #nothing to compile
+ echo "Nothing to compile"
+}
+
+src_install () {
+ dodir ${HTTPD_ROOT}/phpgroupware
+ cd ${WORKDIR}
+ cp -r . ${D}/${HTTPD_ROOT}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} phpgroupware
+ chmod -R 700 phpgroupware/files
+}
+
+pkg_postinst() {
+ einfo "Follow the instructions at http://docs.phpgroupware.org/12-docs/html/admin/x62.html#AEN134 "
+ einfo "to complete the install. You need to add MySQL users and configure phpGroupWare"
+}