summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2014-01-08 15:42:38 +0000
committerMatti Bickel <mabi@gentoo.org>2014-01-08 15:42:38 +0000
commit763cb86de7dd4a83352d592dbc38d392e6aa0f36 (patch)
treecf9509ad6e0ac1fd0311dc57d2a08e55f2c43e94 /dev-php/phpDocumentor
parenteapi=5; vdr-plugin-2.eclass (diff)
downloadgentoo-2-763cb86de7dd4a83352d592dbc38d392e6aa0f36.tar.gz
gentoo-2-763cb86de7dd4a83352d592dbc38d392e6aa0f36.tar.bz2
gentoo-2-763cb86de7dd4a83352d592dbc38d392e6aa0f36.zip
initial version, intended as an update to dev-php/PEAR-PhpDocumentor; note the use of bundled libraries we do not provide in-tree
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xDDF971F118EEA5E6!)
Diffstat (limited to 'dev-php/phpDocumentor')
-rw-r--r--dev-php/phpDocumentor/ChangeLog10
-rw-r--r--dev-php/phpDocumentor/files/channel.xml16
-rw-r--r--dev-php/phpDocumentor/metadata.xml5
-rw-r--r--dev-php/phpDocumentor/phpDocumentor-2.2.0.ebuild28
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-php/phpDocumentor/ChangeLog b/dev-php/phpDocumentor/ChangeLog
new file mode 100644
index 000000000000..7de1e9d2c5fd
--- /dev/null
+++ b/dev-php/phpDocumentor/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-php/phpDocumentor
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpDocumentor/ChangeLog,v 1.1 2014/01/08 15:42:38 mabi Exp $
+
+*phpDocumentor-2.2.0 (08 Jan 2014)
+
+ 08 Jan 2014; Matti Bickel <mabi@gentoo.org> +files/channel.xml, +metadata.xml,
+ +phpDocumentor-2.2.0.ebuild:
+ initial version, intended as an update to dev-php/PEAR-PhpDocumentor; note the
+ use of bundled libraries we do not provide in-tree
diff --git a/dev-php/phpDocumentor/files/channel.xml b/dev-php/phpDocumentor/files/channel.xml
new file mode 100644
index 000000000000..fab798db9a95
--- /dev/null
+++ b/dev-php/phpDocumentor/files/channel.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
+ <name>pear.phpdoc.org</name>
+ <summary>phpdoc PEAR channel</summary>
+ <suggestedalias>phpdoc</suggestedalias>
+ <servers>
+ <primary>
+ <rest>
+ <baseurl type="REST1.0">http://pear.phpdoc.org//rest/</baseurl>
+ <baseurl type="REST1.1">http://pear.phpdoc.org//rest/</baseurl>
+ <baseurl type="REST1.2">http://pear.phpdoc.org//rest/</baseurl>
+ <baseurl type="REST1.3">http://pear.phpdoc.org//rest/</baseurl>
+ </rest>
+ </primary>
+ </servers>
+</channel>
diff --git a/dev-php/phpDocumentor/metadata.xml b/dev-php/phpDocumentor/metadata.xml
new file mode 100644
index 000000000000..40dbb4c4bbaf
--- /dev/null
+++ b/dev-php/phpDocumentor/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/phpDocumentor/phpDocumentor-2.2.0.ebuild b/dev-php/phpDocumentor/phpDocumentor-2.2.0.ebuild
new file mode 100644
index 000000000000..56d885be2a12
--- /dev/null
+++ b/dev-php/phpDocumentor/phpDocumentor-2.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpDocumentor/phpDocumentor-2.2.0.ebuild,v 1.1 2014/01/08 15:42:38 mabi Exp $
+
+EAPI=5
+
+PHP_PEAR_URI="pear.phpdoc.org"
+
+inherit php-pear-r1
+
+DESCRIPTION="The phpDocumentor package provides automatic documenting of php api directly from the source."
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+# block old version that provides the same binary
+DEPEND="media-gfx/graphviz
+ !dev-php/PEAR-PhpDocumentor"
+
+src_install() {
+ php-pear-r1_src_install
+
+ # install manual, tutorial, reference material
+ use doc && dodoc -r docs/*
+}