summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTal Peer <coredumb@gentoo.org>2003-04-25 18:02:38 +0000
committerTal Peer <coredumb@gentoo.org>2003-04-25 18:02:38 +0000
commiteb73561172c917c953dbf82f6bb54bb70caca1d0 (patch)
treefef3c273a39bad7331411d45df90c720b22353f0 /dev-php/php-cvs
parentInitial commit, uses the new php.eclass (diff)
downloadgentoo-2-eb73561172c917c953dbf82f6bb54bb70caca1d0.tar.gz
gentoo-2-eb73561172c917c953dbf82f6bb54bb70caca1d0.tar.bz2
gentoo-2-eb73561172c917c953dbf82f6bb54bb70caca1d0.zip
Initial commit, uses the new php.eclass
Diffstat (limited to 'dev-php/php-cvs')
-rw-r--r--dev-php/php-cvs/ChangeLog9
-rw-r--r--dev-php/php-cvs/Manifest3
-rw-r--r--dev-php/php-cvs/files/digest-php-cvs-5.00
-rw-r--r--dev-php/php-cvs/php-cvs-5.0.ebuild66
4 files changed, 77 insertions, 1 deletions
diff --git a/dev-php/php-cvs/ChangeLog b/dev-php/php-cvs/ChangeLog
new file mode 100644
index 000000000000..fa8cc1bda0b8
--- /dev/null
+++ b/dev-php/php-cvs/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-php/php-cvs
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cvs/ChangeLog,v 1.1 2003/04/25 18:02:10 coredumb Exp $
+
+*php-cvs-5.0 (25 Apr 2003)
+
+ 25 Apr 2003; Tal Peer <coredumb@gentoo.org> php-cvs-5.0.ebuild:
+ Initial import. Currently hard-masked because it uses the new eclass.
+
diff --git a/dev-php/php-cvs/Manifest b/dev-php/php-cvs/Manifest
index 55e5bb654846..36d7add29e7c 100644
--- a/dev-php/php-cvs/Manifest
+++ b/dev-php/php-cvs/Manifest
@@ -1,2 +1,3 @@
-MD5 b19e33c26d8072799699a4d46ca3e598 php-cvs-5.0.ebuild 1444
+MD5 c20294a6a0bb44fc46cc79bfa4e5951f php-cvs-5.0.ebuild 1367
+MD5 839b5588ed0c8c900718b6880434c77c ChangeLog 381
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-php-cvs-5.0 0
diff --git a/dev-php/php-cvs/files/digest-php-cvs-5.0 b/dev-php/php-cvs/files/digest-php-cvs-5.0
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/dev-php/php-cvs/files/digest-php-cvs-5.0
diff --git a/dev-php/php-cvs/php-cvs-5.0.ebuild b/dev-php/php-cvs/php-cvs-5.0.ebuild
new file mode 100644
index 000000000000..a8fce027cda6
--- /dev/null
+++ b/dev-php/php-cvs/php-cvs-5.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cvs/php-cvs-5.0.ebuild,v 1.1 2003/04/25 18:02:10 coredumb Exp $
+
+ECVS_SERVER="cvs.php.net:/repository"
+ECVS_MODULE="php5"
+ECVS_USER="cvsread"
+ECVS_PASS="phpfi"
+ECVS_AUTH="pserver"
+ECVS_BRANCH=""
+
+inherit php cvs
+
+MY_P=php-${PV}
+S=${WORKDIR}/${ECVS_MODULE}
+DESCRIPTION="PHP Shell Interpreter - development version"
+SRC_URI=""
+HOMEPAGE="http://www.php.net/"
+LICENSE="PHP"
+SLOT="0"
+PROVIDE="virtual/php"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+src_unpack() {
+ cvs_src_unpack
+ cd ${S}
+}
+
+src_compile() {
+ ./buildconf
+
+ if [ "`use mysql`" ] ; then
+ if [ "`mysql_config | grep '4.1'`" ] ; then
+ myconf="${myconf} --with-mysqli=/usr"
+ else
+ myconf="${myconf} --with-mysql=/usr"
+ fi
+ else
+ myconf="${myconf} --without-mysql"
+ fi
+
+ myconf="${myconf} --enable-embed"
+ myconf="${myconf} --disable-cgi --enable-cli"
+
+ php_src_compile
+}
+
+
+src_install() {
+ php_src_install
+
+ docinto Zend
+ dodoc Zend/ZEND_CHANGES Zend/ChangeLog Zend/OBJECTS2_HOWTO
+}
+
+pkg_postinst() {
+ # This fixes the permission from world writeable to the correct one.
+ # - novell@kiruna.se
+ chmod 755 /usr/bin/pear
+
+ # This is more correct information.
+ einfo
+ einfo "This is a CLI only build."
+ einfo "You can not use it on a webserver."
+ einfo
+}