summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2014-01-04 19:52:17 +0000
committerMatti Bickel <mabi@gentoo.org>2014-01-04 19:52:17 +0000
commit652b3235452a84ec686d283d5a39b1c5e9833835 (patch)
tree2fa8d61b63bb0646c7d4c6618971fa00c2b27927 /dev-php/phing
parentversion bump, cleanup (diff)
downloadgentoo-2-652b3235452a84ec686d283d5a39b1c5e9833835.tar.gz
gentoo-2-652b3235452a84ec686d283d5a39b1c5e9833835.tar.bz2
gentoo-2-652b3235452a84ec686d283d5a39b1c5e9833835.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xDDF971F118EEA5E6!)
Diffstat (limited to 'dev-php/phing')
-rw-r--r--dev-php/phing/ChangeLog9
-rw-r--r--dev-php/phing/phing-2.6.1.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-php/phing/ChangeLog b/dev-php/phing/ChangeLog
index e2adf8d1d647..598b0bd24f40 100644
--- a/dev-php/phing/ChangeLog
+++ b/dev-php/phing/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/phing
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phing/ChangeLog,v 1.12 2013/08/17 01:09:36 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phing/ChangeLog,v 1.13 2014/01/04 19:52:17 mabi Exp $
+
+*phing-2.6.1 (04 Jan 2014)
+
+ 04 Jan 2014; Matti Bickel <mabi@gentoo.org> +phing-2.6.1.ebuild:
+ version bump
17 Aug 2013; Patrick Lauer <patrick@gentoo.org> -phing-2.4.5.ebuild:
QA: Punt version with broken deps
diff --git a/dev-php/phing/phing-2.6.1.ebuild b/dev-php/phing/phing-2.6.1.ebuild
new file mode 100644
index 000000000000..adad389c3d88
--- /dev/null
+++ b/dev-php/phing/phing-2.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phing/phing-2.6.1.ebuild,v 1.1 2014/01/04 19:52:17 mabi Exp $
+
+EAPI="5"
+
+inherit php-pear-lib-r1 eutils
+
+DESCRIPTION="PHP project build system based on Apache Ant"
+HOMEPAGE="http://www.phing.info/"
+SRC_URI="http://pear.phing.info/get/phing-${PV/_/}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+minimal"
+
+DEPEND=""
+RDEPEND="!minimal? ( >=dev-php/PEAR-PhpDocumentor-1.4.0
+ >=dev-php/PEAR-PEAR_PackageFileManager-1.5.2
+ >=dev-php/PEAR-VersionControl_SVN-0.3.0_alpha1
+ >=dev-php/phpunit-3.2.0
+ >=dev-php/xdebug-2.0.0
+ >=dev-php/simpletest-1.0.1_beta2 )
+ dev-lang/php[xml,xslt]
+ "
+
+S=${WORKDIR}/${PN}-${PV/_/}
+
+pkg_postinst() {
+ if use minimal; then
+ elog "You have enabled the minimal USE flag. If you want to use features"
+ elog "from xdebug, phpunit, simpletest and more, disable the"
+ elog "USE flag or emerge the packages manually"
+ fi
+}