summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-02-02 15:41:47 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-02-02 15:41:47 +0000
commit63cf38eaef8b59916c3aa5776b6f6115a0631119 (patch)
treeb4a99f77ae2b6905051dad075d71ade2f1bd3bf6 /dev-php/phing
parentppc/ppc64 stable wrt #398461 (diff)
downloadgentoo-2-63cf38eaef8b59916c3aa5776b6f6115a0631119.tar.gz
gentoo-2-63cf38eaef8b59916c3aa5776b6f6115a0631119.tar.bz2
gentoo-2-63cf38eaef8b59916c3aa5776b6f6115a0631119.zip
Version bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/phing')
-rw-r--r--dev-php/phing/ChangeLog9
-rw-r--r--dev-php/phing/phing-2.4.9.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-php/phing/ChangeLog b/dev-php/phing/ChangeLog
index 9a9630c139ff..6c44a0bab9d2 100644
--- a/dev-php/phing/ChangeLog
+++ b/dev-php/phing/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/phing
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phing/ChangeLog,v 1.8 2011/03/06 11:20:33 olemarkus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phing/ChangeLog,v 1.9 2012/02/02 15:41:47 olemarkus Exp $
+
+*phing-2.4.9 (02 Feb 2012)
+
+ 02 Feb 2012; Ole Markus With <olemarkus@gentoo.org> +phing-2.4.9.ebuild:
+ Version bump
*phing-2.4.5 (06 Mar 2011)
diff --git a/dev-php/phing/phing-2.4.9.ebuild b/dev-php/phing/phing-2.4.9.ebuild
new file mode 100644
index 000000000000..5964c6feaa2c
--- /dev/null
+++ b/dev-php/phing/phing-2.4.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phing/phing-2.4.9.ebuild,v 1.1 2012/02/02 15:41:47 olemarkus Exp $
+
+EAPI="4"
+inherit php-pear-lib-r1 eutils
+
+DESCRIPTION="PHP project build system based on Apache Ant"
+HOMEPAGE="http://www.phing.info/"
+SRC_URI="http://pear.phing.info/get/phing-${PV/_/}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+minimal"
+
+DEPEND=""
+RDEPEND="!minimal? ( >=dev-php/PEAR-PhpDocumentor-1.4.0
+ >=dev-php/PEAR-PEAR_PackageFileManager-1.5.2
+ >=dev-php/PEAR-VersionControl_SVN-0.3.0_alpha1
+ >=dev-php/phpunit-3.2.0
+ >=dev-php/xdebug-2.0.0
+ >=dev-php/simpletest-1.0.1_beta2 )
+ >=dev-lang/php-5.0.2[xml,xsl]
+ || ( <dev-lang/php-5.3.1[pcre,reflection,spl] >=dev-lang/php-5.3.1 )
+ "
+
+need_php_by_category
+
+S=${WORKDIR}/${PN}-${PV/_/}
+
+pkg_postinst() {
+ if use minimal; then
+ elog "You have enabled the minimal USE flag. If you want to use features"
+ elog "from xdebug, phpunit, simpletest and more, disable the"
+ elog "USE flag or emerge the packages manually"
+ fi
+}