summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2013-11-07 22:28:42 +0000
committerMatti Bickel <mabi@gentoo.org>2013-11-07 22:28:42 +0000
commit8055e155be2dbc6631a515b3aaebd114b9913e5e (patch)
tree92ced8ee5b0b79f706a75f7283b2d79d6cdc8e21 /dev-php/pecl-xdiff
parentVersion bump. (diff)
downloadgentoo-2-8055e155be2dbc6631a515b3aaebd114b9913e5e.tar.gz
gentoo-2-8055e155be2dbc6631a515b3aaebd114b9913e5e.tar.bz2
gentoo-2-8055e155be2dbc6631a515b3aaebd114b9913e5e.zip
allow building against php5.5
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x4849EC6C)
Diffstat (limited to 'dev-php/pecl-xdiff')
-rw-r--r--dev-php/pecl-xdiff/ChangeLog7
-rw-r--r--dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r1.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-php/pecl-xdiff/ChangeLog b/dev-php/pecl-xdiff/ChangeLog
index f6ea757fced2..f33da54d9eec 100644
--- a/dev-php/pecl-xdiff/ChangeLog
+++ b/dev-php/pecl-xdiff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/pecl-xdiff
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-xdiff/ChangeLog,v 1.3 2013/03/05 11:48:20 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-xdiff/ChangeLog,v 1.4 2013/11/07 22:28:42 mabi Exp $
+
+*pecl-xdiff-1.5.2-r1 (07 Nov 2013)
+
+ 07 Nov 2013; Matti Bickel <mabi@gentoo.org> +pecl-xdiff-1.5.2-r1.ebuild:
+ allow building against php5.5
05 Mar 2013; Ole Markus With <olemarkus@gentoo.org>
-pecl-xdiff-1.5.1-r1.ebuild:
diff --git a/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r1.ebuild b/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..5385c4721b8a
--- /dev/null
+++ b/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r1.ebuild,v 1.1 2013/11/07 22:28:42 mabi Exp $
+
+EAPI=4
+
+PHP_EXT_NAME="xdiff"
+PHP_EXT_PECL_PKG="xdiff"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README.API"
+
+USE_PHP="php5-3 php5-4 php5-5"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~x86 ~amd64"
+
+DESCRIPTION="PHP extension for generating diff files"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/libxdiff"
+RDEPEND="${DEPEND}"