summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-04-06 18:51:44 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-04-06 18:51:44 +0000
commit2d907e7b465e78b4334d22657448cf32a9a01424 (patch)
tree2baceadc0b29d10c1b15bc09572e15ed1d2cd1a7 /dev-php/pecl-imagick
parentMask calligra-2.4.0 until it is released (diff)
downloadgentoo-2-2d907e7b465e78b4334d22657448cf32a9a01424.tar.gz
gentoo-2-2d907e7b465e78b4334d22657448cf32a9a01424.tar.bz2
gentoo-2-2d907e7b465e78b4334d22657448cf32a9a01424.zip
Version bump. RC that works with php 5.4
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/pecl-imagick')
-rw-r--r--dev-php/pecl-imagick/ChangeLog10
-rw-r--r--dev-php/pecl-imagick/pecl-imagick-3.1.0_rc1.ebuild34
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-php/pecl-imagick/ChangeLog b/dev-php/pecl-imagick/ChangeLog
index e3396e1f8b66..951dee71759a 100644
--- a/dev-php/pecl-imagick/ChangeLog
+++ b/dev-php/pecl-imagick/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/pecl-imagick
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-imagick/ChangeLog,v 1.1 2011/12/14 22:39:57 mabi Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-imagick/ChangeLog,v 1.2 2012/04/06 18:51:44 olemarkus Exp $
+
+*pecl-imagick-3.1.0_rc1 (06 Apr 2012)
+
+ 06 Apr 2012; Ole Markus With <olemarkus@gentoo.org>
+ +pecl-imagick-3.1.0_rc1.ebuild:
+ Version bump. RC that works with php 5.4
08 Jan 2011; Brent Baude <ranger@gentoo.org> pecl-imagick-3.0.0-r1.ebuild:
Marking pecl-imagick-3.0.0-r1 ~ppc for bug 349659
diff --git a/dev-php/pecl-imagick/pecl-imagick-3.1.0_rc1.ebuild b/dev-php/pecl-imagick/pecl-imagick-3.1.0_rc1.ebuild
new file mode 100644
index 000000000000..ded731582096
--- /dev/null
+++ b/dev-php/pecl-imagick/pecl-imagick-3.1.0_rc1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-imagick/pecl-imagick-3.1.0_rc1.ebuild,v 1.1 2012/04/06 18:51:44 olemarkus Exp $
+
+EAPI=4
+
+PHP_EXT_NAME="imagick"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="TODO"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+PECL_PKG_V="${PECL_PKG}-${MY_PV}"
+FILENAME="${PECL_PKG_V}.tgz"
+S="${WORKDIR}/${PECL_PKG_V}"
+
+USE_PHP="php5-3 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP wrapper for the ImageMagick library."
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="examples"
+
+DEPEND=">=media-gfx/imagemagick-6.2.4"
+RDEPEND="${DEPEND}"
+
+SRC_URI="http://pecl.php.net/get/${FILENAME}"
+
+my_conf="--with-imagick=/usr"