summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-02-28 19:24:54 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-02-28 19:24:54 +0000
commitf7f89acfdfd4ed7e82cf841d6628611b060f76ef (patch)
tree80413d826f45a428294da09a8468446d3e572f87 /dev-php/pear
parentVersion bump (diff)
downloadgentoo-2-f7f89acfdfd4ed7e82cf841d6628611b060f76ef.tar.gz
gentoo-2-f7f89acfdfd4ed7e82cf841d6628611b060f76ef.tar.bz2
gentoo-2-f7f89acfdfd4ed7e82cf841d6628611b060f76ef.zip
Version bump
(Portage version: 2.1.9.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/pear')
-rw-r--r--dev-php/pear/ChangeLog7
-rw-r--r--dev-php/pear/pear-1.9.2.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-php/pear/ChangeLog b/dev-php/pear/ChangeLog
index bb87621b1a15..c525ab1f76ed 100644
--- a/dev-php/pear/ChangeLog
+++ b/dev-php/pear/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/pear
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pear/ChangeLog,v 1.14 2011/01/10 18:08:47 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pear/ChangeLog,v 1.15 2011/02/28 19:24:54 olemarkus Exp $
+
+*pear-1.9.2 (28 Feb 2011)
+
+ 28 Feb 2011; <olemarkus@gentoo.org> +pear-1.9.2.ebuild:
+ Version bump
10 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org> pear-1.9.1.ebuild:
ppc stable wrt #294256
diff --git a/dev-php/pear/pear-1.9.2.ebuild b/dev-php/pear/pear-1.9.2.ebuild
new file mode 100644
index 000000000000..91d54c64f511
--- /dev/null
+++ b/dev-php/pear/pear-1.9.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pear/pear-1.9.2.ebuild,v 1.1 2011/02/28 19:24:54 olemarkus Exp $
+
+inherit depend.php
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="PEAR - PHP Extension and Application Repository"
+HOMEPAGE="http://pear.php.net/"
+SRC_URI=""
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="!<dev-php/PEAR-PEAR-1.8.1
+ ~dev-php/PEAR-PEAR-${PV}
+ >=dev-php/PEAR-Archive_Tar-1.3.7
+ >=dev-php/PEAR-Console_Getopt-1.2.3
+ >=dev-php/PEAR-Structures_Graph-1.0.2
+ >=dev-php/PEAR-XML_Util-1.2.1"
+
+src_install() {
+ :;
+}
+
+pkg_postinst() {
+ pear clear-cache
+
+ # Update PEAR/PECL channels as needed, add new ones to the list if needed
+ elog "Updating PEAR/PECL channels"
+ local pearchans="pear.php.net pecl.php.net components.ez.no
+ pear.propelorm.org pear.phing.info pear.symfony-project.com pear.phpunit.de
+ pear.php-baustelle.de pear.phpontrax.com pear.agavi.org"
+
+ for chan in ${pearchans} ; do
+ pear channel-discover ${chan}
+ pear channel-update ${chan}
+ done
+}