summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2012-01-28 14:07:29 +0000
committerMatti Bickel <mabi@gentoo.org>2012-01-28 14:07:29 +0000
commit3463e75782a3e5d04e0242040cfd9e476d3254be (patch)
tree761150afa5afaaa23836d3fa16863d2dbef440a4 /dev-php/onphp
parentEAPI bump (diff)
downloadgentoo-2-3463e75782a3e5d04e0242040cfd9e476d3254be.tar.gz
gentoo-2-3463e75782a3e5d04e0242040cfd9e476d3254be.tar.bz2
gentoo-2-3463e75782a3e5d04e0242040cfd9e476d3254be.zip
remove unneeded php-lib-r1.php reference, EAPI bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/onphp')
-rw-r--r--dev-php/onphp/ChangeLog8
-rw-r--r--dev-php/onphp/onphp-0.10.13.ebuild33
-rw-r--r--dev-php/onphp/onphp-1.0.10.ebuild13
-rw-r--r--dev-php/onphp/onphp-1.0.9.ebuild33
4 files changed, 12 insertions, 75 deletions
diff --git a/dev-php/onphp/ChangeLog b/dev-php/onphp/ChangeLog
index 4e7b412b9dc2..d917a3b76a3c 100644
--- a/dev-php/onphp/ChangeLog
+++ b/dev-php/onphp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php5/onphp
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/onphp/ChangeLog,v 1.6 2011/04/10 17:30:40 olemarkus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/onphp/ChangeLog,v 1.7 2012/01/28 14:07:28 mabi Exp $
+
+ 26 Jan 2012; Matti Bickel <mabi@gentoo.org> -onphp-0.10.13.ebuild,
+ -onphp-1.0.9.ebuild, onphp-1.0.10.ebuild:
+ remove unneeded php-lib-r1.php reference, EAPI bump
*onphp-1.0.10 (03 Nov 2010)
diff --git a/dev-php/onphp/onphp-0.10.13.ebuild b/dev-php/onphp/onphp-0.10.13.ebuild
deleted file mode 100644
index b55701559565..000000000000
--- a/dev-php/onphp/onphp-0.10.13.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/onphp/onphp-0.10.13.ebuild,v 1.1 2011/04/10 17:30:40 olemarkus Exp $
-
-inherit php-lib-r1
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="onPHP is the LGPL'ed multi-purpose object-oriented PHP framework."
-HOMEPAGE="http://onphp.org/"
-SRC_URI="http://onphp.org/download/${P}.tar.bz2
- doc? ( http://onphp.org/download/${PN}-api-${PV}.tar.bz2 )"
-LICENSE="LGPL-3"
-SLOT="0"
-IUSE="doc"
-
-DEPEND=""
-RDEPEND=""
-
-need_php_by_category
-
-src_install() {
- has_php
-
- dodoc `find doc -maxdepth 1 -type f -print`
-
- if use doc ; then
- dohtml -r "${WORKDIR}/${PN}-api-${PV}/"*
- fi
-
- php-lib-r1_src_install ./ global.inc.php.tpl
- php-lib-r1_src_install ./ `find core main meta -type f -print`
-}
diff --git a/dev-php/onphp/onphp-1.0.10.ebuild b/dev-php/onphp/onphp-1.0.10.ebuild
index 220628ccf31c..ce0f6a118029 100644
--- a/dev-php/onphp/onphp-1.0.10.ebuild
+++ b/dev-php/onphp/onphp-1.0.10.ebuild
@@ -1,10 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/onphp/onphp-1.0.10.ebuild,v 1.1 2011/04/10 17:30:40 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/onphp/onphp-1.0.10.ebuild,v 1.2 2012/01/28 14:07:28 mabi Exp $
-EAPI="3"
-
-inherit php-lib-r1
+EAPI="4"
KEYWORDS="~amd64 ~x86"
@@ -26,6 +24,7 @@ src_install() {
dohtml -r "${WORKDIR}/${PN}-api-${PV}/"*
fi
- php-lib-r1_src_install ./ global.inc.php.tpl
- php-lib-r1_src_install ./ `find core main meta -type f -print`
+ insinto "/usr/share/php/${PN}"
+ doins global.inc.php.tpl
+ doins -r core main meta
}
diff --git a/dev-php/onphp/onphp-1.0.9.ebuild b/dev-php/onphp/onphp-1.0.9.ebuild
deleted file mode 100644
index 2854b3039e66..000000000000
--- a/dev-php/onphp/onphp-1.0.9.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/onphp/onphp-1.0.9.ebuild,v 1.1 2011/04/10 17:30:40 olemarkus Exp $
-
-inherit php-lib-r1
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="onPHP is the LGPL'ed multi-purpose object-oriented PHP framework."
-HOMEPAGE="http://onphp.org/"
-SRC_URI="http://onphp.org/download/${P}.tar.bz2
- doc? ( http://onphp.org/download/${PN}-api-${PV}.tar.bz2 )"
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="doc"
-
-DEPEND=""
-RDEPEND=""
-
-need_php_by_category
-
-src_install() {
- has_php
-
- dodoc `find doc -maxdepth 1 -type f -print`
-
- if use doc ; then
- dohtml -r "${WORKDIR}/${PN}-api-${PV}/"*
- fi
-
- php-lib-r1_src_install ./ global.inc.php.tpl
- php-lib-r1_src_install ./ `find core main meta -type f -print`
-}