summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2005-10-11 04:51:36 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2005-10-11 04:51:36 +0000
commit5f9f6adc621d91c922b2f8f7883b84c74b61f391 (patch)
tree2e52d13035149c6366f3eaed9de695f448f1d281 /dev-php/eaccelerator
parent2nd half of fixing libxfcegui4 for gtk+ 2.8 breakage (diff)
downloadgentoo-2-5f9f6adc621d91c922b2f8f7883b84c74b61f391.tar.gz
gentoo-2-5f9f6adc621d91c922b2f8f7883b84c74b61f391.tar.bz2
gentoo-2-5f9f6adc621d91c922b2f8f7883b84c74b61f391.zip
Fix for bug 107467 by Luca Longinotti <chtekk@longitekk.com>.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'dev-php/eaccelerator')
-rw-r--r--dev-php/eaccelerator/ChangeLog6
-rw-r--r--dev-php/eaccelerator/eaccelerator-0.9.3-r1.ebuild60
2 files changed, 29 insertions, 37 deletions
diff --git a/dev-php/eaccelerator/ChangeLog b/dev-php/eaccelerator/ChangeLog
index 5ccc13f1a334..0e71c29aec7c 100644
--- a/dev-php/eaccelerator/ChangeLog
+++ b/dev-php/eaccelerator/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/eaccelerator
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/eaccelerator/ChangeLog,v 1.17 2005/08/17 08:01:04 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/eaccelerator/ChangeLog,v 1.18 2005/10/11 04:48:31 sebastian Exp $
+
+ 11 Oct 2005; Sebastian Bergmann <sebastian@gentoo.org>
+ eaccelerator-0.9.3-r1.ebuild:
+ Fix for bug 107467 by Luca Longinotti <chtekk@longitekk.com>.
17 Aug 2005; Sebastian Bergmann <sebastian@gentoo.org>
eaccelerator-0.9.3.ebuild, eaccelerator-0.9.3-r1.ebuild:
diff --git a/dev-php/eaccelerator/eaccelerator-0.9.3-r1.ebuild b/dev-php/eaccelerator/eaccelerator-0.9.3-r1.ebuild
index cce08cbd02f6..07f71cfdb818 100644
--- a/dev-php/eaccelerator/eaccelerator-0.9.3-r1.ebuild
+++ b/dev-php/eaccelerator/eaccelerator-0.9.3-r1.ebuild
@@ -1,63 +1,45 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/eaccelerator/eaccelerator-0.9.3-r1.ebuild,v 1.4 2005/08/17 08:01:04 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/eaccelerator/eaccelerator-0.9.3-r1.ebuild,v 1.5 2005/10/11 04:48:31 sebastian Exp $
-PHP_EXT_NAME="eaccelerator"
PHP_EXT_ZENDEXT="yes"
+PHP_EXT_NAME="eaccelerator"
+PHP_EXT_INI="yes"
+
[ -z "${EACCELERATOR_CACHEDIR}" ] && EACCELERATOR_CACHEDIR=/var/cache/eaccelerator
+
inherit php-ext-source
DESCRIPTION="A PHP Accelerator & Encoder."
HOMEPAGE="http://www.eaccelerator.net/"
SRC_URI="mirror://sourceforge/eaccelerator/${P}.tar.gz"
-IUSE="apache2 inode session"
+IUSE="inode session"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
-DEPEND="$DEPEND
+DEPEND="${DEPEND}
+ =virtual/httpd-php-4*
!dev-php/ioncube_loaders
!dev-php/PECL-apc"
-HTTPD_USER=root
-HTTPD_GROUP=root
-
-has_version "net-www/apache" && USE_APACHE=1 && inherit webapp-apache
-[ -n "${USE_APACHE}" ] && webapp-detect || NO_WEBSERVER=1
-
-pkg_setup() {
- if [ "${NO_WEBSERVER}" = "1" ]; then
- ewarn "No webserver detected - ${EACCELERATOR_CACHEDIR} will be"
- ewarn "owned by ${HTTPD_USER} instead"
- else
- einfo "Configuring cache dir ${EACCELERATOR_CACHEDIR} for ${WEBAPP_SERVER}"
- fi
-}
+# this is a good example of why we need all web servers installed under a
+# common 'www' user and group!
+HTTPD_USER=apache
+HTTPD_GROUP=apache
src_compile() {
- # eAccelerator does not work with Zend Thread Safety (ZTS)
- # so about if we are using Apache 2 with an MPM that would
- # require ZTS.
- if use apache2; then
- APACHE2_MPM="`/usr/sbin/apache2 -l | egrep 'worker|perchild|leader|threadpool|prefork'|cut -d. -f1|sed -e 's/^[[:space:]]*//g;s/[[:space:]]+/ /g;'`"
- case "${APACHE2_MPM}" in
- *prefork*) ;;
- *) eerror "eAccelerator does not yet work with the Apache 2 MPM in use." ; die ;;
- esac;
- fi
-
- myconf="--enable-eaccelerator=shared"
+ my_conf="--enable-eaccelerator=shared"
if use !session; then
- myconf="${myconf} --without-eaccelerator-sessions"
+ my_conf="${my_conf} --without-eaccelerator-sessions"
fi
if use !inode; then
- myconf="${myconf} --without-eaccelerator-use-inode"
+ my_conf="${my_conf} --without-eaccelerator-use-inode"
fi
export WANT_AUTOMAKE=1.6
-
php-ext-source_src_compile
}
@@ -92,9 +74,15 @@ src_install() {
php-ext-base_addtoinifiles ";eaccelerator.admin.password" '"hashed_password"'
}
-pkg_postinst () {
- einfo "You need to restart your webserver to activate eAccelerator."
- einfo
+pkg_postinst() {
+ # you only need to restart the webserver if you're using mod_php
+ if has_version "dev-php/mod_php" ; then
+ einfo "You need to restart your webserver to activate eAccelerator."
+ einfo
+ fi
+
+ # this web interface needs moving into a separate, webapp-config compatible
+ # package!!
einfo "A web interface is available to manage the eAccelerator cache."
einfo "Copy /usr/share/eaccelerator/*.php to somewhere"
einfo "where your web server can see it. See the documentation on how"