summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-07-17 07:07:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-07-17 07:07:32 +0000
commitccaf61e3f0d640281d9862b85a1999f62967d998 (patch)
tree14dfee1a4ca59d4b6ea7116b017d116798a37d3a /dev-php/awl
parentBuild with gcc-4.7 Bug #426442 (diff)
downloadgentoo-2-ccaf61e3f0d640281d9862b85a1999f62967d998.tar.gz
gentoo-2-ccaf61e3f0d640281d9862b85a1999f62967d998.tar.bz2
gentoo-2-ccaf61e3f0d640281d9862b85a1999f62967d998.zip
Bump
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/awl')
-rw-r--r--dev-php/awl/ChangeLog7
-rw-r--r--dev-php/awl/awl-0.53.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-php/awl/ChangeLog b/dev-php/awl/ChangeLog
index 6ea60e6f6e16..758130ec7988 100644
--- a/dev-php/awl/ChangeLog
+++ b/dev-php/awl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/awl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/awl/ChangeLog,v 1.3 2012/06/26 09:36:20 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/awl/ChangeLog,v 1.4 2012/07/17 07:07:32 patrick Exp $
+
+*awl-0.53 (17 Jul 2012)
+
+ 17 Jul 2012; Patrick Lauer <patrick@gentoo.org> +awl-0.53.ebuild:
+ Bump
*awl-0.52 (26 Jun 2012)
diff --git a/dev-php/awl/awl-0.53.ebuild b/dev-php/awl/awl-0.53.ebuild
new file mode 100644
index 000000000000..14018cf7789a
--- /dev/null
+++ b/dev-php/awl/awl-0.53.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/awl/awl-0.53.ebuild,v 1.1 2012/07/17 07:07:32 patrick Exp $
+
+EAPI=2
+
+inherit depend.php php-lib-r1
+
+DESCRIPTION="Andrew McMillan's web libraries: A collection of generic classes
+used by the davical calendar server"
+HOMEPAGE="http://andrew.mcmillan.net.nz/projects/awl"
+SRC_URI="http://debian.mcmillan.net.nz/packages/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-lang/php[pdo,postgres,xml]
+ doc? ( dev-php/PEAR-PhpDocumentor )"
+RDEPEND="${DEPEND}"
+
+need_php5
+
+src_compile() {
+ if use doc ; then
+ ebegin "Generating documentation"
+ phpdoc -c "docs/api/phpdoc.ini" || die "Documentation failed to build"
+ fi
+}
+
+src_install() {
+ local docs="debian/README.Debian debian/changelog"
+ dodoc-php ${docs} || die "dodoc failed"
+
+ if use doc ; then
+ dohtml -r "docs/api/" || die "dohtml failed"
+ fi
+
+ php-lib-r1_src_install . dba/* inc/* scripts/*
+}