summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2013-04-04 20:26:04 +0000
committerMatti Bickel <mabi@gentoo.org>2013-04-04 20:26:04 +0000
commit2137d9f02baaea6ce94ac3b4decd7f6f2bf19f7d (patch)
tree5666bce45f919af0d9cfad91cb31043a421dc414 /dev-php/awl
parentStable for x86, wrt bug #463426 (diff)
downloadgentoo-2-2137d9f02baaea6ce94ac3b4decd7f6f2bf19f7d.tar.gz
gentoo-2-2137d9f02baaea6ce94ac3b4decd7f6f2bf19f7d.tar.bz2
gentoo-2-2137d9f02baaea6ce94ac3b4decd7f6f2bf19f7d.zip
eapi bump, only require php at runtime
(Portage version: 2.2.0_alpha168/cvs/Linux x86_64, signed Manifest commit with key 0x4849EC6C)
Diffstat (limited to 'dev-php/awl')
-rw-r--r--dev-php/awl/ChangeLog7
-rw-r--r--dev-php/awl/awl-0.53-r1.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-php/awl/ChangeLog b/dev-php/awl/ChangeLog
index 63e5f1637945..43de621f68e6 100644
--- a/dev-php/awl/ChangeLog
+++ b/dev-php/awl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/awl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/awl/ChangeLog,v 1.5 2013/03/17 15:57:57 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/awl/ChangeLog,v 1.6 2013/04/04 20:26:04 mabi Exp $
+
+*awl-0.53-r1 (04 Apr 2013)
+
+ 04 Apr 2013; Matti Bickel <mabi@gentoo.org> +awl-0.53-r1.ebuild:
+ eapi bump, only require php at runtime
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/dev-php/awl/awl-0.53-r1.ebuild b/dev-php/awl/awl-0.53-r1.ebuild
new file mode 100644
index 000000000000..89f9588bb036
--- /dev/null
+++ b/dev-php/awl/awl-0.53-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/awl/awl-0.53-r1.ebuild,v 1.1 2013/04/04 20:26:04 mabi Exp $
+
+EAPI=4
+
+DESCRIPTION="Andrew McMillan's web libraries: A collection of generic classes
+used by the davical calendar server"
+HOMEPAGE="http://andrew.mcmillan.net.nz/projects/awl"
+SRC_URI="http://debian.mcmillan.net.nz/packages/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-php/PEAR-PhpDocumentor )"
+RDEPEND="dev-lang/php[pdo,postgres,xml]"
+
+DOCS="debian/README.Debian debian/changelog"
+
+src_compile() {
+ if use doc ; then
+ ebegin "Generating documentation"
+ phpdoc -c "docs/api/phpdoc.ini" || die "Documentation failed to build"
+ fi
+}
+
+src_install() {
+ use doc && dohtml -r "docs/api/"
+ insinto "/usr/share/php/${PN}"
+ doins -r dba inc scripts
+}