summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2013-11-27 17:45:05 +0000
committerMatti Bickel <mabi@gentoo.org>2013-11-27 17:45:05 +0000
commit5dc43dd52df36e5dc7c04d55b7ed1e1e413026b0 (patch)
tree5d439a1a6fbc2cd03dfc5ad5af4782e14e40a8fe /dev-php/PEAR-File_Find
parentVersion bump (bug #481470). Drop old versions. (diff)
downloadgentoo-2-5dc43dd52df36e5dc7c04d55b7ed1e1e413026b0.tar.gz
gentoo-2-5dc43dd52df36e5dc7c04d55b7ed1e1e413026b0.tar.bz2
gentoo-2-5dc43dd52df36e5dc7c04d55b7ed1e1e413026b0.zip
force unpack despite lone zero block (bug #476542)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xDDF971F118EEA5E6!)
Diffstat (limited to 'dev-php/PEAR-File_Find')
-rw-r--r--dev-php/PEAR-File_Find/ChangeLog5
-rw-r--r--dev-php/PEAR-File_Find/PEAR-File_Find-1.3.2.ebuild9
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-php/PEAR-File_Find/ChangeLog b/dev-php/PEAR-File_Find/ChangeLog
index 6e5c0195bcde..8c2b98cbd9ba 100644
--- a/dev-php/PEAR-File_Find/ChangeLog
+++ b/dev-php/PEAR-File_Find/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-php/PEAR-File_Find
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-File_Find/ChangeLog,v 1.34 2013/07/03 21:15:22 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-File_Find/ChangeLog,v 1.35 2013/11/27 17:45:05 mabi Exp $
+
+ 27 Nov 2013; Matti Bickel <mabi@gentoo.org> PEAR-File_Find-1.3.2.ebuild:
+ force unpack despite lone zero block (bug #476542)
*PEAR-File_Find-1.3.2 (03 Jul 2013)
diff --git a/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.2.ebuild b/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.2.ebuild
index b53e4ad9457c..bce493ccd6b7 100644
--- a/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.2.ebuild
+++ b/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.2.ebuild,v 1.1 2013/07/03 21:15:22 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-File_Find/PEAR-File_Find-1.3.2.ebuild,v 1.2 2013/11/27 17:45:05 mabi Exp $
-EAPI="4"
+EAPI="5"
inherit php-pear-r1
@@ -11,3 +11,8 @@ LICENSE="PHP-2.02"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
+
+src_unpack() {
+ # see bug #476542
+ tar xof "${DISTDIR}/${A}" --ignore-zeros
+}