summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-01-01 22:54:03 +0000
committerTorsten Veller <tove@gentoo.org>2010-01-01 22:54:03 +0000
commite7f399c2da22d880588e7d92f280b64b7a848d14 (patch)
treec3e4a32e91203faea0e52528e70ab07d1216dbb8 /dev-perl
parentVersion bump (diff)
downloadgentoo-2-e7f399c2da22d880588e7d92f280b64b7a848d14.tar.gz
gentoo-2-e7f399c2da22d880588e7d92f280b64b7a848d14.tar.bz2
gentoo-2-e7f399c2da22d880588e7d92f280b64b7a848d14.zip
Fix pod test (#299280). Add ~amd64
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/CPAN-Mini-Phalanx/CPAN-Mini-Phalanx-0.01.ebuild31
-rw-r--r--dev-perl/CPAN-Mini-Phalanx/ChangeLog8
2 files changed, 23 insertions, 16 deletions
diff --git a/dev-perl/CPAN-Mini-Phalanx/CPAN-Mini-Phalanx-0.01.ebuild b/dev-perl/CPAN-Mini-Phalanx/CPAN-Mini-Phalanx-0.01.ebuild
index f243d5316728..b1ae20d8a445 100644
--- a/dev-perl/CPAN-Mini-Phalanx/CPAN-Mini-Phalanx-0.01.ebuild
+++ b/dev-perl/CPAN-Mini-Phalanx/CPAN-Mini-Phalanx-0.01.ebuild
@@ -1,25 +1,28 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/CPAN-Mini-Phalanx/CPAN-Mini-Phalanx-0.01.ebuild,v 1.6 2006/08/04 22:48:32 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/CPAN-Mini-Phalanx/CPAN-Mini-Phalanx-0.01.ebuild,v 1.7 2010/01/01 22:54:03 tove Exp $
-inherit perl-module
+EAPI=2
-MY_PN="${PN}100"
+MODULE_AUTHOR=SMPETERS
+MY_PN=${PN}100
MY_P=${MY_PN}-${PV}
-S="${WORKDIR}/$MY_P"
+S=${WORKDIR}/${MY_P}
+inherit perl-module
DESCRIPTION="create a minimal mirror of CPAN containing the modules in the Phalanx 100"
-HOMEPAGE="http://search.cpan.org/~smpeters/${MY_P}/"
-SRC_URI="mirror://cpan/authors/id/S/SM/SMPETERS/${MY_P}.tar.gz"
-LICENSE="Artistic"
-#LICENSE="|| ( Artistic GPL-2 )"
SLOT="0"
-KEYWORDS="ia64 sparc x86"
-IUSE=""
+KEYWORDS="~amd64 ia64 sparc x86"
+IUSE="test"
+
+RDEPEND="dev-perl/CPAN-Mini"
+DEPEND="test? ( dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
SRC_TEST="do"
-DEPEND="dev-perl/CPAN-Mini
- dev-lang/perl"
-RDEPEND="${DEPEND}"
+src_prepare() {
+ perl-module_src_prepare
+ sed -i 's,^L<Phalanx Project|,L<,' "${S}"/lib/CPAN/Mini/Phalanx100.pm || die
+}
diff --git a/dev-perl/CPAN-Mini-Phalanx/ChangeLog b/dev-perl/CPAN-Mini-Phalanx/ChangeLog
index 73d7dd6092a8..cf1dc4ab70b0 100644
--- a/dev-perl/CPAN-Mini-Phalanx/ChangeLog
+++ b/dev-perl/CPAN-Mini-Phalanx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/CPAN-Mini-Phalanx
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/CPAN-Mini-Phalanx/ChangeLog,v 1.7 2007/02/22 01:44:21 peper Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/CPAN-Mini-Phalanx/ChangeLog,v 1.8 2010/01/01 22:54:03 tove Exp $
+
+ 01 Jan 2010; Torsten Veller <tove@gentoo.org>
+ CPAN-Mini-Phalanx-0.01.ebuild:
+ Fix pod test (#299280). Add ~amd64
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.