summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-10-15 05:50:21 +0000
committerAchim Gottinger <achim@gentoo.org>2001-10-15 05:50:21 +0000
commitcfdd62da551975e63e98c491ae7d7291bba97b62 (patch)
tree6e0217303a7b92a3b9c0bc24927d69bb58ea6622 /dev-perl
parent*** empty log message *** (diff)
downloadgentoo-2-cfdd62da551975e63e98c491ae7d7291bba97b62.tar.gz
gentoo-2-cfdd62da551975e63e98c491ae7d7291bba97b62.tar.bz2
gentoo-2-cfdd62da551975e63e98c491ae7d7291bba97b62.zip
New version. This version now builds all the gnome bindings if "gnome" is in use.
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/gtk-perl/gtk-perl-0.7008.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-perl/gtk-perl/gtk-perl-0.7008.ebuild b/dev-perl/gtk-perl/gtk-perl-0.7008.ebuild
index b075538aa3ed..f0e3ddacaa28 100644
--- a/dev-perl/gtk-perl/gtk-perl-0.7008.ebuild
+++ b/dev-perl/gtk-perl/gtk-perl-0.7008.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/gtk-perl/gtk-perl-0.7008.ebuild,v 1.1 2001/10/15 05:44:57 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/gtk-perl/gtk-perl-0.7008.ebuild,v 1.2 2001/10/15 05:50:21 achim Exp $
A=Gtk-Perl-${PV}.tar.gz
S=${WORKDIR}/Gtk-Perl-${PV}
@@ -9,11 +9,15 @@ DESCRIPTION="Perl bindings for GTK"
SRC_URI="ftp://ftp.rz.ruhr-uni-bochum.de/pub/CPAN/authors/id/L/LU/LUPUS/${A}"
HOMEPAGE="http://www.perl.org/"
-DEPEND=">=x11-libs/gtk+-1.2.10-r4 sys-devel/perl gnome? ( >=gnome-base/gnome-core-1.4 )"
+DEPEND=">=x11-libs/gtk+-1.2.10-r4 sys-devel/perl dev-perl/XML-Writer gnome? ( gnome-base/gnome-core )"
src_compile() {
- perl Makefile.PL
+ local myconf
+ if [ -z "`use gnome`" ] ; then
+ myconf="--without-guessing"
+ fi
+ perl Makefile.PL $myconf
try make
}