summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-05-17 00:29:55 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-05-17 00:29:55 +0000
commitbad7b5736ca756c8920925e67d9b5161254278f9 (patch)
tree62ce85356aae0cc7140e3777dffcd4c51cd2e544 /dev-perl
parentAdd nss-mdns dep on x86 instead of bundled library. (diff)
downloadgentoo-2-bad7b5736ca756c8920925e67d9b5161254278f9.tar.gz
gentoo-2-bad7b5736ca756c8920925e67d9b5161254278f9.tar.bz2
gentoo-2-bad7b5736ca756c8920925e67d9b5161254278f9.zip
Revbump with PARI_VER changed to allow 2.3.5 to be used. Passes testsuite.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/math-pari/ChangeLog8
-rw-r--r--dev-perl/math-pari/math-pari-2.01080604-r1.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-perl/math-pari/ChangeLog b/dev-perl/math-pari/ChangeLog
index f6641f77dc2d..d841fc16e8d4 100644
--- a/dev-perl/math-pari/ChangeLog
+++ b/dev-perl/math-pari/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/math-pari
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.61 2010/05/14 16:03:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.62 2010/05/17 00:29:55 robbat2 Exp $
+
+*math-pari-2.01080604-r1 (17 May 2010)
+
+ 17 May 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +math-pari-2.01080604-r1.ebuild:
+ Revbump with PARI_VER changed to allow 2.3.5 to be used. Passes testsuite.
14 May 2010; Jeroen Roovers <jer@gentoo.org> math-pari-2.01080604.ebuild:
Stable for HPPA (bug #318669).
diff --git a/dev-perl/math-pari/math-pari-2.01080604-r1.ebuild b/dev-perl/math-pari/math-pari-2.01080604-r1.ebuild
new file mode 100644
index 000000000000..d9118a8c2388
--- /dev/null
+++ b/dev-perl/math-pari/math-pari-2.01080604-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.01080604-r1.ebuild,v 1.1 2010/05/17 00:29:55 robbat2 Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=ILYAZ
+MODULE_SECTION=modules
+MY_PN=Math-Pari
+MY_P=${MY_PN}-${PV}
+inherit perl-module
+
+PARI_VER=2.3.5
+
+DESCRIPTION="Perl interface to PARI"
+SRC_URI="${SRC_URI}
+ http://pari.math.u-bordeaux.fr/pub/pari/unix/pari-${PARI_VER}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+# Math::Pari requires that a copy of the pari source in a parallel
+# directory to where you build it. It does not need to compile it, but
+# it does need to be the same version as is installed, hence the hard
+# DEPEND below
+RDEPEND="~sci-mathematics/pari-${PARI_VER}"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+S_PARI=${WORKDIR}/pari-${PARI_VER}
+SRC_TEST=do
+
+src_prepare() {
+ # On 64-bit hardware, these files are needed in both the 64/ and 32/
+ # directories for the testsuite to pass.
+ cd "${S_PARI}"/src/test/
+ for t in analyz compat ellglobalred elliptic galois graph intnum kernel \
+ linear nfields number objets ploth polyser program qfbsolve rfrac \
+ round4 stark sumiter trans ; do
+ i="in/${t}"
+ o32="32/${t}"
+ o64="64/${t}"
+ [ -f "$i" -a ! -f "$o32" ] && cp -al "$i" "$o32"
+ [ -f "$i" -a ! -f "$o64" ] && cp -al "$i" "$o64"
+ done
+ perl-module_src_prepare
+}
+
+src_configure() {
+ # Unfortunately the assembly routines math-pari has for SPARC do not appear
+ # to be working at current. Perl cannot test math-pari or anything that
+ # pulls in the math-pari module as DynaLoader cannot load the resulting
+ # .so files math-pari generates. As such, we have to use the generic
+ # non-machine specific assembly methods here.
+ use sparc && myconf="${myconf} machine=none"
+
+ perl-module_src_configure
+}