summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2006-08-13 05:54:16 +0000
committerChris White <chriswhite@gentoo.org>2006-08-13 05:54:16 +0000
commitb9606aed858ba5497d0f3d9167d6448a8f984b75 (patch)
treef0084fc3fbe765d63c4d0b1695a9f6612634d6d0 /dev-perl
parentVersion bumped (diff)
downloadgentoo-2-b9606aed858ba5497d0f3d9167d6448a8f984b75.tar.gz
gentoo-2-b9606aed858ba5497d0f3d9167d6448a8f984b75.tar.bz2
gentoo-2-b9606aed858ba5497d0f3d9167d6448a8f984b75.zip
Use logic in global scope makes baby jesus cry, moved to src_compile. Bug #143727.
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/math-pari/ChangeLog6
-rw-r--r--dev-perl/math-pari/math-pari-2.010706.ebuild17
2 files changed, 15 insertions, 8 deletions
diff --git a/dev-perl/math-pari/ChangeLog b/dev-perl/math-pari/ChangeLog
index 3ee72982d826..e26be7499cab 100644
--- a/dev-perl/math-pari/ChangeLog
+++ b/dev-perl/math-pari/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/math-pari
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.29 2006/08/12 21:30:24 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.30 2006/08/13 05:54:16 chriswhite Exp $
+
+ 13 Aug 2006; Chris White <chriswhite@gentoo.org>
+ math-pari-2.010706.ebuild:
+ Moved use sparc logic to src_compile and out of global scope for bug #143727.
12 Aug 2006; Jason Wever <weeve@gentoo.org> math-pari-2.010706.ebuild:
Adjusted machine detection for SPARC as the native SPARC assembly routines
diff --git a/dev-perl/math-pari/math-pari-2.010706.ebuild b/dev-perl/math-pari/math-pari-2.010706.ebuild
index 579d75125316..91d183d01352 100644
--- a/dev-perl/math-pari/math-pari-2.010706.ebuild
+++ b/dev-perl/math-pari/math-pari-2.010706.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010706.ebuild,v 1.4 2006/08/12 21:30:24 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010706.ebuild,v 1.5 2006/08/13 05:54:16 chriswhite Exp $
inherit perl-module eutils
@@ -26,10 +26,13 @@ DEPEND="~sci-mathematics/pari-2.1.7
dev-lang/perl"
RDEPEND="${DEPEND}"
-# Unfortunately the assembly routines math-pari has for SPARC do not appear
-# to be working at current. Perl cannot test math-pari or anything that pulls
-# in the math-pari module as DynaLoader cannot load the resulting .so files
-# math-pari generates. As such, we have to use the generic non-machine
-# specific assembly methods here.
+src_compile() {
+ # Unfortunately the assembly routines math-pari has for SPARC do not appear
+ # to be working at current. Perl cannot test math-pari or anything that pulls
+ # in the math-pari module as DynaLoader cannot load the resulting .so files
+ # math-pari generates. As such, we have to use the generic non-machine
+ # specific assembly methods here.
+ use sparc && myconf="${myconf} machine=none"
-use sparc && myconf="${myconf} machine=none"
+ perl-module_src_compile
+}