summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2014-06-13 19:08:35 +0000
committerMikle Kolyada <zlogene@gentoo.org>2014-06-13 19:08:35 +0000
commitb129fbf4a66d9a46045c3f1ac5774a4897496b1f (patch)
tree142ba7bf237a5687e0543387fc7bcc551e011fe5 /dev-perl
parentStable for HPPA (bug #512516). (diff)
downloadgentoo-2-b129fbf4a66d9a46045c3f1ac5774a4897496b1f.tar.gz
gentoo-2-b129fbf4a66d9a46045c3f1ac5774a4897496b1f.tar.bz2
gentoo-2-b129fbf4a66d9a46045c3f1ac5774a4897496b1f.zip
Version bump wrt bug #511498
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xC42EB5D6)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/DBD-Pg/ChangeLog9
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-3.3.0.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-perl/DBD-Pg/ChangeLog b/dev-perl/DBD-Pg/ChangeLog
index 4461c7676e53..87287433ff86 100644
--- a/dev-perl/DBD-Pg/ChangeLog
+++ b/dev-perl/DBD-Pg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/DBD-Pg
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.133 2013/01/08 18:27:04 tove Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.134 2014/06/13 19:08:35 zlogene Exp $
+
+*DBD-Pg-3.3.0 (13 Jun 2014)
+
+ 13 Jun 2014; Mikle Kolyada <zlogene@gentoo.org> +DBD-Pg-3.3.0.ebuild:
+ Version bump wrt bug #511498
08 Jan 2013; Torsten Veller <tove@gentoo.org> -DBD-Pg-2.19.2.ebuild:
Cleanup
diff --git a/dev-perl/DBD-Pg/DBD-Pg-3.3.0.ebuild b/dev-perl/DBD-Pg/DBD-Pg-3.3.0.ebuild
new file mode 100644
index 000000000000..b78570182854
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-3.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/DBD-Pg-3.3.0.ebuild,v 1.1 2014/06/13 19:08:35 zlogene Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=TURNSTEP
+MODULE_VERSION=3.3.0
+inherit perl-module
+
+DESCRIPTION="The Perl DBD::Pg Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="virtual/perl-version
+ >=dev-perl/DBI-1.52
+ dev-db/postgresql-base"
+DEPEND="${RDEPEND}"
+
+# testcases require a local database with an
+# open password for the postgres user.
+SRC_TEST="skip"
+
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}