summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-02-27 20:18:19 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-02-27 20:18:19 +0000
commitaad1a2cdd369f423753c0869e207ded96808e297 (patch)
tree360b45d0d25bc94fe15fbe8ff3ae8c0acd57922a /dev-perl
parentFix DEPEND/RDEPEND for bug #210856 (diff)
downloadgentoo-2-aad1a2cdd369f423753c0869e207ded96808e297.tar.gz
gentoo-2-aad1a2cdd369f423753c0869e207ded96808e297.tar.bz2
gentoo-2-aad1a2cdd369f423753c0869e207ded96808e297.zip
fix built_with_use issues. bug #193661
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/GD/ChangeLog7
-rw-r--r--dev-perl/GD/GD-2.35-r1.ebuild40
2 files changed, 42 insertions, 5 deletions
diff --git a/dev-perl/GD/ChangeLog b/dev-perl/GD/ChangeLog
index c3c23eff0cb3..c9ce78239ecf 100644
--- a/dev-perl/GD/ChangeLog
+++ b/dev-perl/GD/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-perl/GD
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/ChangeLog,v 1.74 2007/07/22 07:56:29 graaff Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/ChangeLog,v 1.75 2008/02/27 20:18:19 cardoe Exp $
+
+ 27 Feb 2008; Doug Klima <cardoe@gentoo.org> GD-2.35-r1.ebuild:
+ fix built_with_use issues. bug #193661
22 Jul 2007; Hans de Graaff <graaff@gentoo.org> GD-2.30.ebuild,
GD-2.32.ebuild, GD-2.34.ebuild, GD-2.35.ebuild, GD-2.35-r1.ebuild:
diff --git a/dev-perl/GD/GD-2.35-r1.ebuild b/dev-perl/GD/GD-2.35-r1.ebuild
index e0a8f6433684..e5c2ea9ba286 100644
--- a/dev-perl/GD/GD-2.35-r1.ebuild
+++ b/dev-perl/GD/GD-2.35-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/GD-2.35-r1.ebuild,v 1.11 2007/07/22 07:56:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/GD-2.35-r1.ebuild,v 1.12 2008/02/27 20:18:19 cardoe Exp $
inherit eutils perl-module
DESCRIPTION="interface to Thomas Boutell's gd library"
-HOMEPAGE="http://www.cpan.org/modules/by-module/GD/${P}.readme"
+HOMEPAGE="http://www.cpan.org/modules/by-module/GD/"
SRC_URI="mirror://cpan/authors/id/L/LD/LDS/${P}.tar.gz"
LICENSE="|| ( Artistic GPL-2 )"
@@ -21,6 +21,40 @@ DEPEND=">=media-libs/gd-2.0.33
gif? ( media-libs/giflib )
dev-lang/perl"
+pkg_setup() {
+ local i_can_has_die=0
+
+ if use jpeg && ! built_with_use media-libs/gd jpeg; then
+ echo
+ eerror "If you want to compile dev-perl/GD with USE=jpeg, you must first"
+ eerror "compile media-libs/gd with USE=jpeg"
+ i_can_has_die=1
+ fi
+
+ if use truetype && ! built_with_use media-libs/gd truetype; then
+ echo
+ eerror "If you want to compile dev-perl/GD with USE=truetype, you must first"
+ eerror "compile media-libs/gd with USE=truetype"
+ i_can_has_die=1
+ fi
+
+ if use png && ! built_with_use media-libs/gd png; then
+ echo
+ eerror "If you want to compile dev-perl/GD with USE=png, you must first"
+ eerror "compile media-libs/gd with USE=png"
+ i_can_has_die=1
+ fi
+
+ if use xpm && ! built_with_use media-libs/gd xpm; then
+ echo
+ eerror "If you want to compile dev-perl/GD with USE=xpm, you must first"
+ eerror "compile media-libs/gd with USE=xpm"
+ i_can_has_die=1
+ fi
+
+ [[ ${i_can_has_die} -ne 0 ]] && die "Please fix the errors above before continuing"
+}
+
src_compile() {
myconf=""
use gif && use animgif && myconf="${myconf},ANIMGIF"