summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2003-06-26 17:25:53 +0000
committerMichael Cummings <mcummings@gentoo.org>2003-06-26 17:25:53 +0000
commit97d1106c9459f2db5de0966d1366b7de39dc0057 (patch)
treee4b14ef34120892f565783f3446778554fa53887 /dev-perl
parentmodule-build is a dep for alzabo; it's a new perl module installer (diff)
downloadgentoo-2-97d1106c9459f2db5de0966d1366b7de39dc0057.tar.gz
gentoo-2-97d1106c9459f2db5de0966d1366b7de39dc0057.tar.bz2
gentoo-2-97d1106c9459f2db5de0966d1366b7de39dc0057.zip
module-build is a dep for alzabo; it's a new perl module installer
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/module-build/ChangeLog10
-rw-r--r--dev-perl/module-build/Manifest3
-rw-r--r--dev-perl/module-build/files/digest-module-build-0.181
-rw-r--r--dev-perl/module-build/module-build-0.18.ebuild63
4 files changed, 76 insertions, 1 deletions
diff --git a/dev-perl/module-build/ChangeLog b/dev-perl/module-build/ChangeLog
new file mode 100644
index 000000000000..6331eb75d84b
--- /dev/null
+++ b/dev-perl/module-build/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-perl/module-build
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/ChangeLog,v 1.1 2003/06/26 17:25:49 mcummings Exp $
+
+*module-build-0.18 (26 Jun 2003)
+
+ 26 Jun 2003; Michael Cummings <mcummings@gentoo.org>
+ module-build-0.18.ebuild:
+ module-build is a dep for alzabo; it's a new perl module installer
+
diff --git a/dev-perl/module-build/Manifest b/dev-perl/module-build/Manifest
index 579379e06166..26cac8b8fe9a 100644
--- a/dev-perl/module-build/Manifest
+++ b/dev-perl/module-build/Manifest
@@ -1,2 +1,3 @@
-MD5 c1f3c6165c84f0bf92b607cda76ec367 module-build-0.18.ebuild 497
+MD5 6bfd1b369db2b2de3d52032721c911e6 module-build-0.18.ebuild 1777
+MD5 292781eca5cadc519d20655211637136 ChangeLog 414
MD5 46c83a840d25a11c761e0cbceae27a95 files/digest-module-build-0.18 68
diff --git a/dev-perl/module-build/files/digest-module-build-0.18 b/dev-perl/module-build/files/digest-module-build-0.18
new file mode 100644
index 000000000000..b7780008eb58
--- /dev/null
+++ b/dev-perl/module-build/files/digest-module-build-0.18
@@ -0,0 +1 @@
+MD5 18f35dc7e5751f8e56554f564293d0bc Module-Build-0.18.tar.gz 60816
diff --git a/dev-perl/module-build/module-build-0.18.ebuild b/dev-perl/module-build/module-build-0.18.ebuild
new file mode 100644
index 000000000000..2ad370cbe28f
--- /dev/null
+++ b/dev-perl/module-build/module-build-0.18.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/module-build-0.18.ebuild,v 1.1 2003/06/26 17:25:49 mcummings Exp $
+
+inherit perl-module
+
+MY_P="Module-Build-${PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Build and install Perl modules"
+SRC_URI="http://www.cpan.org/modules/by-authors/id/K/KW/KWILLIAMS/${MY_P}.tar.gz"
+HOMEPAGE="http://www.cpan.org/modules/by-authors/id/K/KW/KWILLIAMS/${MY_P}.readme"
+
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="x86 ~alpha ~arm ~hppa ~mips ~ppc ~sparc"
+
+DEPEND="dev-perl/module-info"
+
+
+src_compile() {
+ SRC_PREP="no"
+ perl ${S}/Build.PL destdir=${D}
+}
+src_test() {
+ perl ${S}/Build test
+}
+
+src_install() {
+ perlinfo
+ dodir ${POD_DIR}
+
+ test -z ${mytargets} && mytargets="install"
+ eval `perl '-V:installsitearch'`
+ SITE_ARCH=${installsitearch}
+ eval `perl '-V:installarchlib'`
+ ARCH_LIB=${installarchlib}
+ perl ${S}/Build install
+
+
+ if [ -f ${D}${ARCH_LIB}/perllocal.pod ];
+ then
+ touch ${D}/${POD_DIR}/${P}.pod
+ sed -e "s:${D}::g" \
+ ${D}${ARCH_LIB}/perllocal.pod >>${D}/${POD_DIR}/${P}.pod
+ touch ${D}/${POD_DIR}/${P}.pod.arch
+ cat ${D}/${POD_DIR}/${P}.pod >>${D}/${POD_DIR}/${P}.pod.arch
+ rm -f ${D}/${ARCH_LIB}/perllocal.pod
+ fi
+ if [ -f ${D}${SITE_LIB}/perllocal.pod ]
+ then
+ touch ${D}/${POD_DIR}/${P}.pod
+ sed -e "s:${D}::g" \
+ ${D}${SITE_LIB}/perllocal.pod >> ${D}/${POD_DIR}/${P}.pod
+ touch ${D}/${POD_DIR}/${P}.pod.site
+ cat ${D}/${POD_DIR}/${P}.pod >>${D}/${POD_DIR}/${P}.pod.site
+ rm -f ${D}/${SITE_LIB}/perllocal.pod
+ fi
+
+ for FILE in `find ${D} -type f -name "*.html" -o -name ".packlist"`; do
+ sed -i -e "s:${D}:/:g" ${FILE}
+ done
+ dodoc Change* MANIFEST* README* ${mydoc}
+}