summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-06-10 01:50:07 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-06-10 01:50:07 +0000
commit91088073cec5128dd831b20e1000007caf55b65f (patch)
tree49ec1421a172e6faa1ea4ee54a283f90c690ffb0 /dev-perl
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-91088073cec5128dd831b20e1000007caf55b65f.tar.gz
gentoo-2-91088073cec5128dd831b20e1000007caf55b65f.tar.bz2
gentoo-2-91088073cec5128dd831b20e1000007caf55b65f.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/HTML-Mason/ChangeLog8
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.42.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-perl/HTML-Mason/ChangeLog b/dev-perl/HTML-Mason/ChangeLog
index 4ca326d22b19..efda8b0e54d6 100644
--- a/dev-perl/HTML-Mason/ChangeLog
+++ b/dev-perl/HTML-Mason/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/HTML-Mason
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.85 2009/05/26 17:00:02 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.86 2009/06/10 01:50:07 robbat2 Exp $
+
+*HTML-Mason-1.42 (10 Jun 2009)
+
+ 10 Jun 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +HTML-Mason-1.42.ebuild:
+ Version bump via perl-bump experimental tool.
26 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
HTML-Mason-1.37.ebuild, HTML-Mason-1.40.ebuild:
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.42.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.42.ebuild
new file mode 100644
index 000000000000..a7af8cbb2924
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.42.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.42.ebuild,v 1.1 2009/06/10 01:50:07 robbat2 Exp $
+
+inherit depend.apache perl-module
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+SRC_URI="mirror://cpan/authors/id/D/DR/DROLSKY/${P}.tar.gz"
+HOMEPAGE="http://www.masonhq.com/"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="modperl doc"
+SRC_TEST="do"
+
+RDEPEND="!modperl? ( virtual/perl-CGI )
+ modperl? (
+ www-apache/libapreq2
+ >=www-apache/mod_perl-2
+ )
+ >=dev-perl/Params-Validate-0.7
+ >=dev-perl/Class-Container-0.08
+ >=dev-perl/Exception-Class-1.15
+ dev-perl/HTML-Parser
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-File-Spec
+ >=dev-perl/Cache-Cache-1.01
+ dev-lang/perl"
+
+DEPEND="${RDEPEND}
+ virtual/perl-Module-Build"
+
+want_apache2 modperl
+
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ perl-module_pkg_setup
+}
+
+perl-module_src_prep() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ sleep 5
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ APACHE="${APACHE_BIN}" perl ${S}/Build.PL installdirs=vendor destdir=${D} ${myconf}
+}
+
+src_install () {
+ perl-module_src_install
+ # rendhalver - the html docs have subdirs so this gets all of them
+ use doc && dohtml -r htdocs/*
+}