summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-04-30 07:31:07 +0000
committerTorsten Veller <tove@gentoo.org>2011-04-30 07:31:07 +0000
commit728b634e3ba3802edac6f40c1c5e0621181a5a1c (patch)
treef303a10a91ba0cb9c92c839ad9fdb89cc46c4a4c /dev-perl
parentVersion bump. (diff)
downloadgentoo-2-728b634e3ba3802edac6f40c1c5e0621181a5a1c.tar.gz
gentoo-2-728b634e3ba3802edac6f40c1c5e0621181a5a1c.tar.bz2
gentoo-2-728b634e3ba3802edac6f40c1c5e0621181a5a1c.zip
[bump] dev-perl/math-pari-2.10.806.50
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/math-pari/ChangeLog7
-rw-r--r--dev-perl/math-pari/math-pari-2.10.806.50.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-perl/math-pari/ChangeLog b/dev-perl/math-pari/ChangeLog
index ab57f5546e69..8ebcae527d5c 100644
--- a/dev-perl/math-pari/ChangeLog
+++ b/dev-perl/math-pari/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/math-pari
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.66 2011/04/24 15:57:27 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.67 2011/04/30 07:31:07 tove Exp $
+
+*math-pari-2.10.806.50 (30 Apr 2011)
+
+ 30 Apr 2011; Torsten Veller <tove@gentoo.org> +math-pari-2.10.806.50.ebuild:
+ Version bump
24 Apr 2011; Fabian Groffen <grobian@gentoo.org>
math-pari-2.01080604-r1.ebuild:
diff --git a/dev-perl/math-pari/math-pari-2.10.806.50.ebuild b/dev-perl/math-pari/math-pari-2.10.806.50.ebuild
new file mode 100644
index 000000000000..3cd716554cf2
--- /dev/null
+++ b/dev-perl/math-pari/math-pari-2.10.806.50.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.10.806.50.ebuild,v 1.1 2011/04/30 07:31:07 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=ILYAZ
+MODULE_SECTION=modules
+MODULE_VERSION=2.01080605
+MY_PN=Math-Pari
+inherit perl-module
+
+PARI_VER=2.3.5
+
+DESCRIPTION="Perl interface to PARI"
+SRC_URI="${SRC_URI}
+ http://pari.math.u-bordeaux.fr/pub/pari/unix/pari-${PARI_VER}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+# Math::Pari requires that a copy of the pari source in a parallel
+# directory to where you build it. It does not need to compile it, but
+# it does need to be the same version as is installed, hence the hard
+# DEPEND below
+RDEPEND="~sci-mathematics/pari-${PARI_VER}"
+DEPEND="${RDEPEND}"
+
+S_PARI=${WORKDIR}/pari-${PARI_VER}
+SRC_TEST=do
+
+src_prepare() {
+ # On 64-bit hardware, these files are needed in both the 64/ and 32/
+ # directories for the testsuite to pass.
+ cd "${S_PARI}"/src/test/
+ for t in analyz compat ellglobalred elliptic galois graph intnum kernel \
+ linear nfields number objets ploth polyser program qfbsolve rfrac \
+ round4 stark sumiter trans ; do
+ i="in/${t}"
+ o32="32/${t}"
+ o64="64/${t}"
+ [ -f "$i" -a ! -f "$o32" ] && cp -al "$i" "$o32"
+ [ -f "$i" -a ! -f "$o64" ] && cp -al "$i" "$o64"
+ done
+ perl-module_src_prepare
+}
+
+src_configure() {
+ # Unfortunately the assembly routines math-pari has for SPARC do not appear
+ # to be working at current. Perl cannot test math-pari or anything that
+ # pulls in the math-pari module as DynaLoader cannot load the resulting
+ # .so files math-pari generates. As such, we have to use the generic
+ # non-machine specific assembly methods here.
+ use sparc && myconf="${myconf} machine=none"
+
+ perl-module_src_configure
+}