summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-04-29 22:00:40 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-04-29 22:00:40 +0000
commit709f3f2a4cb61a5e8615b3daa5ad2b0ff6bc9d77 (patch)
treec72b84cc6dad6befe86cb1b3e070291fc1c8d025 /dev-perl
parentUpdated older darcs ebuilds with deps+blocks, newer ones got ghc-extra-libs d... (diff)
downloadgentoo-2-709f3f2a4cb61a5e8615b3daa5ad2b0ff6bc9d77.tar.gz
gentoo-2-709f3f2a4cb61a5e8615b3daa5ad2b0ff6bc9d77.tar.bz2
gentoo-2-709f3f2a4cb61a5e8615b3daa5ad2b0ff6bc9d77.zip
Version bump
(Portage version: 2.1.2.3)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/module-build/ChangeLog8
-rw-r--r--dev-perl/module-build/files/digest-module-build-0.28.083
-rw-r--r--dev-perl/module-build/module-build-0.28.08.ebuild30
3 files changed, 40 insertions, 1 deletions
diff --git a/dev-perl/module-build/ChangeLog b/dev-perl/module-build/ChangeLog
index 80dd0a2a377f..9283e2f8d928 100644
--- a/dev-perl/module-build/ChangeLog
+++ b/dev-perl/module-build/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/module-build
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/ChangeLog,v 1.62 2007/04/16 13:11:41 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/ChangeLog,v 1.63 2007/04/29 22:00:40 mcummings Exp $
+
+*module-build-0.28.08 (29 Apr 2007)
+
+ 29 Apr 2007; Michael Cummings <mcummings@gentoo.org>
+ +module-build-0.28.08.ebuild:
+ Version bump
*module-build-0.28.07 (16 Apr 2007)
diff --git a/dev-perl/module-build/files/digest-module-build-0.28.08 b/dev-perl/module-build/files/digest-module-build-0.28.08
new file mode 100644
index 000000000000..5bbbc431b240
--- /dev/null
+++ b/dev-perl/module-build/files/digest-module-build-0.28.08
@@ -0,0 +1,3 @@
+MD5 b8e457b1a4b72c46bcec3d9bce87329b Module-Build-0.2808.tar.gz 196525
+RMD160 eb156aef5b9bef9b56068abeb29f2596c33f92ec Module-Build-0.2808.tar.gz 196525
+SHA256 1b49bb26aef78c4a90bdb01c0ece4b033cf6dac2ad5e95e8211b59f188bb1fc1 Module-Build-0.2808.tar.gz 196525
diff --git a/dev-perl/module-build/module-build-0.28.08.ebuild b/dev-perl/module-build/module-build-0.28.08.ebuild
new file mode 100644
index 000000000000..6e08217a55a4
--- /dev/null
+++ b/dev-perl/module-build/module-build-0.28.08.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/module-build-0.28.08.ebuild,v 1.1 2007/04/29 22:00:40 mcummings Exp $
+
+inherit versionator perl-module
+
+MY_PV="$(delete_version_separator 2)"
+MY_P="Module-Build-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Build and install Perl modules"
+HOMEPAGE="http://search.cpan.org/~kwilliams/"
+SRC_URI="mirror://cpan/authors/id/K/KW/KWILLIAMS/${MY_P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+# Removing these as hard deps. They are listed as recommended in the Build.PL,
+# but end up causing a dep loop since they require module-build to be built.
+# ~mcummings 06.16.06
+PDEPEND=">=dev-perl/ExtUtils-CBuilder-0.15
+ >=dev-perl/extutils-parsexs-1.02"
+
+DEPEND="dev-lang/perl
+ dev-perl/yaml
+ test? ( dev-perl/version )
+ >=dev-perl/Archive-Tar-1.09"
+
+SRC_TEST="do"