summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-01-13 16:12:09 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-01-13 16:12:09 +0000
commit2d75329f1a8406fa5ee80e43fd8225f4f45f08d2 (patch)
treeb043dd78a663ba7576d5eafcd762b9bf58791050 /dev-perl
parentVersion bump upstream (diff)
downloadgentoo-2-2d75329f1a8406fa5ee80e43fd8225f4f45f08d2.tar.gz
gentoo-2-2d75329f1a8406fa5ee80e43fd8225f4f45f08d2.tar.bz2
gentoo-2-2d75329f1a8406fa5ee80e43fd8225f4f45f08d2.zip
Version bump
(Portage version: 2.1_pre1)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/SOAP-Lite/ChangeLog10
-rw-r--r--dev-perl/SOAP-Lite/Manifest12
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-0.66.ebuild50
-rw-r--r--dev-perl/SOAP-Lite/files/digest-SOAP-Lite-0.661
-rw-r--r--dev-perl/SVG/ChangeLog9
-rw-r--r--dev-perl/SVG/Manifest6
-rw-r--r--dev-perl/SVG/SVG-2.33.ebuild13
-rw-r--r--dev-perl/SVG/files/digest-SVG-2.331
8 files changed, 86 insertions, 16 deletions
diff --git a/dev-perl/SOAP-Lite/ChangeLog b/dev-perl/SOAP-Lite/ChangeLog
index b95162f04670..a5e8a6572bb7 100644
--- a/dev-perl/SOAP-Lite/ChangeLog
+++ b/dev-perl/SOAP-Lite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/SOAP-Lite
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.22 2005/12/30 11:57:04 mcummings Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.23 2006/01/13 16:10:08 mcummings Exp $
+
+*SOAP-Lite-0.66 (13 Jan 2006)
+
+ 13 Jan 2006; Michael Cummings <mcummings@gentoo.org>
+ +SOAP-Lite-0.66.ebuild:
+ Version bump
30 Dec 2005; <mcumming@gentoo.org> SOAP-Lite-0.60a-r1.ebuild,
-SOAP-Lite-0.60a.ebuild:
diff --git a/dev-perl/SOAP-Lite/Manifest b/dev-perl/SOAP-Lite/Manifest
index 77a90d2c1c48..27d10acbb28b 100644
--- a/dev-perl/SOAP-Lite/Manifest
+++ b/dev-perl/SOAP-Lite/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 3f23d6a6d142cd800aac8292a030b82b ChangeLog 3268
MD5 03e1610150a202705650e6a938eb8024 SOAP-Lite-0.55.ebuild 813
MD5 bccf98001439cc65a9f1173b8c52620d SOAP-Lite-0.60a-r1.ebuild 1550
+MD5 9670c3aee94122196d0c85ac76e2853b SOAP-Lite-0.66.ebuild 1446
MD5 0c6fe7b828190ad115d346daf86d4c67 files/SOAP-Lite-0.60.a.patch 652
MD5 a28ac4a4bb16719e4bd3ce3c6ab5e08b files/digest-SOAP-Lite-0.55 66
MD5 6d49bd1e5b967a5a203500df88e8c738 files/digest-SOAP-Lite-0.60a-r1 67
+MD5 d366a295adee3b17a6b73e544f3146a7 files/digest-SOAP-Lite-0.66 66
MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD4DBQFDtSCZtG5z4I8BtQoRAkwmAJdZyfOQ1DkK0blpGFIZCgCdKNnVAJ9G8e+b
-jCOfrPWoWBtFBX7S8uPlIA==
-=DlBr
------END PGP SIGNATURE-----
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-0.66.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-0.66.ebuild
new file mode 100644
index 000000000000..b0e8c8713c16
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-0.66.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/SOAP-Lite-0.66.ebuild,v 1.1 2006/01/13 16:10:08 mcummings Exp $
+
+IUSE="jabber ssl"
+
+inherit perl-module eutils
+
+MY_PV=${PV/a//}
+MY_P=SOAP-Lite-${MY_PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Provides a simple and lightweight interface to the SOAP protocol (sic) both on client and server side."
+
+SRC_URI="mirror://cpan/authors/id/B/BY/BYRNE/SOAP/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/~byrne/${P}"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+myconf="${myconf} --noprompt"
+
+# TESTS ARE DISABLED ON PURPOSE
+# This module attempts to access an external website for validation
+# of the MIME::Parser - not only is that bad practice in general,
+# but in this particular case the external site isn't even valid anymore# -mpc
+# 24/10/04
+#SRC_TEST="do"
+
+DEPEND="${DEPEND}
+ dev-perl/XML-Parser
+ dev-perl/libwww-perl
+ perl-core/libnet
+ dev-perl/MIME-Lite
+ perl-core/MIME-Base64
+ ssl? ( dev-perl/Crypt-SSLeay )
+ jabber? ( dev-perl/Net-Jabber )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ dev-perl/Compress-Zlib
+ >=dev-perl/MIME-tools-5.413"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # The author of this module put a dep for MIME::Parser 6.X - but the6.X
+ # release of MIME::Parser was a mistake during a change in maintainers on
+ # cpan. This patch alters the dependancy to the "real" stable version of
+ # MIME::Parser.
+ epatch ${FILESDIR}/SOAP-Lite-0.60.a.patch
+}
diff --git a/dev-perl/SOAP-Lite/files/digest-SOAP-Lite-0.66 b/dev-perl/SOAP-Lite/files/digest-SOAP-Lite-0.66
new file mode 100644
index 000000000000..9f211b5cfb24
--- /dev/null
+++ b/dev-perl/SOAP-Lite/files/digest-SOAP-Lite-0.66
@@ -0,0 +1 @@
+MD5 2342b450775fb0a8ca579fd1dee0d9b2 SOAP-Lite-0.66.tar.gz 236804
diff --git a/dev-perl/SVG/ChangeLog b/dev-perl/SVG/ChangeLog
index 1f1b2ffe255c..ce82c9022496 100644
--- a/dev-perl/SVG/ChangeLog
+++ b/dev-perl/SVG/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/SVG
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SVG/ChangeLog,v 1.16 2005/10/02 13:13:56 agriffis Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SVG/ChangeLog,v 1.17 2006/01/13 16:12:09 mcummings Exp $
+
+*SVG-2.33 (13 Jan 2006)
+
+ 13 Jan 2006; Michael Cummings <mcummings@gentoo.org> +SVG-2.33.ebuild:
+ Version bump
02 Oct 2005; Aron Griffis <agriffis@gentoo.org> SVG-2.32.ebuild:
Mark 2.32 stable on ia64
diff --git a/dev-perl/SVG/Manifest b/dev-perl/SVG/Manifest
index f4a95f09a119..cb9f5fb584b0 100644
--- a/dev-perl/SVG/Manifest
+++ b/dev-perl/SVG/Manifest
@@ -1,6 +1,8 @@
-MD5 481d88ccd478ad0f14fb6102be6c92c2 metadata.xml 157
MD5 87bdb7a42fdf6f7852b351587fa38e0d ChangeLog 1727
MD5 594bb430de66ad6817b5ff779fec71d2 SVG-2.28.ebuild 487
MD5 d3471e4f5d536225c6af7fe3770215ae SVG-2.32.ebuild 503
-MD5 953d794ae2f4afb8cfde6ac08f4a222a files/digest-SVG-2.32 59
+MD5 2deb570922ac5848c5d7276cf6cc867e SVG-2.33.ebuild 416
MD5 f5d64055eb535adb84f6404133c5feae files/digest-SVG-2.28 59
+MD5 953d794ae2f4afb8cfde6ac08f4a222a files/digest-SVG-2.32 59
+MD5 ed75c16240fedccf995019b184484c03 files/digest-SVG-2.33 59
+MD5 481d88ccd478ad0f14fb6102be6c92c2 metadata.xml 157
diff --git a/dev-perl/SVG/SVG-2.33.ebuild b/dev-perl/SVG/SVG-2.33.ebuild
new file mode 100644
index 000000000000..c7f5cb6c09f3
--- /dev/null
+++ b/dev-perl/SVG/SVG-2.33.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SVG/SVG-2.33.ebuild,v 1.1 2006/01/13 16:12:09 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="Perl extension for generating Scalable Vector Graphics (SVG) documents"
+SRC_URI="mirror://cpan/authors/id/R/RO/RONAN/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/~ronan/${P}/"
+IUSE=""
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
diff --git a/dev-perl/SVG/files/digest-SVG-2.33 b/dev-perl/SVG/files/digest-SVG-2.33
new file mode 100644
index 000000000000..ff515b5dc1f8
--- /dev/null
+++ b/dev-perl/SVG/files/digest-SVG-2.33
@@ -0,0 +1 @@
+MD5 80aff1f4d107bf56696653895e5eed81 SVG-2.33.tar.gz 47100