summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-04-11 18:03:55 +0000
committerTorsten Veller <tove@gentoo.org>2012-04-11 18:03:55 +0000
commitf2612882040c6091bc5c2429c11f7259784ae545 (patch)
tree4e41dd3698fa87bd44f64ceff44df8b4bc9880d4 /dev-perl/perl-tk
parentAdd ipadic license to MISC-FREE group, bug 397833. (diff)
downloadgentoo-2-f2612882040c6091bc5c2429c11f7259784ae545.tar.gz
gentoo-2-f2612882040c6091bc5c2429c11f7259784ae545.tar.bz2
gentoo-2-f2612882040c6091bc5c2429c11f7259784ae545.zip
Version bump (#411241)
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/perl-tk')
-rw-r--r--dev-perl/perl-tk/ChangeLog9
-rw-r--r--dev-perl/perl-tk/perl-tk-804.30.0.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-perl/perl-tk/ChangeLog b/dev-perl/perl-tk/ChangeLog
index 1b6e489862bd..0b69a5290241 100644
--- a/dev-perl/perl-tk/ChangeLog
+++ b/dev-perl/perl-tk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/perl-tk
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/perl-tk/ChangeLog,v 1.84 2011/11/30 18:41:29 grobian Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/perl-tk/ChangeLog,v 1.85 2012/04/11 18:03:55 tove Exp $
+
+*perl-tk-804.30.0 (11 Apr 2012)
+
+ 11 Apr 2012; Torsten Veller <tove@gentoo.org> +perl-tk-804.30.0.ebuild:
+ Version bump (#411241)
30 Nov 2011; Fabian Groffen <grobian@gentoo.org> perl-tk-804.29.0.ebuild:
Fix building on Prefix platforms, bug #385621
diff --git a/dev-perl/perl-tk/perl-tk-804.30.0.ebuild b/dev-perl/perl-tk/perl-tk-804.30.0.ebuild
new file mode 100644
index 000000000000..092e42b508fa
--- /dev/null
+++ b/dev-perl/perl-tk/perl-tk-804.30.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/perl-tk/perl-tk-804.30.0.ebuild,v 1.1 2012/04/11 18:03:55 tove Exp $
+
+EAPI=4
+
+MY_PN=Tk
+MODULE_AUTHOR=SREZIC
+MODULE_VERSION=804.030
+inherit multilib perl-module
+
+DESCRIPTION="A Perl Module for Tk"
+
+LICENSE+=" BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXft
+ media-libs/freetype
+ >=media-libs/libpng-1.4
+ virtual/jpeg"
+RDEPEND="${DEPEND}"
+
+# No test running here, requires an X server, and fails lots anyway.
+SRC_TEST="skip"
+PATCHES=( "${FILESDIR}"/xorg.patch )
+
+src_prepare() {
+ MAKEOPTS+=" -j1" #333049
+ myconf=( X11ROOT=${EPREFIX}/usr XFT=1 -I${EPREFIX}/usr/include/ -l${EPREFIX}/usr/$(get_libdir) )
+ mydoc="ToDo VERSIONS"
+
+ perl-module_src_prepare
+ # fix detection logic for Prefix, bug #385621
+ sed -i -e "s:/usr:${EPREFIX}/usr:g" myConfig || die
+ # having this around breaks with perl-module and a case-IN-sensitive fs
+ rm build || die
+}