summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-06-18 00:34:22 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-06-18 00:34:22 +0000
commit2aa9147e8f38d1c2c7c77ee8264556790c3d7f95 (patch)
tree2df25e6faf95fbd81e35e2d35f8aa2bc3b2e7a0e /dev-perl/module-build
parentAdd patch to fix strict-aliasing. (diff)
downloadgentoo-2-2aa9147e8f38d1c2c7c77ee8264556790c3d7f95.tar.gz
gentoo-2-2aa9147e8f38d1c2c7c77ee8264556790c3d7f95.tar.bz2
gentoo-2-2aa9147e8f38d1c2c7c77ee8264556790c3d7f95.zip
Bug 137118 - PDEPENDing the deps we dropped since they do add post installed functionality necessary for other tools that dep on module-build
(Portage version: 2.1)
Diffstat (limited to 'dev-perl/module-build')
-rw-r--r--dev-perl/module-build/ChangeLog9
-rw-r--r--dev-perl/module-build/files/digest-module-build-0.28-r13
-rw-r--r--dev-perl/module-build/module-build-0.28-r1.ebuild28
-rw-r--r--dev-perl/module-build/module-build-0.28.ebuild7
4 files changed, 43 insertions, 4 deletions
diff --git a/dev-perl/module-build/ChangeLog b/dev-perl/module-build/ChangeLog
index 8b83d4c450f2..f546bb34f69f 100644
--- a/dev-perl/module-build/ChangeLog
+++ b/dev-perl/module-build/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-perl/module-build
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/ChangeLog,v 1.38 2006/06/16 14:13:52 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/ChangeLog,v 1.39 2006/06/18 00:34:22 mcummings Exp $
+
+*module-build-0.28-r1 (18 Jun 2006)
+
+ 18 Jun 2006; Michael Cummings <mcummings@gentoo.org>
+ module-build-0.28.ebuild, +module-build-0.28-r1.ebuild:
+ Bug 137118 - PDEPENDing the deps we dropped since they do add post installed
+ functionality necessary for other tools that dep on module-build
16 Jun 2006; Michael Cummings <mcummings@gentoo.org>
module-build-0.28.ebuild:
diff --git a/dev-perl/module-build/files/digest-module-build-0.28-r1 b/dev-perl/module-build/files/digest-module-build-0.28-r1
new file mode 100644
index 000000000000..938aec1c3afc
--- /dev/null
+++ b/dev-perl/module-build/files/digest-module-build-0.28-r1
@@ -0,0 +1,3 @@
+MD5 8b3d9cf3eadebdfbe5847d80ed3a2d0b Module-Build-0.28.tar.gz 180076
+RMD160 d0e7136576d65150aa46a6698e882b01f203bb6a Module-Build-0.28.tar.gz 180076
+SHA256 7ebb0f57d153fa3aef302b83444ad414dddcdd3af2fcda34a8d9f95955f28b5a Module-Build-0.28.tar.gz 180076
diff --git a/dev-perl/module-build/module-build-0.28-r1.ebuild b/dev-perl/module-build/module-build-0.28-r1.ebuild
new file mode 100644
index 000000000000..c177778eff23
--- /dev/null
+++ b/dev-perl/module-build/module-build-0.28-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/module-build-0.28-r1.ebuild,v 1.1 2006/06/18 00:34:22 mcummings Exp $
+
+inherit perl-module
+
+MY_PV=${PV/26.11/2611}
+MY_P="Module-Build-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Build and install Perl modules"
+HOMEPAGE="http://search.cpan.org/~kwilliams/${MY_P}/"
+SRC_URI="mirror://cpan/authors/id/K/KW/KWILLIAMS/${MY_P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ppc ~ppc64 sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# Removing these as hard deps. They are listed as recommended in the Build.PL,
+# but end up causing a dep loop since they require module-build to be built.
+# ~mcummings 06.16.06
+PDEPEND=">=dev-perl/ExtUtils-CBuilder-0.15
+ >=dev-perl/extutils-parsexs-1.02"
+
+DEPEND="dev-perl/yaml
+ >=dev-perl/Archive-Tar-1.09"
+
+SRC_TEST="do"
diff --git a/dev-perl/module-build/module-build-0.28.ebuild b/dev-perl/module-build/module-build-0.28.ebuild
index 6519cbb578d0..76f0065684f4 100644
--- a/dev-perl/module-build/module-build-0.28.ebuild
+++ b/dev-perl/module-build/module-build-0.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/module-build-0.28.ebuild,v 1.5 2006/06/16 14:13:52 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/module-build-0.28.ebuild,v 1.6 2006/06/18 00:34:22 mcummings Exp $
inherit perl-module
@@ -19,8 +19,9 @@ IUSE=""
# Removing these as hard deps. They are listed as recommended in the Build.PL,
# but end up causing a dep loop since they require module-build to be built.
# ~mcummings 06.16.06
-#>=dev-perl/ExtUtils-CBuilder-0.15
-#>=dev-perl/extutils-parsexs-1.02
+PDEPEND=">=dev-perl/ExtUtils-CBuilder-0.15
+ >=dev-perl/extutils-parsexs-1.02"
+
DEPEND="dev-perl/yaml
>=dev-perl/Archive-Tar-1.09"