summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-12-08 02:26:03 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-12-08 02:26:03 +0000
commit4a72f5c7a73b00d738bc6945e81cf88f144da54b (patch)
tree2d61fcf7563e20b814c61bd5d9a9fb05204c8599 /dev-perl/math-pari
parentVersion bump. (diff)
downloadgentoo-2-4a72f5c7a73b00d738bc6945e81cf88f144da54b.tar.gz
gentoo-2-4a72f5c7a73b00d738bc6945e81cf88f144da54b.tar.bz2
gentoo-2-4a72f5c7a73b00d738bc6945e81cf88f144da54b.zip
Version bump.
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc5-00117-g7f0f598 x86_64)
Diffstat (limited to 'dev-perl/math-pari')
-rw-r--r--dev-perl/math-pari/ChangeLog8
-rw-r--r--dev-perl/math-pari/math-pari-2.010800.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-perl/math-pari/ChangeLog b/dev-perl/math-pari/ChangeLog
index a14351c49d9d..e0d0db9f9ba0 100644
--- a/dev-perl/math-pari/ChangeLog
+++ b/dev-perl/math-pari/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/math-pari
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.39 2008/03/28 09:10:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.40 2008/12/08 02:26:03 robbat2 Exp $
+
+*math-pari-2.010800 (08 Dec 2008)
+
+ 08 Dec 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +math-pari-2.010800.ebuild:
+ Version bump.
28 Mar 2008; Jeroen Roovers <jer@gentoo.org> math-pari-2.010709.ebuild:
Stable for HPPA too.
diff --git a/dev-perl/math-pari/math-pari-2.010800.ebuild b/dev-perl/math-pari/math-pari-2.010800.ebuild
new file mode 100644
index 000000000000..8ee5cbae3506
--- /dev/null
+++ b/dev-perl/math-pari/math-pari-2.010800.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010800.ebuild,v 1.1 2008/12/08 02:26:03 robbat2 Exp $
+
+inherit perl-module eutils
+
+MY_P="Math-Pari-${PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Perl interface to PARI"
+HOMEPAGE="http://www.cpan.org/authors/id/I/IL/ILYAZ/modules/${MY_P}.readme"
+SRC_URI="mirror://cpan/authors/id/I/IL/ILYAZ/modules/${MY_P}.tar.gz
+ http://pari.math.u-bordeaux.fr/pub/pari/unix/pari-2.1.7.tgz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+SRC_TEST="do"
+
+# Math::Pari requires that a copy of the pari source in a parallel
+# directory to where you build it. It does not need to compile it, but
+# it does need to be the same version as is installed, hence the hard
+# DEPEND below
+DEPEND="~sci-mathematics/pari-2.1.7
+ dev-lang/perl"
+
+src_compile() {
+ # Unfortunately the assembly routines math-pari has for SPARC do not appear
+ # to be working at current. Perl cannot test math-pari or anything that
+ # pulls in the math-pari module as DynaLoader cannot load the resulting
+ # .so files math-pari generates. As such, we have to use the generic
+ # non-machine specific assembly methods here.
+ use sparc && myconf="${myconf} machine=none"
+
+ perl-module_src_compile
+}