summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-05-13 10:32:47 +0000
committerTorsten Veller <tove@gentoo.org>2010-05-13 10:32:47 +0000
commitf45105c3025caa49f2090b870660c3b72aeb83aa (patch)
tree7a44fe9553b4e6ac57eb67dc8d21e1a1bab307f2 /dev-perl/libwww-perl
parentFix for new CBIN location (diff)
downloadgentoo-2-f45105c3025caa49f2090b870660c3b72aeb83aa.tar.gz
gentoo-2-f45105c3025caa49f2090b870660c3b72aeb83aa.tar.bz2
gentoo-2-f45105c3025caa49f2090b870660c3b72aeb83aa.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/libwww-perl')
-rw-r--r--dev-perl/libwww-perl/ChangeLog7
-rw-r--r--dev-perl/libwww-perl/libwww-perl-5.836.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-perl/libwww-perl/ChangeLog b/dev-perl/libwww-perl/ChangeLog
index 651efbacb376..5d25c309a8a2 100644
--- a/dev-perl/libwww-perl/ChangeLog
+++ b/dev-perl/libwww-perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/libwww-perl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.128 2010/05/08 18:14:18 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.129 2010/05/13 10:32:47 tove Exp $
+
+*libwww-perl-5.836 (13 May 2010)
+
+ 13 May 2010; Torsten Veller <tove@gentoo.org> +libwww-perl-5.836.ebuild:
+ Version bump
08 May 2010; Raúl Porcel <armin76@gentoo.org>
libwww-perl-5.834-r1.ebuild:
diff --git a/dev-perl/libwww-perl/libwww-perl-5.836.ebuild b/dev-perl/libwww-perl/libwww-perl-5.836.ebuild
new file mode 100644
index 000000000000..d0e0c73508c6
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-5.836.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.836.ebuild,v 1.1 2010/05/13 10:32:47 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=GAAS
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl"
+
+DEPEND="virtual/perl-libnet
+ >=dev-perl/HTML-Parser-3.34
+ >=dev-perl/URI-1.10
+ >=virtual/perl-Digest-MD5-2.12
+ dev-perl/HTML-Tree
+ >=virtual/perl-MIME-Base64-2.12
+ >=virtual/perl-IO-Compress-1.10
+ ssl? ( dev-perl/Crypt-SSLeay )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ perl-module_src_install
+
+ # Perform a check to see if the live filesystem is case-INsensitive
+ # or not. If it is, the symlinks GET, POST and in particular HEAD
+ # will collide with e.g. head from coreutils. While under Linux
+ # having a case-INsensitive filesystem is really unusual, most Mac
+ # OS X users are on it, and also Interix users deal with
+ # case-INsensitivity since Windows is underneath.
+
+ # bash should always be there, if we can find it in capitals, we're
+ # on a case-INsensitive filesystem.
+ if [[ ! -f ${EROOT}/BIN/BASH ]] ; then
+ dosym /usr/bin/lwp-request /usr/bin/GET
+ dosym /usr/bin/lwp-request /usr/bin/POST
+ dosym /usr/bin/lwp-request /usr/bin/HEAD
+ fi
+}
+#SRC_TEST=do