summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-02-19 11:38:54 +0000
committerTorsten Veller <tove@gentoo.org>2012-02-19 11:38:54 +0000
commitdbe649a0ab1e08850368b3bfaa06f2b3f1653df1 (patch)
tree8bac0eb1af281e692f89f677627420b5af3332d5 /dev-perl/libwww-perl
parentStable on alpha, bug #388489 (diff)
downloadgentoo-2-dbe649a0ab1e08850368b3bfaa06f2b3f1653df1.tar.gz
gentoo-2-dbe649a0ab1e08850368b3bfaa06f2b3f1653df1.tar.bz2
gentoo-2-dbe649a0ab1e08850368b3bfaa06f2b3f1653df1.zip
[bump] dev-perl/libwww-perl-6.40.0
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/libwww-perl')
-rw-r--r--dev-perl/libwww-perl/ChangeLog7
-rw-r--r--dev-perl/libwww-perl/libwww-perl-6.40.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-perl/libwww-perl/ChangeLog b/dev-perl/libwww-perl/ChangeLog
index 1e6b383043e4..775efca56a16 100644
--- a/dev-perl/libwww-perl/ChangeLog
+++ b/dev-perl/libwww-perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/libwww-perl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.159 2012/02/02 15:27:07 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.160 2012/02/19 11:38:54 tove Exp $
+
+*libwww-perl-6.40.0 (19 Feb 2012)
+
+ 19 Feb 2012; Torsten Veller <tove@gentoo.org> +libwww-perl-6.40.0.ebuild:
+ Version bump
02 Feb 2012; Torsten Veller <tove@gentoo.org> -libwww-perl-5.836.ebuild,
-libwww-perl-6.20.0.ebuild:
diff --git a/dev-perl/libwww-perl/libwww-perl-6.40.0.ebuild b/dev-perl/libwww-perl/libwww-perl-6.40.0.ebuild
new file mode 100644
index 000000000000..82108170d5fa
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-6.40.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-6.40.0.ebuild,v 1.1 2012/02/19 11:38:54 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=GAAS
+MODULE_VERSION=6.04
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl"
+
+RDEPEND="
+ >=dev-perl/File-Listing-6.0.0
+ >=dev-perl/HTTP-Cookies-6.0.0
+ >=dev-perl/HTTP-Daemon-6.0.0
+ >=dev-perl/HTTP-Date-6.0.0
+ >=dev-perl/HTTP-Negotiate-6.0.0
+ >=dev-perl/HTTP-Message-6.0.0
+ >=dev-perl/LWP-MediaTypes-6.0.0
+ >=dev-perl/Net-HTTP-6.0.0
+ >=dev-perl/WWW-RobotRules-6.0.0
+ >=virtual/perl-Digest-MD5-2.12
+ dev-perl/Encode-Locale
+ >=dev-perl/HTML-Parser-3.34
+ >=virtual/perl-MIME-Base64-2.12
+ virtual/perl-libnet
+ >=dev-perl/URI-1.10
+"
+DEPEND="${RDEPEND}"
+PDEPEND="
+ ssl? (
+ dev-perl/LWP-Protocol-https
+ )
+"
+
+src_install() {
+ perl-module_src_install
+
+ # Perform a check to see if the live filesystem is case-INsensitive
+ # or not. If it is, the symlinks GET, POST and in particular HEAD
+ # will collide with e.g. head from coreutils. While under Linux
+ # having a case-INsensitive filesystem is really unusual, most Mac
+ # OS X users are on it, and also Interix users deal with
+ # case-INsensitivity since Windows is underneath.
+
+ # bash should always be there, if we can find it in capitals, we're
+ # on a case-INsensitive filesystem.
+ if [[ ! -f ${EROOT}/BIN/BASH ]] ; then
+ dosym /usr/bin/lwp-request /usr/bin/GET
+ dosym /usr/bin/lwp-request /usr/bin/POST
+ dosym /usr/bin/lwp-request /usr/bin/HEAD
+ fi
+}
+#SRC_TEST=do