summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-03-29 07:38:58 +0000
committerTorsten Veller <tove@gentoo.org>2011-03-29 07:38:58 +0000
commit0bc97fe709aa6ec59ba4989b5034eafa525917e6 (patch)
treebb0d7f6eecffd51a883c2e7c88066abcfcd3e414 /dev-perl/libwww-perl
parentUpdate to EAPI 2, remove unused eutils eclass, and use slot deps for gtk+ and... (diff)
downloadgentoo-2-0bc97fe709aa6ec59ba4989b5034eafa525917e6.tar.gz
gentoo-2-0bc97fe709aa6ec59ba4989b5034eafa525917e6.tar.bz2
gentoo-2-0bc97fe709aa6ec59ba4989b5034eafa525917e6.zip
Version bump. Split LWP-Protocol-https
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/libwww-perl')
-rw-r--r--dev-perl/libwww-perl/ChangeLog7
-rw-r--r--dev-perl/libwww-perl/libwww-perl-6.20.0.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-perl/libwww-perl/ChangeLog b/dev-perl/libwww-perl/ChangeLog
index 7a1c5c3bb87b..ac47e44220f6 100644
--- a/dev-perl/libwww-perl/ChangeLog
+++ b/dev-perl/libwww-perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/libwww-perl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.139 2011/03/17 07:23:22 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.140 2011/03/29 07:38:58 tove Exp $
+
+*libwww-perl-6.20.0 (29 Mar 2011)
+
+ 29 Mar 2011; Torsten Veller <tove@gentoo.org> +libwww-perl-6.20.0.ebuild:
+ Version bump. Split LWP-Protocol-https
17 Mar 2011; Torsten Veller <tove@gentoo.org> -libwww-perl-6.0.0.ebuild,
libwww-perl-6.10.0.ebuild, +files/ca-certs.patch:
diff --git a/dev-perl/libwww-perl/libwww-perl-6.20.0.ebuild b/dev-perl/libwww-perl/libwww-perl-6.20.0.ebuild
new file mode 100644
index 000000000000..d70b95351451
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-6.20.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-6.20.0.ebuild,v 1.1 2011/03/29 07:38:58 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=GAAS
+MODULE_VERSION=6.02
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+RDEPEND="
+ >=dev-perl/File-Listing-6.0.0
+ >=dev-perl/HTTP-Cookies-6.0.0
+ >=dev-perl/HTTP-Daemon-6.0.0
+ >=dev-perl/HTTP-Date-6.0.0
+ >=dev-perl/HTTP-Negotiate-6.0.0
+ >=dev-perl/HTTP-Message-6.0.0
+ >=dev-perl/LWP-MediaTypes-6.0.0
+ >=dev-perl/Net-HTTP-6.0.0
+ >=dev-perl/WWW-RobotRules-6.0.0
+ >=virtual/perl-Digest-MD5-2.12
+ dev-perl/Encode-Locale
+ >=dev-perl/HTML-Parser-3.34
+ >=virtual/perl-MIME-Base64-2.12
+ virtual/perl-libnet
+ >=dev-perl/URI-1.10
+"
+DEPEND="${RDEPEND}"
+PDEPEND="
+ ssl? (
+ dev-perl/LWP-Protocol-https
+ )
+"
+
+src_install() {
+ perl-module_src_install
+
+ # Perform a check to see if the live filesystem is case-INsensitive
+ # or not. If it is, the symlinks GET, POST and in particular HEAD
+ # will collide with e.g. head from coreutils. While under Linux
+ # having a case-INsensitive filesystem is really unusual, most Mac
+ # OS X users are on it, and also Interix users deal with
+ # case-INsensitivity since Windows is underneath.
+
+ # bash should always be there, if we can find it in capitals, we're
+ # on a case-INsensitive filesystem.
+ if [[ ! -f ${EROOT}/BIN/BASH ]] ; then
+ dosym /usr/bin/lwp-request /usr/bin/GET
+ dosym /usr/bin/lwp-request /usr/bin/POST
+ dosym /usr/bin/lwp-request /usr/bin/HEAD
+ fi
+}
+#SRC_TEST=do