summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-05-02 13:30:00 +0000
committerTorsten Veller <tove@gentoo.org>2012-05-02 13:30:00 +0000
commit75f90c1beb7d09d571b24af608329427baf745c8 (patch)
tree291c030ee151774955f2d9b98c46a2c0cc8f9065 /dev-perl/XML-LibXML
parentBump to 1.4.2 (diff)
downloadgentoo-2-75f90c1beb7d09d571b24af608329427baf745c8.tar.gz
gentoo-2-75f90c1beb7d09d571b24af608329427baf745c8.tar.bz2
gentoo-2-75f90c1beb7d09d571b24af608329427baf745c8.zip
[bump] dev-perl/XML-LibXML-1.970.0
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/XML-LibXML')
-rw-r--r--dev-perl/XML-LibXML/ChangeLog7
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-1.970.0.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/dev-perl/XML-LibXML/ChangeLog b/dev-perl/XML-LibXML/ChangeLog
index 7fb995b9b54c..e6ee0f507fd2 100644
--- a/dev-perl/XML-LibXML/ChangeLog
+++ b/dev-perl/XML-LibXML/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/XML-LibXML
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/ChangeLog,v 1.132 2012/03/31 06:37:53 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/ChangeLog,v 1.133 2012/05/02 13:30:00 tove Exp $
+
+*XML-LibXML-1.970.0 (02 May 2012)
+
+ 02 May 2012; Torsten Veller <tove@gentoo.org> +XML-LibXML-1.970.0.ebuild:
+ Version bump
31 Mar 2012; Torsten Veller <tove@gentoo.org> -XML-LibXML-1.70.ebuild,
-XML-LibXML-1.950.0.ebuild:
diff --git a/dev-perl/XML-LibXML/XML-LibXML-1.970.0.ebuild b/dev-perl/XML-LibXML/XML-LibXML-1.970.0.ebuild
new file mode 100644
index 000000000000..48d8fa78a962
--- /dev/null
+++ b/dev-perl/XML-LibXML/XML-LibXML-1.970.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/XML-LibXML-1.970.0.ebuild,v 1.1 2012/05/02 13:30:00 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=SHLOMIF
+MODULE_VERSION=1.97
+inherit perl-module
+
+DESCRIPTION="A Perl module to parse XSL Transformational sheets using gnome's libXSLT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/XML-SAX-0.120.0
+ >=dev-libs/libxml2-2.6.21
+ >=dev-perl/XML-NamespaceSupport-1.70.0
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Pod
+ )
+"
+
+SRC_TEST="do"
+
+# rac can't discern any difference between the build with or without
+# this, and if somebody wants to reactivate it, get it out of global
+# scope.
+#export PERL5LIB=`perl -e 'print map { ":$ENV{D}/$_" } @INC'`
+mytargets="pure_install doc_install"
+
+src_compile() {
+ export SKIP_SAX_INSTALL=1
+ perl-module_src_compile
+}
+
+pkg_postinst() {
+ pkg_update_parser add XML::LibXML::SAX::Parser
+ pkg_update_parser add XML::LibXML::SAX
+}
+
+pkg_postrm() {
+ pkg_update_parser remove XML::LibXML::SAX::Parser
+ pkg_update_parser remove XML::LibXML::SAX
+}
+
+pkg_update_parser() {
+ # pkg_update_parser [add|remove] $parser_module
+ local action=$1
+ local parser_module=$2
+
+ if [[ "$ROOT" = "/" ]] ; then
+ einfo "Update Parser: $1 $2"
+ perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
+ || ewarn "Update Parser: $1 $2 failed"
+ else
+ elog "To $1 $2 run:"
+ elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
+ fi
+}