summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-04-24 09:50:28 +0000
committerTorsten Veller <tove@gentoo.org>2011-04-24 09:50:28 +0000
commitb13f413c04f4c2a52876e9d875100b8162f8f02e (patch)
treecdab1b213f63e017699824b5bca8a8af3b87f386 /dev-perl/WWW-Mechanize
parentMarked ~ppc-macos, ~x86-solaris (diff)
downloadgentoo-2-b13f413c04f4c2a52876e9d875100b8162f8f02e.tar.gz
gentoo-2-b13f413c04f4c2a52876e9d875100b8162f8f02e.tar.bz2
gentoo-2-b13f413c04f4c2a52876e9d875100b8162f8f02e.zip
[bump] dev-perl/WWW-Mechanize-1.680.0
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/WWW-Mechanize')
-rw-r--r--dev-perl/WWW-Mechanize/ChangeLog7
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.680.0.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-perl/WWW-Mechanize/ChangeLog b/dev-perl/WWW-Mechanize/ChangeLog
index 7b5a6d6ddff5..86233e73b50c 100644
--- a/dev-perl/WWW-Mechanize/ChangeLog
+++ b/dev-perl/WWW-Mechanize/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/WWW-Mechanize
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.77 2011/03/16 09:03:31 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.78 2011/04/24 09:50:28 tove Exp $
+
+*WWW-Mechanize-1.680.0 (24 Apr 2011)
+
+ 24 Apr 2011; Torsten Veller <tove@gentoo.org> +WWW-Mechanize-1.680.0.ebuild:
+ Version bump
16 Mar 2011; Torsten Veller <tove@gentoo.org> -WWW-Mechanize-1.60.ebuild,
-WWW-Mechanize-1.62.ebuild, -WWW-Mechanize-1.64.ebuild,
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.680.0.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.680.0.ebuild
new file mode 100644
index 000000000000..6cbfe7af59c8
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.680.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.680.0.ebuild,v 1.1 2011/04/24 09:50:28 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=JESSE
+MODULE_VERSION=1.68
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+# Bug in the tests - improper use of HTTP::Server
+SRC_TEST="do"
+
+# configure to run the local tests, but not the ones which access the Internet
+myconf="--local --nolive"
+
+RDEPEND="dev-perl/IO-Socket-SSL
+ || (
+ ( >dev-perl/libwww-perl-6 dev-perl/HTML-Form )
+ <dev-perl/libwww-perl-6
+ )
+ >=dev-perl/URI-1.36
+ >=dev-perl/HTML-Parser-3.34
+ dev-perl/Test-LongString"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/PadWalker
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Test-Exception
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Taint
+ >=dev-perl/Test-Warn-0.11
+ dev-perl/Test-Memory-Cycle )"
+# dev-perl/HTTP-Server-Simple )"
+
+# Remove test until the bug is fixed:
+# http://rt.cpan.org/Public/Bug/Display.html?id=41673
+src_prepare() {
+ mv "${S}"/t/cookies.t{,.disable} || die
+ sed -i "/cookies.t/d" "${S}/MANIFEST" || die
+ perl-module_src_prepare
+}