summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-06-01 18:26:04 +0000
committerTorsten Veller <tove@gentoo.org>2009-06-01 18:26:04 +0000
commit13b75b5e88e935022a69dc3c5e44bd7afb0579aa (patch)
treef1f1559fed0b710a0dc150448659fc91f1073c8c /dev-perl/Tk-CursorControl
parentRemove old with repoman issues. (diff)
downloadgentoo-2-13b75b5e88e935022a69dc3c5e44bd7afb0579aa.tar.gz
gentoo-2-13b75b5e88e935022a69dc3c5e44bd7afb0579aa.tar.bz2
gentoo-2-13b75b5e88e935022a69dc3c5e44bd7afb0579aa.zip
Fix bug #272083
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'dev-perl/Tk-CursorControl')
-rw-r--r--dev-perl/Tk-CursorControl/ChangeLog8
-rw-r--r--dev-perl/Tk-CursorControl/Tk-CursorControl-0.4.ebuild20
-rw-r--r--dev-perl/Tk-CursorControl/files/0.4-demo.patch12
3 files changed, 31 insertions, 9 deletions
diff --git a/dev-perl/Tk-CursorControl/ChangeLog b/dev-perl/Tk-CursorControl/ChangeLog
index fbfc71028515..7decb84133a1 100644
--- a/dev-perl/Tk-CursorControl/ChangeLog
+++ b/dev-perl/Tk-CursorControl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/Tk-CursorControl
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Tk-CursorControl/ChangeLog,v 1.10 2007/01/19 17:04:14 mcummings Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Tk-CursorControl/ChangeLog,v 1.11 2009/06/01 18:26:04 tove Exp $
+
+ 01 Jun 2009; Torsten Veller <tove@gentoo.org> +files/0.4-demo.patch,
+ Tk-CursorControl-0.4.ebuild:
+ Fix collision by renaming cursor.pl to cursor_cursor.pl(#272083)
19 Jan 2007; Michael Cummings <mcummings@gentoo.org>
Tk-CursorControl-0.4.ebuild:
diff --git a/dev-perl/Tk-CursorControl/Tk-CursorControl-0.4.ebuild b/dev-perl/Tk-CursorControl/Tk-CursorControl-0.4.ebuild
index e7829057b72a..7a769123c58f 100644
--- a/dev-perl/Tk-CursorControl/Tk-CursorControl-0.4.ebuild
+++ b/dev-perl/Tk-CursorControl/Tk-CursorControl-0.4.ebuild
@@ -1,19 +1,25 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Tk-CursorControl/Tk-CursorControl-0.4.ebuild,v 1.10 2007/01/19 17:04:14 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Tk-CursorControl/Tk-CursorControl-0.4.ebuild,v 1.11 2009/06/01 18:26:04 tove Exp $
-inherit perl-module
+MODULE_AUTHOR=DUNNIGANJ
+inherit eutils perl-module
DESCRIPTION="Manipulate the mouse cursor programmatically"
-HOMEPAGE="http://search.cpan.org/~dunniganj/"
-SRC_URI="mirror://cpan/authors/id/D/DU/DUNNIGANJ/${P}.tar.gz"
-LICENSE="|| ( Artistic GPL-2 )"
SLOT="0"
KEYWORDS="amd64 ia64 sparc x86"
IUSE=""
#SRC_TEST="do"
-DEPEND="dev-perl/perl-tk
+RDEPEND="dev-perl/perl-tk
dev-lang/perl"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PV}-demo.patch" )
+
+src_prepare() {
+ perl-module_src_prepare
+ edos2unix "{S}"/{CursorControl.pm,demos/cursor.pl} || die
+}
diff --git a/dev-perl/Tk-CursorControl/files/0.4-demo.patch b/dev-perl/Tk-CursorControl/files/0.4-demo.patch
new file mode 100644
index 000000000000..8bb70f86e42a
--- /dev/null
+++ b/dev-perl/Tk-CursorControl/files/0.4-demo.patch
@@ -0,0 +1,12 @@
+Collision with perl-tk -- bug 272083
+--- Tk-CursorControl-0.4/Makefile.PL
++++ Tk-CursorControl-0.4/Makefile.PL
+@@ -16,7 +16,7 @@
+ 'trans_cur.mask' => '$(INST_LIB)/Tk/trans_cur.mask',
+ 'demos/cursor.pl' => ($] >= 5.005
+ ? '$(INST_ARCHLIB)'
+- : '$(INST_LIB)') . '/Tk/demos/widtrib/cursor.pl',
++ : '$(INST_LIB)') . '/Tk/demos/widtrib/cursor_control.pl',
+ },
+
+ 'PREREQ_PM' => {