summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-05-23 15:07:14 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-05-23 15:07:14 +0000
commitf414ee4c0082134711e27871466625d801fb3e4e (patch)
treee8dc146da2255599633401cb27839ee1063e87f1 /dev-perl/Search-Xapian
parentVersion bump. (diff)
downloadgentoo-2-f414ee4c0082134711e27871466625d801fb3e4e.tar.gz
gentoo-2-f414ee4c0082134711e27871466625d801fb3e4e.tar.bz2
gentoo-2-f414ee4c0082134711e27871466625d801fb3e4e.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-perl/Search-Xapian')
-rw-r--r--dev-perl/Search-Xapian/ChangeLog8
-rw-r--r--dev-perl/Search-Xapian/Search-Xapian-1.2.21.0.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-perl/Search-Xapian/ChangeLog b/dev-perl/Search-Xapian/ChangeLog
index d2af527be381..f910f3b5724c 100644
--- a/dev-perl/Search-Xapian/ChangeLog
+++ b/dev-perl/Search-Xapian/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Search-Xapian
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Search-Xapian/ChangeLog,v 1.68 2015/04/20 23:45:28 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Search-Xapian/ChangeLog,v 1.69 2015/05/23 15:07:14 blueness Exp $
+
+*Search-Xapian-1.2.21.0 (23 May 2015)
+
+ 23 May 2015; Anthony G. Basile <blueness@gentoo.org>
+ +Search-Xapian-1.2.21.0.ebuild:
+ Version bump.
20 Apr 2015; Anthony G. Basile <blueness@gentoo.org> ChangeLog:
Fix gpg signiture.
diff --git a/dev-perl/Search-Xapian/Search-Xapian-1.2.21.0.ebuild b/dev-perl/Search-Xapian/Search-Xapian-1.2.21.0.ebuild
new file mode 100644
index 000000000000..02f725172f8a
--- /dev/null
+++ b/dev-perl/Search-Xapian/Search-Xapian-1.2.21.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Search-Xapian/Search-Xapian-1.2.21.0.ebuild,v 1.1 2015/05/23 15:07:14 blueness Exp $
+
+EAPI="5"
+
+MODULE_AUTHOR=OLLY
+inherit perl-module toolchain-funcs versionator
+
+VERSION=$(get_version_component_range 1-3)
+
+SRC_URI+=" http://oligarchy.co.uk/xapian/${VERSION}/${P}.tar.gz"
+DESCRIPTION="Perl XS frontend to the Xapian C++ search library"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND="~dev-libs/xapian-${VERSION}
+ !dev-libs/xapian-bindings[perl]"
+DEPEND="${RDEPEND}
+ virtual/perl-Module-Build"
+
+SRC_TEST="do"
+
+myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+
+src_install() {
+ perl-module_src_install
+
+ use examples && {
+ docinto examples
+ dodoc "${S}"/examples/*
+ }
+}