summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-08-10 15:35:45 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-08-10 15:35:45 +0000
commitff9aad8f7865186e566b6452c7b6daede2a2ed29 (patch)
tree0693f55b538a6b96a7035793e233bd6b153a1c1c /dev-perl/SOAP-Lite
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-ff9aad8f7865186e566b6452c7b6daede2a2ed29.tar.gz
gentoo-2-ff9aad8f7865186e566b6452c7b6daede2a2ed29.tar.bz2
gentoo-2-ff9aad8f7865186e566b6452c7b6daede2a2ed29.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/SOAP-Lite')
-rw-r--r--dev-perl/SOAP-Lite/ChangeLog8
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-0.712.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-perl/SOAP-Lite/ChangeLog b/dev-perl/SOAP-Lite/ChangeLog
index cb262aa7ace9..ae9b0402e7d5 100644
--- a/dev-perl/SOAP-Lite/ChangeLog
+++ b/dev-perl/SOAP-Lite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/SOAP-Lite
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.55 2010/06/27 19:19:21 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.56 2010/08/10 15:35:45 robbat2 Exp $
+
+*SOAP-Lite-0.712 (10 Aug 2010)
+
+ 10 Aug 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +SOAP-Lite-0.712.ebuild:
+ Version bump via perl-bump experimental tool.
27 Jun 2010; <nixnut@gentoo.org> SOAP-Lite-0.710.10.ebuild:
ppc stable #323529
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-0.712.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-0.712.ebuild
new file mode 100644
index 000000000000..166a5350dda4
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-0.712.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/SOAP-Lite-0.712.ebuild,v 1.1 2010/08/10 15:35:45 robbat2 Exp $
+
+MODULE_AUTHOR="MKUTTER"
+inherit perl-module eutils
+
+DESCRIPTION="Simple and lightweight interface to the SOAP protocol (sic) both on client and server side"
+
+IUSE="jabber ssl"
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+myconf="${myconf} --noprompt"
+
+# TESTS ARE DISABLED ON PURPOSE
+# This module attempts to access an external website for validation
+# of the MIME::Parser - not only is that bad practice in general,
+# but in this particular case the external site isn't even valid anymore# -mpc
+# 24/10/04
+SRC_TEST="do"
+
+DEPEND="dev-perl/XML-Parser
+ dev-perl/libwww-perl
+ virtual/perl-libnet
+ dev-perl/MIME-Lite
+ virtual/perl-MIME-Base64
+ ssl? ( dev-perl/Crypt-SSLeay )
+ jabber? ( dev-perl/Net-Jabber )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ virtual/perl-IO-Compress
+ >=dev-perl/MIME-tools-5.413
+ virtual/perl-version
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # The author of this module put a dep for MIME::Parser 6.X - but the6.X
+ # release of MIME::Parser was a mistake during a change in maintainers on
+ # cpan. This patch alters the dependancy to the "real" stable version of
+ # MIME::Parser.
+ epatch "${FILESDIR}"/SOAP-Lite-0.710.08.patch
+}
+
+src_test() {
+ has_version '>=www-apache/mod_perl-2' && export MOD_PERL_API_VERSION=2
+ perl-module_src_test
+}