summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-05-10 18:39:14 +0000
committerJeroen Roovers <jer@gentoo.org>2014-05-10 18:39:14 +0000
commit85daa010ddd226cd4d5f2a953b4ee6cf5bd44a22 (patch)
tree7864e3c8d002cfc474f346ce772bcc854e72f639 /dev-perl/SNMP_Session
parentNew package for Cinnamon 2.x (diff)
downloadgentoo-2-85daa010ddd226cd4d5f2a953b4ee6cf5bd44a22.tar.gz
gentoo-2-85daa010ddd226cd4d5f2a953b4ee6cf5bd44a22.tar.bz2
gentoo-2-85daa010ddd226cd4d5f2a953b4ee6cf5bd44a22.zip
Add fix for SNMP_Session::pack_sockaddr_in6 redefinition (bug #509986).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-perl/SNMP_Session')
-rw-r--r--dev-perl/SNMP_Session/ChangeLog8
-rw-r--r--dev-perl/SNMP_Session/SNMP_Session-1.13-r2.ebuild24
-rw-r--r--dev-perl/SNMP_Session/files/SNMP_Session-1.13-Socket6.patch20
3 files changed, 51 insertions, 1 deletions
diff --git a/dev-perl/SNMP_Session/ChangeLog b/dev-perl/SNMP_Session/ChangeLog
index 939d3b9b6dcf..903f32e52e74 100644
--- a/dev-perl/SNMP_Session/ChangeLog
+++ b/dev-perl/SNMP_Session/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/SNMP_Session
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SNMP_Session/ChangeLog,v 1.33 2014/01/11 16:20:58 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SNMP_Session/ChangeLog,v 1.34 2014/05/10 18:39:14 jer Exp $
+
+*SNMP_Session-1.13-r2 (10 May 2014)
+
+ 10 May 2014; Jeroen Roovers <jer@gentoo.org> +SNMP_Session-1.13-r2.ebuild,
+ +files/SNMP_Session-1.13-Socket6.patch:
+ Add fix for SNMP_Session::pack_sockaddr_in6 redefinition (bug #509986).
11 Jan 2014; <zlogene@gentoo.org> -SNMP_Session-1.13.ebuild,
SNMP_Session-1.13-r1.ebuild:
diff --git a/dev-perl/SNMP_Session/SNMP_Session-1.13-r2.ebuild b/dev-perl/SNMP_Session/SNMP_Session-1.13-r2.ebuild
new file mode 100644
index 000000000000..f71c800c9daf
--- /dev/null
+++ b/dev-perl/SNMP_Session/SNMP_Session-1.13-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SNMP_Session/SNMP_Session-1.13-r2.ebuild,v 1.1 2014/05/10 18:39:14 jer Exp $
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="A SNMP Perl Module"
+SRC_URI="http://snmp-session.googlecode.com/files/${P}.tar.gz"
+HOMEPAGE="http://code.google.com/p/snmp-session/"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~sparc-solaris ~x86-solaris"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Socket6.patch
+)
+
+src_install() {
+ perl-module_src_install
+ dohtml index.html
+}
diff --git a/dev-perl/SNMP_Session/files/SNMP_Session-1.13-Socket6.patch b/dev-perl/SNMP_Session/files/SNMP_Session-1.13-Socket6.patch
new file mode 100644
index 000000000000..27d8081b31cc
--- /dev/null
+++ b/dev-perl/SNMP_Session/files/SNMP_Session-1.13-Socket6.patch
@@ -0,0 +1,20 @@
+--- a/lib/SNMP_Session.pm Fri Nov 21 05:25:17 2008
++++ b/lib/SNMP_Session.pm Tue Mar 16 16:14:22 2010
+@@ -146,7 +146,7 @@ BEGIN {
+
+ if (eval {local $SIG{__DIE__};require Socket6;} &&
+ eval {local $SIG{__DIE__};require IO::Socket::INET6; IO::Socket::INET6->VERSION("1.26");}) {
+- import Socket6;
++ Socket6->import(qw(inet_pton getaddrinfo));
+ $ipv6_addr_len = length(pack_sockaddr_in6(161, inet_pton(AF_INET6(), "::1")));
+ $SNMP_Session::ipv6available = 1;
+ }
+@@ -605,7 +605,7 @@ use Carp;
+ BEGIN {
+ if($SNMP_Session::ipv6available) {
+ import IO::Socket::INET6;
+- import Socket6;
++ Socket6->import(qw(inet_pton getaddrinfo));
+ }
+ }
+