summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-10-19 16:01:59 +0000
committerAchim Gottinger <achim@gentoo.org>2000-10-19 16:01:59 +0000
commitf232ecbeb0323c9e914ae76abf1c1fd227f3d794 (patch)
tree33077c4597bb7be00ce359a1da5c7eff6e7e2eeb /dev-perl/SGMLSpm
parent*** empty log message *** (diff)
downloadgentoo-2-f232ecbeb0323c9e914ae76abf1c1fd227f3d794.tar.gz
gentoo-2-f232ecbeb0323c9e914ae76abf1c1fd227f3d794.tar.bz2
gentoo-2-f232ecbeb0323c9e914ae76abf1c1fd227f3d794.zip
*** empty log message ***
Diffstat (limited to 'dev-perl/SGMLSpm')
-rw-r--r--dev-perl/SGMLSpm/SGMLSpm-1.03.ebuild34
-rw-r--r--dev-perl/SGMLSpm/files/Makefile98
-rw-r--r--dev-perl/SGMLSpm/files/digest-SGMLSpm-1.031
3 files changed, 133 insertions, 0 deletions
diff --git a/dev-perl/SGMLSpm/SGMLSpm-1.03.ebuild b/dev-perl/SGMLSpm/SGMLSpm-1.03.ebuild
new file mode 100644
index 000000000000..76cd7d53b302
--- /dev/null
+++ b/dev-perl/SGMLSpm/SGMLSpm-1.03.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SGMLSpm/SGMLSpm-1.03.ebuild,v 1.1 2000/10/19 16:01:59 achim Exp $
+
+A=${PN}-${PV}ii.tar.gz
+S=${WORKDIR}/${PN}
+DESCRIPTION="Perl library for parsing the output of nsgmls"
+SRC_URI="ftp://cpan.perl.org/pub/perl/CPAN/modules/by-module/SGMLS/${A}"
+HOMEPAGE="ftp://cpan.perl.org/pub/perl/CPAN/modules/by-module/SGMLS/${PN}-${PV}ii.readme"
+
+
+src_unpack() {
+
+ unpack ${A}
+ cp ${FILESDIR}/Makefile ${S}
+
+}
+src_compile() {
+
+ cd ${S}
+
+}
+
+src_install () {
+
+ cd ${S}
+ dodir /usr/lib/perl5/site_perl/5.6.0/
+ dodir /usr/bin
+ dodoc BUGS DOC README TODO COPYING ChangeLog
+ try make
+
+}
+
diff --git a/dev-perl/SGMLSpm/files/Makefile b/dev-perl/SGMLSpm/files/Makefile
new file mode 100644
index 000000000000..c9f53097ad16
--- /dev/null
+++ b/dev-perl/SGMLSpm/files/Makefile
@@ -0,0 +1,98 @@
+########################################################################
+# Makefile for installing SGMLS.pm and associated files in Unix
+# or Unix-like environments. You should check the values of the
+# variables at the beginning and change them as appropriate.
+#
+# Version: 1.03ii
+########################################################################
+
+DIST = SGMLSpm-1.03ii.tar.gz
+
+#
+# Beginning of user options.
+#
+
+# Where is the binary for perl5 located on your system?
+PERL = /usr/bin/perl
+
+# Where do you want the sgmlspl executable script to be installed?
+BINDIR = ${D}/usr/bin
+
+# Where do you put local perl5 libaries?
+PERL5DIR = ${D}/usr/lib/perl5
+MODULEDIR = ${PERL5DIR}/site_perl/5.6.0/SGMLS
+
+# Where do you want to put sgmlspl specifications?
+SPECDIR = ${PERL5DIR}
+
+# If you plan to install the HTML version of the documentation, where
+# do you intend to put it? 'make html' will create two
+# subdirectories, ${HTMLDIR}/SGMLSpm and ${HTMLDIR}/sgmlspl, and place
+# its files there.
+HTMLDIR = ${D}/usr/doc/${P}/html
+
+
+#
+# End of user options.
+#
+
+HTML_SOURCES = DOC/HTML/SGMLSpm/ DOC/HTML/sgmlspl/
+
+FILES = ${BINDIR}/sgmlspl \
+ ${PERL5DIR}/SGMLS.pm \
+ ${MODULEDIR}/Output.pm \
+ ${MODULEDIR}/Refs.pm \
+ ${SPECDIR}/skel.pl
+
+all: install docs
+
+install: install_system # install_html
+
+install_system: ${MODULEDIR} ${FILES}
+
+dist: ${DIST}
+
+${BINDIR}/sgmlspl: sgmlspl.pl
+ sed -e 's!/usr/bin/perl!${PERL}!' sgmlspl.pl > ${BINDIR}/sgmlspl
+ chmod a+x,a+r ${BINDIR}/sgmlspl
+
+${PERL5DIR}/SGMLS.pm: SGMLS.pm
+ cp SGMLS.pm ${PERL5DIR}/SGMLS.pm
+ chmod a+r ${PERL5DIR}/SGMLS.pm
+
+${MODULEDIR}:
+ if [ ! -d ${MODULEDIR} ]; then\
+ mkdir ${MODULEDIR}; \
+ chmod a+x ${MODULEDIR}; \
+ fi
+
+${MODULEDIR}/Output.pm: Output.pm
+ cp Output.pm ${MODULEDIR}/Output.pm
+ chmod a+r ${MODULEDIR}/Output.pm
+
+${MODULEDIR}/Refs.pm: Refs.pm
+ cp Refs.pm ${MODULEDIR}/Refs.pm
+ chmod a+r ${MODULEDIR}/Refs.pm
+
+${SPECDIR}/skel.pl: skel.pl
+ cp skel.pl ${SPECDIR}/skel.pl
+ chmod a+r ${SPECDIR}/skel.pl
+
+install_html: ${HTML_SOURCES}
+ cd DOC; make html
+ rm -rf ${HTMLDIR}/SGMLSpm ${HTMLDIR}/sgmlspl
+ cp -r ${HTML_SOURCES} ${HTMLDIR}
+ chmod a+x,a+r ${HTMLDIR}/SGMLSpm ${HTMLDIR}/sgmlspl
+ chmod a+r ${HTMLDIR}/SGMLSpm/* ${HTMLDIR}/sgmlspl/*
+
+docs:
+ cd DOC; make all
+
+${DIST}: clean docs
+ cd ..; \
+ tar -c -v -z --exclude RCS -f /tmp/${DIST} SGMLSpm; \
+ mv /tmp/${DIST} SGMLSpm
+
+clean:
+ cd DOC; make clean
+ rm -f *~ core *.tar *.tar.gz
diff --git a/dev-perl/SGMLSpm/files/digest-SGMLSpm-1.03 b/dev-perl/SGMLSpm/files/digest-SGMLSpm-1.03
new file mode 100644
index 000000000000..aa3b0373a8da
--- /dev/null
+++ b/dev-perl/SGMLSpm/files/digest-SGMLSpm-1.03
@@ -0,0 +1 @@
+MD5 5bcb197fd42e67d51c739b1414d514a7 SGMLSpm-1.03ii.tar.gz