summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-02-19 09:08:43 +0000
committerTorsten Veller <tove@gentoo.org>2010-02-19 09:08:43 +0000
commitfa8f2658e086fd84ed710f8aeaf6e6b76c37b0b9 (patch)
treef058ca6e53c2934844df1d28b3fe02ec0d5e7b03 /dev-perl/PDL
parentVersion bump. (diff)
downloadgentoo-2-fa8f2658e086fd84ed710f8aeaf6e6b76c37b0b9.tar.gz
gentoo-2-fa8f2658e086fd84ed710f8aeaf6e6b76c37b0b9.tar.bz2
gentoo-2-fa8f2658e086fd84ed710f8aeaf6e6b76c37b0b9.zip
Version bump. Remove non-functional opengl useflag. Disable HDF and 3D modules
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/PDL')
-rw-r--r--dev-perl/PDL/ChangeLog8
-rw-r--r--dev-perl/PDL/PDL-2.4.6.ebuild91
2 files changed, 98 insertions, 1 deletions
diff --git a/dev-perl/PDL/ChangeLog b/dev-perl/PDL/ChangeLog
index 5c19d2b5e21b..e94d4e062536 100644
--- a/dev-perl/PDL/ChangeLog
+++ b/dev-perl/PDL/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/PDL
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.89 2010/02/01 17:38:27 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.90 2010/02/19 09:08:43 tove Exp $
+
+*PDL-2.4.6 (19 Feb 2010)
+
+ 19 Feb 2010; Torsten Veller <tove@gentoo.org> +PDL-2.4.6.ebuild:
+ Version bump. Remove non-functional opengl useflag. Disable HDF and 3D
+ modules. Run tests
01 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> PDL-2.4.5.ebuild:
Missing virtual/perl-PodParser depend for podselect command.
diff --git a/dev-perl/PDL/PDL-2.4.6.ebuild b/dev-perl/PDL/PDL-2.4.6.ebuild
new file mode 100644
index 000000000000..027c0a3357eb
--- /dev/null
+++ b/dev-perl/PDL/PDL-2.4.6.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.6.ebuild,v 1.1 2010/02/19 09:08:43 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=CHM
+inherit perl-module eutils multilib
+
+DESCRIPTION="PDL Perl Module"
+
+LICENSE="Artistic as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="badval fftw gsl"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ virtual/perl-Filter
+ virtual/perl-File-Spec
+ virtual/perl-PodParser
+ dev-perl/Inline
+ dev-perl/Astro-FITS-Header
+ >=dev-perl/ExtUtils-F77-1.13
+ virtual/perl-Text-Balanced
+ dev-perl/Term-ReadLine-Perl
+ gsl? ( sci-libs/gsl )
+ fftw? ( sci-libs/fftw:2.1 )"
+ #opengl? ( virtual/opengl virtual/glu )
+
+mydoc="DEPENDENCIES DEVELOPMENT MANIFEST* Release_Notes TODO"
+
+SRC_TEST="do"
+
+src_prepare() {
+ epatch "${FILESDIR}/PDL-2.4.2-makemakerfix.patch"
+
+ # Unconditional -fPIC for the lib (#55238, #180807, #250335)
+ epatch "${FILESDIR}/${PN}-2.4.4-PIC.patch"
+
+ # TODO: everything in this function below this
+ # TODO: line really belongs in src_compile() :
+
+ # This 'fix' breaks compiles for non-opengl users
+ #if ! use opengl ; then
+ # sed -e "s:WITH_3D => undef:WITH_3D => 0:" \
+ # ${FILESDIR}/perldl.conf > ${S}/perldl.conf
+ #fi
+ sed -i \
+ -e "s:WITH_HDF => undef:WITH_HDF => 0:" \
+ -e "s:USE_POGL => undef:USE_POGL => 0:" \
+ -e "s:WITH_3D => undef:WITH_3D => 0:" "${S}/perldl.conf" || die
+
+ if use badval ; then
+ sed -i -e "s:WITH_BADVAL => 0:WITH_BADVAL => 1:" "${S}/perldl.conf" || die
+ fi
+
+ # Turn off GSL automagic:
+ if use gsl ; then
+ sed -i -e "s:WITH_GSL => undef:WITH_GSL => 1:" "${S}/perldl.conf" || die
+ else
+ sed -i -e "s:WITH_GSL => undef:WITH_GSL => 0:" "${S}/perldl.conf" || die
+ fi
+ # Turn off FFTW automagic too:
+ if use fftw ; then
+ sed -i -e "s:WITH_FFTW => undef:WITH_FFTW => 1:" "${S}/perldl.conf" || die
+ else
+ sed -i -e "s:WITH_FFTW => undef:WITH_FFTW => 0:" "${S}/perldl.conf" || die
+ fi
+}
+
+src_install() {
+ perl-module_src_install
+
+ cp "${S}"/Doc/{scantree.pl,mkhtmldoc.pl} "${D}"/${VENDOR_ARCH}/PDL/Doc/ || die
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} = / ]] ; then
+ perl ${VENDOR_ARCH}/PDL/Doc/scantree.pl
+ elog "Building perldl.db done. You can recreate this at any time"
+ elog "by running"
+ else
+ elog "You must create perldl.db by running"
+ fi
+ elog "perl ${VENDOR_ARCH}/PDL/Doc/scantree.pl"
+ epause 3
+ elog "PDL requires that glx and dri support be enabled in"
+ elog "your X configuration for certain parts of the graphics"
+ elog "engine to work. See your X's documentation for futher"
+ elog "information."
+}