summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-12-13 11:54:12 +0000
committerTorsten Veller <tove@gentoo.org>2009-12-13 11:54:12 +0000
commite021ac6e1f927b89fa13683bf743ae70c3fd43b9 (patch)
tree25214d6fd9682cf1461c0b6b297ce0bbf215cdf4 /dev-perl/PDL
parentRemove all keywords from 1.9.0.11-r1 except sparc (diff)
downloadgentoo-2-e021ac6e1f927b89fa13683bf743ae70c3fd43b9.tar.gz
gentoo-2-e021ac6e1f927b89fa13683bf743ae70c3fd43b9.tar.bz2
gentoo-2-e021ac6e1f927b89fa13683bf743ae70c3fd43b9.zip
Ebuild maintainance
(Portage version: 2.2_rc58/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/PDL')
-rw-r--r--dev-perl/PDL/ChangeLog6
-rw-r--r--dev-perl/PDL/PDL-2.4.4.ebuild32
-rw-r--r--dev-perl/PDL/PDL-2.4.5.ebuild32
3 files changed, 27 insertions, 43 deletions
diff --git a/dev-perl/PDL/ChangeLog b/dev-perl/PDL/ChangeLog
index f0a9e424e184..6eff3b5784ff 100644
--- a/dev-perl/PDL/ChangeLog
+++ b/dev-perl/PDL/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/PDL
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.84 2009/11/10 10:27:04 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.85 2009/12/13 11:54:12 tove Exp $
+
+ 13 Dec 2009; Torsten Veller <tove@gentoo.org> PDL-2.4.4.ebuild,
+ PDL-2.4.5.ebuild:
+ Ebuild maintainance
*PDL-2.4.5 (10 Nov 2009)
diff --git a/dev-perl/PDL/PDL-2.4.4.ebuild b/dev-perl/PDL/PDL-2.4.4.ebuild
index 19875dbf5b0d..be1d5506466d 100644
--- a/dev-perl/PDL/PDL-2.4.4.ebuild
+++ b/dev-perl/PDL/PDL-2.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.4.ebuild,v 1.5 2009/08/10 19:57:18 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.4.ebuild,v 1.6 2009/12/13 11:54:12 tove Exp $
EAPI=2
@@ -65,29 +65,19 @@ src_prepare() {
src_install() {
perl-module_src_install
- dodir /usr/share/doc/${PF}/html
- eval `perl '-V:version'`
- PERLVERSION=${version}
- eval `perl '-V:archname'`
- ARCHVERSION=${archname}
- mv "${D}"/usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/HtmlDocs/PDL \
- "${D}"/usr/share/doc/${PF}/html
-
- mydir=${D}/usr/share/doc/${PF}/html/PDL
-
- for i in "${mydir}"/* "${mydir}"/IO/* "${mydir}"/Fit/* "${mydir}"/Pod/* "${mydir}"/Graphics/*
- do
- dosed "${i/${D}}"
- done
- cp "${S}"/Doc/scantree.pl "${D}"/usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/
- cp "${S}"/Doc/mkhtmldoc.pl "${D}"/usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/
+
+ cp "${S}"/Doc/{scantree.pl,mkhtmldoc.pl} "${D}"/${VENDOR_ARCH}/PDL/Doc/ || die
}
pkg_postinst() {
- perl /usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/scantree.pl
- elog "Building perldl.db done. You can recreate this at any time"
- elog "by running"
- elog "perl /usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/scantree.pl"
+ if [[ ${ROOT} = / ]] ; then
+ perl ${VENDOR_ARCH}/PDL/Doc/scantree.pl
+ elog "Building perldl.db done. You can recreate this at any time"
+ elog "by running"
+ else
+ elog "You must create perldl.db by running"
+ fi
+ elog "perl ${VENDOR_ARCH}/PDL/Doc/scantree.pl"
epause 3
elog "PDL requires that glx and dri support be enabled in"
elog "your X configuration for certain parts of the graphics"
diff --git a/dev-perl/PDL/PDL-2.4.5.ebuild b/dev-perl/PDL/PDL-2.4.5.ebuild
index fa1c82793b0f..c2a8d059a262 100644
--- a/dev-perl/PDL/PDL-2.4.5.ebuild
+++ b/dev-perl/PDL/PDL-2.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.5.ebuild,v 1.1 2009/11/10 10:27:04 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.5.ebuild,v 1.2 2009/12/13 11:54:12 tove Exp $
EAPI=2
@@ -65,29 +65,19 @@ src_prepare() {
src_install() {
perl-module_src_install
- dodir /usr/share/doc/${PF}/html
- eval `perl '-V:version'`
- PERLVERSION=${version}
- eval `perl '-V:archname'`
- ARCHVERSION=${archname}
- mv "${D}"/usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/HtmlDocs/PDL \
- "${D}"/usr/share/doc/${PF}/html
-
- mydir=${D}/usr/share/doc/${PF}/html/PDL
-
- for i in "${mydir}"/* "${mydir}"/IO/* "${mydir}"/Fit/* "${mydir}"/Pod/* "${mydir}"/Graphics/*
- do
- dosed "${i/${D}}"
- done
- cp "${S}"/Doc/scantree.pl "${D}"/usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/
- cp "${S}"/Doc/mkhtmldoc.pl "${D}"/usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/
+
+ cp "${S}"/Doc/{scantree.pl,mkhtmldoc.pl} "${D}"/${VENDOR_ARCH}/PDL/Doc/ || die
}
pkg_postinst() {
- perl /usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/scantree.pl
- elog "Building perldl.db done. You can recreate this at any time"
- elog "by running"
- elog "perl /usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/scantree.pl"
+ if [[ ${ROOT} = / ]] ; then
+ perl ${VENDOR_ARCH}/PDL/Doc/scantree.pl
+ elog "Building perldl.db done. You can recreate this at any time"
+ elog "by running"
+ else
+ elog "You must create perldl.db by running"
+ fi
+ elog "perl ${VENDOR_ARCH}/PDL/Doc/scantree.pl"
epause 3
elog "PDL requires that glx and dri support be enabled in"
elog "your X configuration for certain parts of the graphics"