summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-01-09 05:03:20 +0000
committerTorsten Veller <tove@gentoo.org>2010-01-09 05:03:20 +0000
commita8abdb23dc8efb19f15c03f35e3bf7208073df67 (patch)
tree97af8bc161431434a41a96c2c65e8be7e9590719 /dev-perl/PDL
parentfix digest (diff)
downloadgentoo-2-a8abdb23dc8efb19f15c03f35e3bf7208073df67.tar.gz
gentoo-2-a8abdb23dc8efb19f15c03f35e3bf7208073df67.tar.bz2
gentoo-2-a8abdb23dc8efb19f15c03f35e3bf7208073df67.zip
Readd accidentally dropped PDL-2.4.4
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'dev-perl/PDL')
-rw-r--r--dev-perl/PDL/ChangeLog7
-rw-r--r--dev-perl/PDL/PDL-2.4.4.ebuild86
2 files changed, 91 insertions, 2 deletions
diff --git a/dev-perl/PDL/ChangeLog b/dev-perl/PDL/ChangeLog
index b1249c04e823..5a89c3f64100 100644
--- a/dev-perl/PDL/ChangeLog
+++ b/dev-perl/PDL/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-perl/PDL
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.86 2009/12/24 19:40:29 tove Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.87 2010/01/09 05:03:20 tove Exp $
+
+ 09 Jan 2010; Torsten Veller <tove@gentoo.org> +PDL-2.4.4.ebuild:
+ Readd accidentally dropped PDL-2.4.4
24 Dec 2009; Torsten Veller <tove@gentoo.org> -PDL-2.4.4.ebuild:
Cleanup
diff --git a/dev-perl/PDL/PDL-2.4.4.ebuild b/dev-perl/PDL/PDL-2.4.4.ebuild
new file mode 100644
index 000000000000..0855bef853e3
--- /dev/null
+++ b/dev-perl/PDL/PDL-2.4.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.4.ebuild,v 1.8 2010/01/09 05:03:20 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=CHM
+inherit perl-module eutils multilib
+
+DESCRIPTION="PDL Perl Module"
+
+LICENSE="Artistic as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="badval fftw gsl opengl"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ virtual/perl-Filter
+ virtual/perl-File-Spec
+ dev-perl/Inline
+ dev-perl/Astro-FITS-Header
+ >=dev-perl/ExtUtils-F77-1.13
+ virtual/perl-Text-Balanced
+ opengl? ( virtual/opengl virtual/glu )
+ dev-perl/Term-ReadLine-Perl
+ gsl? ( sci-libs/gsl )
+ fftw? ( sci-libs/fftw:2.1 )"
+
+mydoc="DEPENDENCIES DEVELOPMENT MANIFEST* Release_Notes TODO"
+
+#SRC_TEST="do"
+
+src_prepare() {
+ epatch "${FILESDIR}/PDL-2.4.2-makemakerfix.patch"
+
+ # Unconditional -fPIC for the lib (#55238, #180807, #250335)
+ epatch "${FILESDIR}/${P}-PIC.patch"
+
+ # TODO: everything in this function below this
+ # TODO: line really belongs in src_compile() :
+
+ # This 'fix' breaks compiles for non-opengl users
+ #if ! use opengl ; then
+ # sed -e "s:WITH_3D => undef:WITH_3D => 0:" \
+ # ${FILESDIR}/perldl.conf > ${S}/perldl.conf
+ #fi
+
+ if use badval ; then
+ sed -i -e "s:WITH_BADVAL => 0:WITH_BADVAL => 1:" "${S}/perldl.conf"
+ fi
+
+ # Turn off GSL automagic:
+ if use gsl ; then
+ sed -i -e "s:WITH_GSL => undef:WITH_GSL => 1:" "${S}/perldl.conf"
+ else
+ sed -i -e "s:WITH_GSL => undef:WITH_GSL => 0:" "${S}/perldl.conf"
+ fi
+ # Turn off FFTW automagic too:
+ if use fftw ; then
+ sed -i -e "s:WITH_FFTW => undef:WITH_FFTW => 1:" "${S}/perldl.conf"
+ else
+ sed -i -e "s:WITH_FFTW => undef:WITH_FFTW => 0:" "${S}/perldl.conf"
+ fi
+}
+
+src_install() {
+ perl-module_src_install
+
+ cp "${S}"/Doc/{scantree.pl,mkhtmldoc.pl} "${D}"/${VENDOR_ARCH}/PDL/Doc/ || die
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} = / ]] ; then
+ perl ${VENDOR_ARCH}/PDL/Doc/scantree.pl
+ elog "Building perldl.db done. You can recreate this at any time"
+ elog "by running"
+ else
+ elog "You must create perldl.db by running"
+ fi
+ elog "perl ${VENDOR_ARCH}/PDL/Doc/scantree.pl"
+ epause 3
+ elog "PDL requires that glx and dri support be enabled in"
+ elog "your X configuration for certain parts of the graphics"
+ elog "engine to work. See your X's documentation for futher"
+ elog "information."
+}